summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2008-04-14 23:16:36 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2008-04-14 23:16:36 +0000
commit8b46978afac6c47201ecd58eae739eaaf08a9bbe (patch)
tree3cee00533eb5e477efe25c057e6c21b8b37e03f4 /sci-biology/t-coffee
parentVersion bump. (diff)
downloadgentoo-2-8b46978afac6c47201ecd58eae739eaaf08a9bbe.tar.gz
gentoo-2-8b46978afac6c47201ecd58eae739eaaf08a9bbe.tar.bz2
gentoo-2-8b46978afac6c47201ecd58eae739eaaf08a9bbe.zip
Bump.
(Portage version: 2.1.5_rc3)
Diffstat (limited to 'sci-biology/t-coffee')
-rw-r--r--sci-biology/t-coffee/ChangeLog8
-rw-r--r--sci-biology/t-coffee/t-coffee-5.65.ebuild67
2 files changed, 74 insertions, 1 deletions
diff --git a/sci-biology/t-coffee/ChangeLog b/sci-biology/t-coffee/ChangeLog
index 96fbb36f16f2..0e66d9e243f0 100644
--- a/sci-biology/t-coffee/ChangeLog
+++ b/sci-biology/t-coffee/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-biology/t-coffee
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/t-coffee/ChangeLog,v 1.28 2008/02/17 11:02:35 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/t-coffee/ChangeLog,v 1.29 2008/04/14 23:16:36 dberkholz Exp $
+
+*t-coffee-5.65 (14 Apr 2008)
+
+ 14 Apr 2008; Donnie Berkholz <dberkholz@gentoo.org>;
+ +t-coffee-5.65.ebuild:
+ Bump.
17 Feb 2008; Christian Faulhammer <opfer@gentoo.org> t-coffee-5.31.ebuild:
stable x86/amd64, bug 208416
diff --git a/sci-biology/t-coffee/t-coffee-5.65.ebuild b/sci-biology/t-coffee/t-coffee-5.65.ebuild
new file mode 100644
index 000000000000..f7c78c1f4827
--- /dev/null
+++ b/sci-biology/t-coffee/t-coffee-5.65.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/t-coffee/t-coffee-5.65.ebuild,v 1.1 2008/04/14 23:16:36 dberkholz Exp $
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="A multiple sequence alignment package"
+LICENSE="t-coffee"
+HOMEPAGE="http://www.tcoffee.org/Projects_home_page/t_coffee_home_page.html"
+SRC_URI="http://www.tcoffee.org/Packages/T-COFFEE_distribution_Version_${PV}.tar.gz"
+
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RESTRICT="mirror"
+
+DEPEND="sci-biology/clustalw"
+
+TCDIR="${WORKDIR}/T-COFFEE_distribution_Version_${PV}"
+S="${TCDIR}/t_coffee_source"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -e "s/CC = cc/CC = $(tc-getCC) ${CFLAGS}/" -i makefile || die \
+ "Failed to patch makefile."
+}
+
+die_compile() {
+ echo
+ eerror "If you experience an internal compiler error (consult the above"
+ eerror "messages), try compiling t-coffee using very modest compiler flags."
+ eerror "See bug #114745 on the Gentoo Bugzilla for more details."
+ die "Compilation failed"
+}
+
+src_compile() {
+ [[ $(gcc-version) == "3.4" ]] && append-flags -fno-unit-at-a-time
+ [[ $(gcc-version) == "4.1" ]] && append-flags -fno-unit-at-a-time
+ emake all || die_compile
+}
+
+src_install() {
+ dobin "${TCDIR}"/bin/t_coffee \
+ || die "Failed to install program."
+
+ insinto /usr/share/${PN}/lib/html
+ doins "${TCDIR}"/html/* \
+ || die "Failed to install Web interface files."
+
+ cd "${TCDIR}"/doc
+ dodoc aln_compare.doc.txt README4T-COFFEE seq_reformat.doc.txt \
+ t_coffee_technical.txt t_coffee_tutorial.txt \
+ || die "Failed to install text documentation."
+
+ dohtml t_coffee_technical.htm t_coffee_tutorial.htm \
+ || die "Failed to install HTML documentation."
+
+ insinto /usr/share/doc/${PF}
+ doins t_coffee_technical.doc t_coffee_tutorial.doc \
+ || die "Failed to install DOC documentation."
+
+ insinto /usr/share/${PN}/example
+ doins "${TCDIR}"/example/* \
+ || die "Failed to install example files."
+}