summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-03-01 17:15:20 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-03-01 17:15:20 +0000
commitac83d332213b57f0cc76ae4d7ed67a6d223814db (patch)
tree838813020608adcf19c5adf6d2c6897ea6804efa /sci-biology/t-coffee
parentUse mirror://gentoo/ for SRC_URI w.r.t. bug 260741. (diff)
downloadgentoo-2-ac83d332213b57f0cc76ae4d7ed67a6d223814db.tar.gz
gentoo-2-ac83d332213b57f0cc76ae4d7ed67a6d223814db.tar.bz2
gentoo-2-ac83d332213b57f0cc76ae4d7ed67a6d223814db.zip
Bump to 7.54. Closes #258081.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology/t-coffee')
-rw-r--r--sci-biology/t-coffee/ChangeLog9
-rw-r--r--sci-biology/t-coffee/t-coffee-7.54.ebuild58
2 files changed, 65 insertions, 2 deletions
diff --git a/sci-biology/t-coffee/ChangeLog b/sci-biology/t-coffee/ChangeLog
index 0cdccee89417..95ace70bc299 100644
--- a/sci-biology/t-coffee/ChangeLog
+++ b/sci-biology/t-coffee/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-biology/t-coffee
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/t-coffee/ChangeLog,v 1.34 2008/09/06 11:29:59 markusle Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/t-coffee/ChangeLog,v 1.35 2009/03/01 17:15:20 patrick Exp $
+
+*t-coffee-7.54 (01 Mar 2009)
+
+ 01 Mar 2009; Patrick Lauer <patrick@gentoo.org> +t-coffee-7.54.ebuild:
+ Bump to 7.54. Closes #258081.
*t-coffee-6.82 (06 Sep 2008)
diff --git a/sci-biology/t-coffee/t-coffee-7.54.ebuild b/sci-biology/t-coffee/t-coffee-7.54.ebuild
new file mode 100644
index 000000000000..3dd596d3185b
--- /dev/null
+++ b/sci-biology/t-coffee/t-coffee-7.54.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/t-coffee/t-coffee-7.54.ebuild,v 1.1 2009/03/01 17:15:20 patrick Exp $
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="A multiple sequence alignment package"
+LICENSE="GPL-2"
+HOMEPAGE="http://www.tcoffee.org/Projects_home_page/t_coffee_home_page.html"
+SRC_URI="http://www.tcoffee.org/Packages/T-COFFEE_distribution_Version_${PV}.tar.gz"
+
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="sci-biology/clustalw"
+RDEPEND="${DEPEND}"
+
+TCDIR="${WORKDIR}/T-COFFEE_distribution_Version_${PV}"
+S="${TCDIR}/t_coffee_source"
+
+die_compile() {
+ echo
+ eerror "If you experience an internal compiler error (consult the above"
+ eerror "messages), try compiling t-coffee using very modest compiler flags."
+ eerror "See bug #114745 on the Gentoo Bugzilla for more details."
+ die "Compilation failed"
+}
+
+src_compile() {
+ [[ $(gcc-version) == "3.4" ]] && append-flags -fno-unit-at-a-time
+ [[ $(gcc-version) == "4.1" ]] && append-flags -fno-unit-at-a-time
+ CC="$(tc-getCC)" CFLAGS="${CFLAGS}" emake || die_compile
+}
+
+src_install() {
+ dobin t_coffee || die "Failed to install program."
+
+ insinto /usr/share/${PN}/lib/html
+ doins "${TCDIR}"/html/* \
+ || die "Failed to install Web interface files."
+
+ cd "${TCDIR}"/doc
+ dodoc aln_compare.doc.txt seq_reformat.doc.txt \
+ t_coffee_technical.txt t_coffee_tutorial.txt \
+ || die "Failed to install text documentation."
+
+ dohtml t_coffee_technical.htm t_coffee_tutorial.htm \
+ || die "Failed to install HTML documentation."
+
+ insinto /usr/share/doc/${PF}
+ doins t_coffee_technical.doc t_coffee_tutorial.doc \
+ || die "Failed to install DOC documentation."
+
+ insinto /usr/share/${PN}/example
+ doins "${TCDIR}"/example/* \
+ || die "Failed to install example files."
+}