summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-01-06 08:46:49 +0000
committerJustin Lecher <jlec@gentoo.org>2014-01-06 08:46:49 +0000
commit5c3a9f20116b8b9daf298705eab2eb83d80ae849 (patch)
treeddbea7c75d4df6f09c094b84b104858c1b04180c /sci-biology
parentsci-biology/clustalx: Make sure only system libs are used (diff)
downloadgentoo-2-5c3a9f20116b8b9daf298705eab2eb83d80ae849.tar.gz
gentoo-2-5c3a9f20116b8b9daf298705eab2eb83d80ae849.tar.bz2
gentoo-2-5c3a9f20116b8b9daf298705eab2eb83d80ae849.zip
sci-biology/clustalw: Readd SLOT=1 ebuild; punt base.eclass usage; bump to EAPI=5
(Portage version: 2.2.8/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/clustalw/ChangeLog6
-rw-r--r--sci-biology/clustalw/clustalw-1.83-r2.ebuild36
-rw-r--r--sci-biology/clustalw/clustalw-1.83-r3.ebuild36
3 files changed, 77 insertions, 1 deletions
diff --git a/sci-biology/clustalw/ChangeLog b/sci-biology/clustalw/ChangeLog
index c753f3a6aad7..55e051f5dd42 100644
--- a/sci-biology/clustalw/ChangeLog
+++ b/sci-biology/clustalw/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-biology/clustalw
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/clustalw/ChangeLog,v 1.29 2014/01/06 08:25:30 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/clustalw/ChangeLog,v 1.30 2014/01/06 08:46:49 jlec Exp $
+
+ 06 Jan 2014; Justin Lecher <jlec@gentoo.org> +clustalw-1.83-r2.ebuild,
+ +clustalw-1.83-r3.ebuild:
+ Readd SLOT=1 ebuild; punt base.eclass usage; bump to EAPI=5
06 Jan 2014; Justin Lecher <jlec@gentoo.org> -clustalw-1.83-r2.ebuild,
-clustalw-1.83-r3.ebuild, -clustalw-2.0.11.ebuild, -clustalw-2.0.12.ebuild:
diff --git a/sci-biology/clustalw/clustalw-1.83-r2.ebuild b/sci-biology/clustalw/clustalw-1.83-r2.ebuild
new file mode 100644
index 000000000000..7bdebde52f3c
--- /dev/null
+++ b/sci-biology/clustalw/clustalw-1.83-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/clustalw/clustalw-1.83-r2.ebuild,v 1.6 2014/01/06 08:46:49 jlec Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="General purpose multiple alignment program for DNA and proteins"
+HOMEPAGE="http://www.embl-heidelberg.de/~seqanal/"
+SRC_URI="ftp://ftp.ebi.ac.uk/pub/software/unix/clustalw/${PN}${PV}.UNIX.tar.gz"
+
+LICENSE="clustalw"
+SLOT="1"
+KEYWORDS="alpha amd64 ppc ppc64 sparc x86"
+IUSE=""
+
+S="${WORKDIR}"/${PN}${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i -e "s/CC = cc/CC = $(tc-getCC)/" \
+ -e "s/CFLAGS = -c -O/CFLAGS = -c ${CFLAGS}/" \
+ -e "s/LFLAGS = -O -lm/LFLAGS = -lm ${CFLAGS}/" makefile || die
+ sed -i -e "s%clustalw_help%/usr/share/doc/${PF}/clustalw_help%" clustalw.c || die
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ dobin clustalw || die
+ dodoc README clustalv.doc clustalw.doc clustalw.ms
+ insinto /usr/share/doc/${PF}
+ doins clustalw_help
+}
diff --git a/sci-biology/clustalw/clustalw-1.83-r3.ebuild b/sci-biology/clustalw/clustalw-1.83-r3.ebuild
new file mode 100644
index 000000000000..a60e97100862
--- /dev/null
+++ b/sci-biology/clustalw/clustalw-1.83-r3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/clustalw/clustalw-1.83-r3.ebuild,v 1.4 2014/01/06 08:46:49 jlec Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="General purpose multiple alignment program for DNA and proteins"
+HOMEPAGE="http://www.embl-heidelberg.de/~seqanal/"
+SRC_URI="ftp://ftp.ebi.ac.uk/pub/software/unix/clustalw/${PN}${PV}.UNIX.tar.gz"
+
+LICENSE="clustalw"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
+IUSE=""
+
+S="${WORKDIR}"/${PN}${PV}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-as-needed.patch
+
+ sed \
+ -e "/^CC/s:cc:$(tc-getCC):g" \
+ -i makefile || die
+ sed \
+ -e "s%clustalw_help%/usr/share/doc/${PF}/clustalw_help%" \
+ -i clustalw.c || die
+}
+
+src_install() {
+ dobin clustalw
+ dodoc README clustalv.doc clustalw.doc clustalw.ms
+ insinto /usr/share/doc/${PF}
+ doins clustalw_help
+}