summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-07-14 02:21:54 +0000
committerMike Frysinger <vapier@gentoo.org>2005-07-14 02:21:54 +0000
commit72653c42589129c946d12962e4bd2f8a9f96f51d (patch)
tree5629ac85e798ddcc2b8ba80f0889d56e21d4f81b /sci-calculators/pcalc
parentadd small hack to unlink the temp file in case lex parsing failed (diff)
downloadgentoo-2-72653c42589129c946d12962e4bd2f8a9f96f51d.tar.gz
gentoo-2-72653c42589129c946d12962e4bd2f8a9f96f51d.tar.bz2
gentoo-2-72653c42589129c946d12962e4bd2f8a9f96f51d.zip
fix building with newer flex
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'sci-calculators/pcalc')
-rw-r--r--sci-calculators/pcalc/files/pcalc-1.0.0-flex.patch24
-rw-r--r--sci-calculators/pcalc/pcalc-1.0.0-r1.ebuild3
2 files changed, 26 insertions, 1 deletions
diff --git a/sci-calculators/pcalc/files/pcalc-1.0.0-flex.patch b/sci-calculators/pcalc/files/pcalc-1.0.0-flex.patch
new file mode 100644
index 000000000000..a34c2c604725
--- /dev/null
+++ b/sci-calculators/pcalc/files/pcalc-1.0.0-flex.patch
@@ -0,0 +1,24 @@
+Tweaks so pcalc will build with flex 2.5.4a and 2.5.31.
+
+Patch by Mike Frysinger <vapier@gentoo.org>
+
+--- pcalcl.l
++++ pcalcl.l
+@@ -15,8 +15,6 @@
+ extern YYSTYPE yylval;
+ extern int lineno;
+
+-/* default yywrap function - always treat EOF as an EOF */
+-#define yywrap() 1
+
+
+ char *name;
+--- Makefile
++++ Makefile
+@@ -36,5 +36,5 @@
+
+ pcalc: $(OB0) $(OB1) $(OB2) $(OB3) $(OB4) $(OB5) $(OB6) $(OB7) $(OB8) $(OB9)
+- $(CC) $(CFLAGS) $(OB0) $(OB1) $(OB2) $(OB3) $(OB4) $(OB5) $(OB6) $(OB7) $(OB8) $(OB9) -o pcalc -lm
++ $(CC) $(CFLAGS) $(OB0) $(OB1) $(OB2) $(OB3) $(OB4) $(OB5) $(OB6) $(OB7) $(OB8) $(OB9) -o pcalc -lm -lfl
+
+ pcalc.c: pcalc.y
diff --git a/sci-calculators/pcalc/pcalc-1.0.0-r1.ebuild b/sci-calculators/pcalc/pcalc-1.0.0-r1.ebuild
index 04b59ba4d32e..fc9513309ac2 100644
--- a/sci-calculators/pcalc/pcalc-1.0.0-r1.ebuild
+++ b/sci-calculators/pcalc/pcalc-1.0.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-calculators/pcalc/pcalc-1.0.0-r1.ebuild,v 1.2 2005/06/24 11:23:56 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/pcalc/pcalc-1.0.0-r1.ebuild,v 1.3 2005/07/14 02:21:54 vapier Exp $
inherit eutils
@@ -31,6 +31,7 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-usage.patch
epatch "${FILESDIR}"/${P}-string-overflow-checks.patch
epatch "${FILESDIR}"/${P}-duplicated-case.patch
+ epatch "${FILESDIR}"/${P}-flex.patch
}
src_test() {