summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2008-10-11 17:29:21 +0000
committerMarkus Dittrich <markusle@gentoo.org>2008-10-11 17:29:21 +0000
commit56a0528c2648bbf78e97e22d0774f73e3e13c498 (patch)
treed427d0d29743b198f97d2b20f43c7a7c150ed96a /sci-chemistry/apbs
parentppc stable, bug #231831 (diff)
downloadgentoo-2-56a0528c2648bbf78e97e22d0774f73e3e13c498.tar.gz
gentoo-2-56a0528c2648bbf78e97e22d0774f73e3e13c498.tar.bz2
gentoo-2-56a0528c2648bbf78e97e22d0774f73e3e13c498.zip
Version bump to pull in updated patch fixing bad install location for docs (see bug #241316). Added patch for ignored LDFLAGS.
(Portage version: 2.2_rc11/cvs/Linux 2.6.26-SENTINEL-2 i686)
Diffstat (limited to 'sci-chemistry/apbs')
-rw-r--r--sci-chemistry/apbs/ChangeLog11
-rw-r--r--sci-chemistry/apbs/apbs-1.0.0-r1.ebuild (renamed from sci-chemistry/apbs/apbs-1.0.0.ebuild)11
-rw-r--r--sci-chemistry/apbs/files/apbs-1.0.0-LDFLAGS.patch21
-rw-r--r--sci-chemistry/apbs/files/apbs-1.0.0-install-fix.patch27
4 files changed, 54 insertions, 16 deletions
diff --git a/sci-chemistry/apbs/ChangeLog b/sci-chemistry/apbs/ChangeLog
index 71d140fdbafe..eb5edced8ded 100644
--- a/sci-chemistry/apbs/ChangeLog
+++ b/sci-chemistry/apbs/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sci-chemistry/apbs
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/ChangeLog,v 1.18 2008/04/29 22:21:19 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/ChangeLog,v 1.19 2008/10/11 17:29:20 markusle Exp $
+
+*apbs-1.0.0-r1 (11 Oct 2008)
+
+ 11 Oct 2008; Markus Dittrich <markusle@gentoo.org>
+ +files/apbs-1.0.0-LDFLAGS.patch,
+ files/apbs-1.0.0-install-fix.patch, -apbs-1.0.0.ebuild,
+ +apbs-1.0.0-r1.ebuild:
+ Version bump to pull in updated patch fixing bad install location
+ for docs (see bug #241316). Added patch for ignored LDFLAGS.
*apbs-1.0.0 (29 Apr 2008)
diff --git a/sci-chemistry/apbs/apbs-1.0.0.ebuild b/sci-chemistry/apbs/apbs-1.0.0-r1.ebuild
index 03a1e0073e1e..61d74bfa4e7a 100644
--- a/sci-chemistry/apbs/apbs-1.0.0.ebuild
+++ b/sci-chemistry/apbs/apbs-1.0.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/apbs-1.0.0.ebuild,v 1.2 2008/04/30 01:18:01 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/apbs-1.0.0-r1.ebuild,v 1.1 2008/10/11 17:29:20 markusle Exp $
inherit eutils fortran autotools
@@ -35,15 +35,12 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-openmpi.patch
epatch "${FILESDIR}"/${P}-install-fix.patch
epatch "${FILESDIR}"/${P}-libmaloc-noinstall.patch
-
- sed -e "s:GENTOO_PKG_NAME:${PN}:" -i Makefile.am \
- || die "Failed to fix Makefile.am"
-
+ epatch "${FILESDIR}"/${P}-LDFLAGS.patch
eautoreconf
}
src_compile() {
- local myconf
+ local myconf="--docdir=/usr/share/doc/${PF}"
use blas && myconf="${myconf} --with-blas=-lblas"
# check which mpi version is installed and tell configure
@@ -72,4 +69,6 @@ src_test() {
src_install() {
make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS INSTALL README NEWS ChangeLog \
+ || die "Failed to install docs"
}
diff --git a/sci-chemistry/apbs/files/apbs-1.0.0-LDFLAGS.patch b/sci-chemistry/apbs/files/apbs-1.0.0-LDFLAGS.patch
new file mode 100644
index 000000000000..4fde1c4883b0
--- /dev/null
+++ b/sci-chemistry/apbs/files/apbs-1.0.0-LDFLAGS.patch
@@ -0,0 +1,21 @@
+diff -Naur apbs-1.0.0-source/tools/python/Makefile.am apbs-1.0.0-source.new/tools/python/Makefile.am
+--- apbs-1.0.0-source/tools/python/Makefile.am 2008-04-17 16:41:08.000000000 -0400
++++ apbs-1.0.0-source.new/tools/python/Makefile.am 2008-10-11 11:54:17.000000000 -0400
+@@ -15,5 +15,5 @@
+
+ noinst_PROGRAMS = _apbslib.so
+ _apbslib_so_SOURCES = apbslib.c
+-_apbslib_so_LINK = $(PY_CC) $(PY_LINKFLAGS) -o $@ $(PY_SHARED)
++_apbslib_so_LINK = $(PY_CC) $(PY_LINKFLAGS) $(LDFLAGS) -o $@ $(PY_SHARED)
+ _apbslib_so_LDADD = ${top_builddir}/bin/.libs/libapbsmainroutines.a ${top_builddir}/src/aaa_lib/.libs/libapbs.a ${top_builddir}/contrib/lib/libmaloc.a $(PY_LDFLAGS)
+diff -Naur apbs-1.0.0-source/tools/python/vgrid/Makefile.am apbs-1.0.0-source.new/tools/python/vgrid/Makefile.am
+--- apbs-1.0.0-source/tools/python/vgrid/Makefile.am 2008-04-17 16:41:08.000000000 -0400
++++ apbs-1.0.0-source.new/tools/python/vgrid/Makefile.am 2008-10-11 12:02:02.000000000 -0400
+@@ -15,6 +15,6 @@
+ if PY_PRESENT
+ noinst_PROGRAMS = _vgrid.so
+ _vgrid_so_SOURCES = vgridlib.c
+- _vgrid_so_LINK = $(PY_CC) $(PY_LINKFLAGS) -o $@ $(PY_SHARED)
++ _vgrid_so_LINK = $(PY_CC) $(PY_LINKFLAGS) $(LDFLAGS) -o $@ $(PY_SHARED)
+ _vgrid_so_LDADD = ${top_builddir}/bin/.libs/libapbsmainroutines.a ${top_builddir}/src/aaa_lib/.libs/libapbs.a $(PY_LDFLAGS) ${top_builddir}/contrib/lib/libmaloc.a @lib_list@
+ endif
diff --git a/sci-chemistry/apbs/files/apbs-1.0.0-install-fix.patch b/sci-chemistry/apbs/files/apbs-1.0.0-install-fix.patch
index d9c5a808f0fe..6efd4e16a1f5 100644
--- a/sci-chemistry/apbs/files/apbs-1.0.0-install-fix.patch
+++ b/sci-chemistry/apbs/files/apbs-1.0.0-install-fix.patch
@@ -1,7 +1,16 @@
diff -Naur apbs-1.0.0-source/Makefile.am apbs-1.0.0-source.new/Makefile.am
--- apbs-1.0.0-source/Makefile.am 2008-04-17 16:44:51.000000000 -0400
-+++ apbs-1.0.0-source.new/Makefile.am 2008-04-28 18:51:14.000000000 -0400
-@@ -28,7 +28,10 @@
++++ apbs-1.0.0-source.new/Makefile.am 2008-10-11 13:02:42.000000000 -0400
+@@ -16,6 +16,8 @@
+
+ SUBDIRS = contrib src bin @apbs_do_tools@
+
++example_dir = $(datarootdir)/@PACKAGE@
++
+ distclean-local: clean-local
+
+ clean-local: clean-ac
+@@ -28,7 +30,10 @@
-rm -f ./bin/apbs
install-data-local:
@@ -9,10 +18,10 @@ diff -Naur apbs-1.0.0-source/Makefile.am apbs-1.0.0-source.new/Makefile.am
- -cp -rf examples ${prefix}/share
- -cp -rf doc ${prefix}/share
- -cp -rf tools ${prefix}/share
-+ mkdir -p $(DESTDIR)${prefix}/share/GENTOO_PKG_NAME/examples
-+ mkdir -p $(DESTDIR)${prefix}/share/GENTOO_PKG_NAME/tools
-+ -rm -f doc/LICENSE.txt
-+ -rm -f tools/manip/*.pyc
-+ -cp -rf doc $(DESTDIR)${prefix}/share
-+ -cp -rf examples $(DESTDIR)${prefix}/share/GENTOO_PKG_NAME/
-+ -cp -rf tools $(DESTDIR)${prefix}/share/GENTOO_PKG_NAME/
++ $(mkinstalldirs) $(DESTDIR)$(docdir)
++ $(mkinstalldirs) $(DESTDIR)$(example_dir)/examples
++ $(mkinstalldirs) $(DESTDIR)$(example_dir)/tools
++ rm -f doc/LICENSE.txt doc/README
++ -cp -rf doc $(DESTDIR)$(docdir)/html
++ -cp -rf examples/* $(DESTDIR)$(example_dir)/examples
++ -cp -rf tools/* $(DESTDIR)$(example_dir)/tools