summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-02-21 09:56:35 +0000
committerJustin Lecher <jlec@gentoo.org>2010-02-21 09:56:35 +0000
commita7b9b5bc127daf19e15a3acddc95896524207830 (patch)
tree0ea0bf07296b603aa1283eccd244bbeb15d97393 /sci-chemistry/caver
parentBump (diff)
downloadgentoo-2-a7b9b5bc127daf19e15a3acddc95896524207830.tar.gz
gentoo-2-a7b9b5bc127daf19e15a3acddc95896524207830.tar.bz2
gentoo-2-a7b9b5bc127daf19e15a3acddc95896524207830.zip
EAPI=3, keywording for {amd64,x86}-linux and make it work
(Portage version: 2.2_rc63/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/caver')
-rw-r--r--sci-chemistry/caver/ChangeLog8
-rw-r--r--sci-chemistry/caver/caver-2.0.003-r1.ebuild65
-rw-r--r--sci-chemistry/caver/caver-2.0.003.ebuild9
3 files changed, 77 insertions, 5 deletions
diff --git a/sci-chemistry/caver/ChangeLog b/sci-chemistry/caver/ChangeLog
index b717b8732f09..d44c3a63f481 100644
--- a/sci-chemistry/caver/ChangeLog
+++ b/sci-chemistry/caver/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/caver
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/caver/ChangeLog,v 1.13 2010/02/12 17:29:36 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/caver/ChangeLog,v 1.14 2010/02/21 09:56:35 jlec Exp $
+
+*caver-2.0.003-r1 (21 Feb 2010)
+
+ 21 Feb 2010; Justin Lecher (jlec) <jlec@gentoo.org>
+ +caver-2.0.003-r1.ebuild:
+ EAPI=3, keywording for {amd64,x86}-linux
*caver-2.0.003 (12 Feb 2010)
diff --git a/sci-chemistry/caver/caver-2.0.003-r1.ebuild b/sci-chemistry/caver/caver-2.0.003-r1.ebuild
new file mode 100644
index 000000000000..3a91b8a21abb
--- /dev/null
+++ b/sci-chemistry/caver/caver-2.0.003-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/caver/caver-2.0.003-r1.ebuild,v 1.1 2010/02/21 09:56:35 jlec Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit multilib python eutils versionator java-utils-2
+
+MY_PV="$(replace_version_separator 2 -v $(replace_version_separator 1 _ ${PV}))"
+MY_P="${PN}${MY_PV}_pymol_plugin"
+
+DESCRIPTION="Calculation of pathways from buried cavities to outside solvent in protein structures"
+HOMEPAGE="http://loschmidt.chemi.muni.cz/caver/"
+SRC_URI="${MY_P}.zip"
+
+LICENSE="CAVER"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ >=virtual/jre-1.6
+ sci-chemistry/pymol"
+DEPEND="app-arch/unzip"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+
+RESTRICT="fetch"
+
+S="${WORKDIR}/Caver${MY_PV}"/linux_mac
+
+pkg_nofetch() {
+ elog "Download ${MY_P}.tar.gz"
+ elog "from ${HOMEPAGE}. This requires registration."
+ elog "Place tarballs in ${DISTDIR}."
+}
+
+src_prepare() {
+ python_copy_sources --no-link
+}
+
+src_install() {
+ java-pkg_dojar Caver$(replace_all_version_separators _ ${PV})/*.jar
+
+ java-pkg_jarinto /usr/share/${PN}/lib/lib/
+ java-pkg_dojar Caver$(replace_all_version_separators _ ${PV})/lib/*.jar
+
+ installation() {
+ sed \
+ -e "s:directory/where/jar/with/plugin/is/located:${EPREFIX}/usr/share/${PN}/lib/:g" \
+ -i Caver$(replace_all_version_separators _ ${PV}).py || die
+
+ insinto $(python_get_sitedir)/pmg_tk/startup/
+ doins Caver$(replace_all_version_separators _ ${PV}).py || die
+ }
+ python_execute_function -s installation
+}
+
+pkg_postinst() {
+ python_mod_optimize pmg_tk/startup/Caver$(replace_all_version_separators _ ${PV}).py
+}
+
+pkg_postrm() {
+ python_mod_cleanup pmg_tk/startup/Caver$(replace_all_version_separators _ ${PV}).py
+}
diff --git a/sci-chemistry/caver/caver-2.0.003.ebuild b/sci-chemistry/caver/caver-2.0.003.ebuild
index daceb7b5e283..e84e6d984cf6 100644
--- a/sci-chemistry/caver/caver-2.0.003.ebuild
+++ b/sci-chemistry/caver/caver-2.0.003.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/caver/caver-2.0.003.ebuild,v 1.1 2010/02/12 17:29:36 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/caver/caver-2.0.003.ebuild,v 1.2 2010/02/21 09:56:35 jlec Exp $
EAPI="2"
SUPPORT_PYTHON_ABIS="1"
@@ -23,6 +23,7 @@ RDEPEND="
>=virtual/jre-1.6
sci-chemistry/pymol"
DEPEND="app-arch/unzip"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
RESTRICT="fetch"
@@ -41,7 +42,7 @@ src_prepare() {
src_install() {
java-pkg_dojar Caver$(replace_all_version_separators _ ${PV})/*.jar
- java-pkg_jarinto /usr/share/${PN}/lib/
+ java-pkg_jarinto /usr/share/${PN}/lib/lib/
java-pkg_dojar Caver$(replace_all_version_separators _ ${PV})/lib/*.jar
installation() {
@@ -56,9 +57,9 @@ src_install() {
}
pkg_postinst() {
- python_mod_optimize ${PN}
+ python_mod_optimize pmg_tk/startup/Caver$(replace_all_version_separators _ ${PV}).py
}
pkg_postrm() {
- python_mod_cleanup ${PN}
+ python_mod_cleanup pmg_tk/startup/Caver$(replace_all_version_separators _ ${PV}).py
}