summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-01-10 17:41:33 +0000
committerJustin Lecher <jlec@gentoo.org>2013-01-10 17:41:33 +0000
commitc1bad902a7aa4889bf10195d2c0f65e33f08a67f (patch)
treee13aa44a69e87cc1fc6880fe549c459c852bed60 /sci-chemistry/ccpn
parentUpgraded test suite to ensure testing by use of the in source built content, ... (diff)
downloadgentoo-2-c1bad902a7aa4889bf10195d2c0f65e33f08a67f.tar.gz
gentoo-2-c1bad902a7aa4889bf10195d2c0f65e33f08a67f.tar.bz2
gentoo-2-c1bad902a7aa4889bf10195d2c0f65e33f08a67f.zip
sci-chemistry/ccpn: Todays python patches
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'sci-chemistry/ccpn')
-rw-r--r--sci-chemistry/ccpn/ChangeLog12
-rw-r--r--sci-chemistry/ccpn/ccpn-2.2.2_p120912.ebuild180
-rw-r--r--sci-chemistry/ccpn/ccpn-2.2.2_p121012.ebuild180
-rw-r--r--sci-chemistry/ccpn/ccpn-2.2.2_p121112.ebuild180
-rw-r--r--sci-chemistry/ccpn/ccpn-2.2.2_p121119.ebuild180
-rw-r--r--sci-chemistry/ccpn/ccpn-2.2.2_p130110.ebuild (renamed from sci-chemistry/ccpn/ccpn-2.2.2_p120829.ebuild)22
-rw-r--r--sci-chemistry/ccpn/metadata.xml14
7 files changed, 25 insertions, 743 deletions
diff --git a/sci-chemistry/ccpn/ChangeLog b/sci-chemistry/ccpn/ChangeLog
index 7f52a849ce96..c0dc7ce3b597 100644
--- a/sci-chemistry/ccpn/ChangeLog
+++ b/sci-chemistry/ccpn/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-chemistry/ccpn
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccpn/ChangeLog,v 1.99 2012/11/25 09:16:31 jlec Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccpn/ChangeLog,v 1.100 2013/01/10 17:41:33 jlec Exp $
+
+*ccpn-2.2.2_p130110 (10 Jan 2013)
+
+ 10 Jan 2013; Justin Lecher <jlec@gentoo.org> -ccpn-2.2.2_p120829.ebuild,
+ -ccpn-2.2.2_p120912.ebuild, -ccpn-2.2.2_p121012.ebuild,
+ -ccpn-2.2.2_p121112.ebuild, -ccpn-2.2.2_p121119.ebuild,
+ +ccpn-2.2.2_p130110.ebuild, metadata.xml:
+ Todays python patches
*ccpn-2.2.2_p121125 (25 Nov 2012)
diff --git a/sci-chemistry/ccpn/ccpn-2.2.2_p120912.ebuild b/sci-chemistry/ccpn/ccpn-2.2.2_p120912.ebuild
deleted file mode 100644
index 95938b6ad10a..000000000000
--- a/sci-chemistry/ccpn/ccpn-2.2.2_p120912.ebuild
+++ /dev/null
@@ -1,180 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccpn/ccpn-2.2.2_p120912.ebuild,v 1.1 2012/09/12 11:26:07 jlec Exp $
-
-EAPI=4
-
-PYTHON_DEPEND="2:2.5"
-PYTHON_USE_WITH="ssl tk"
-
-inherit eutils portability python toolchain-funcs versionator
-
-PATCHSET="${PV##*_p}"
-MY_PN="${PN}mr"
-MY_PV="$(replace_version_separator 3 _ ${PV%%_p*})"
-MY_MAJOR="$(get_version_component_range 1-3)"
-
-DESCRIPTION="The Collaborative Computing Project for NMR"
-SRC_URI="http://www-old.ccpn.ac.uk/download/${MY_PN}/analysis${MY_PV}.tar.gz"
- [[ -n ${PATCHSET} ]] && SRC_URI="${SRC_URI} http://dev.gentoo.org/~jlec/distfiles/ccpn-update-${MY_MAJOR}-${PATCHSET}.patch.xz"
-HOMEPAGE="http://www.ccpn.ac.uk/ccpn"
-
-SLOT="0"
-LICENSE="|| ( CCPN LGPL-2.1 )"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="extendnmr +opengl"
-
-RDEPEND="
- dev-lang/tk[threads]
- dev-python/numpy
- dev-tcltk/tix
- =sci-libs/ccpn-data-"${MY_MAJOR}"*
- sci-biology/psipred
- x11-libs/libXext
- x11-libs/libX11
- opengl? (
- media-libs/freeglut
- dev-python/pyglet )"
-# We need to fix this
-# sci-chemistry/mdd
-DEPEND="${RDEPEND}"
-PDEPEND="
- extendnmr? (
- >=sci-chemistry/aria-2.3.2-r1
- sci-chemistry/prodecomp )"
-
-RESTRICT="mirror"
-
-S="${WORKDIR}"/${MY_PN}/${MY_PN}$(get_version_component_range 1-2 ${PV})
-
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
-}
-
-src_prepare() {
- [[ -n ${PATCHSET} ]] && \
- epatch "${WORKDIR}"/ccpn-update-${MY_MAJOR}-${PATCHSET}.patch
-
- epatch "${FILESDIR}"/${MY_PV}-parallel.patch
-
- sed \
- -e "/PSIPRED_DIR/s:'data':'share/psipred/data':g" \
- -e "s:weights_s:weights:g" \
- -i python/ccpnmr/analysis/wrappers/Psipred.py || die
-
- local tk_ver
- local myconf
-
- tk_ver="$(best_version dev-lang/tk | cut -d- -f3 | cut -d. -f1,2)"
-
- if use opengl; then
- GLUT_NEED_INIT="-DNEED_GLUT_INIT"
- IGNORE_GL_FLAG=""
- GL_FLAG="-DUSE_GL_TRUE"
- GL_DIR="${EPREFIX}/usr"
- GL_LIB="-lglut -lGLU -lGL"
- GL_INCLUDE_FLAGS="-I\$(GL_DIR)/include"
- GL_LIB_FLAGS="-L\$(GL_DIR)/$(get_libdir)"
-
- else
- IGNORE_GL_FLAG="-DIGNORE_GL"
- GL_FLAG="-DUSE_GL_FALSE"
- fi
-
- GLUT_NOT_IN_GL=""
- GLUT_FLAG="\$(GLUT_NEED_INIT) \$(GLUT_NOT_IN_GL)"
-
- rm -rf data model doc license || die
-
- sed \
- -e "s|/usr|${EPREFIX}/usr|g" \
- -e "s|^\(CC =\).*|\1 $(tc-getCC)|g" \
- -e "s|^\(OPT_FLAG =\).*|\1 ${CFLAGS}|g" \
- -e "s|^\(LINK_FLAGS =.*\)|\1 ${LDFLAGS}|g" \
- -e "s|^\(IGNORE_GL_FLAG =\).*|\1 ${IGNORE_GL_FLAG}|g" \
- -e "s|^\(GL_FLAG =\).*|\1 ${GL_FLAG}|g" \
- -e "s|^\(GL_DIR =\).*|\1 ${GL_DIR}|g" \
- -e "s|^\(GL_LIB =\).*|\1 ${GL_LIB}|g" \
- -e "s|^\(GL_LIB_FLAGS =\).*|\1 ${GL_LIB_FLAGS}|g" \
- -e "s|^\(GL_INCLUDE_FLAGS =\).*|\1 ${GL_INCLUDE_FLAGS}|g" \
- -e "s|^\(GLUT_NEED_INIT =\).*|\1 ${GLUT_NEED_INIT}|g" \
- -e "s|^\(GLUT_NOT_IN_GL =\).*|\1|g" \
- -e "s|^\(X11_LIB_FLAGS =\).*|\1 -L${EPREFIX}/usr/$(get_libdir)|g" \
- -e "s|^\(TCL_LIB_FLAGS =\).*|\1 -L${EPREFIX}/usr/$(get_libdir)|g" \
- -e "s|^\(TK_LIB_FLAGS =\).*|\1 -L${EPREFIX}/usr/$(get_libdir)|g" \
- -e "s|^\(PYTHON_INCLUDE_FLAGS =\).*|\1 -I${EPREFIX}/$(python_get_includedir)|g" \
- -e "s|^\(PYTHON_LIB =\).*|\1 $(python_get_library -l)|g" \
- c/environment_default.txt > c/environment.txt || die
-
- sed \
- -e 's:ln -s:cp -f:g' \
- -i $(find python -name linkSharedObjs) || die
-}
-
-src_compile() {
- emake -C c all
- emake -C c links
-}
-
-src_install() {
- local libdir
- local tkver
- local _wrapper
-
- find . -name "*.pyc" -type f -delete
-
- libdir=$(get_libdir)
- tkver=$(best_version dev-lang/tk | cut -d- -f3 | cut -d. -f1,2)
-
- _wrapper="analysis dangle dataShifter depositionFileImporter eci formatConverter pipe2azara xeasy2azara"
- use extendnmr && _wrapper="${_wrapper} extendNmr"
- for wrapper in ${_wrapper}; do
- sed \
- -e "s|gentoo_sitedir|${EPREFIX}$(python_get_sitedir)|g" \
- -e "s|gentoolibdir|${EPREFIX}/usr/${libdir}|g" \
- -e "s|gentootk|${EPREFIX}/usr/${libdir}/tk${tkver}|g" \
- -e "s|gentootcl|${EPREFIX}/usr/${libdir}/tclk${tkver}|g" \
- -e "s|gentoopython|$(PYTHON -a)|g" \
- -e "s|gentoousr|${EPREFIX}/usr|g" \
- -e "s|//|/|g" \
- "${FILESDIR}"/${wrapper} > "${T}"/${wrapper} || die "Fail fix ${wrapper}"
- dobin "${T}"/${wrapper}
- done
-
- local in_path=$(python_get_sitedir)/${PN}
- local files
- local pydocs
-
- pydocs="$(find python -name doc -type d)"
- rm -rf ${pydocs} || die
-
- for i in python/memops/format/compatibility/{Converters,part2/Converters2}.py; do
- sed \
- -e 's|#from __future__|from __future__|g' \
- -i ${i} || die
- done
-
- insinto ${in_path}
-
- dodir ${in_path}/c
-
- ebegin "Installing main files"
- doins -r python
- eend
-
- ebegin "Adjusting permissions"
-
- for _file in $(find "${ED}" -type f -name "*so"); do
- chmod 755 ${_file}
- done
- eend
-}
-
-pkg_postinst() {
- python_mod_optimize ${PN}
-}
-
-pkg_postrm() {
- python_mod_cleanup ${PN}
-}
diff --git a/sci-chemistry/ccpn/ccpn-2.2.2_p121012.ebuild b/sci-chemistry/ccpn/ccpn-2.2.2_p121012.ebuild
deleted file mode 100644
index cd38f77e1eb1..000000000000
--- a/sci-chemistry/ccpn/ccpn-2.2.2_p121012.ebuild
+++ /dev/null
@@ -1,180 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccpn/ccpn-2.2.2_p121012.ebuild,v 1.1 2012/10/12 16:24:44 jlec Exp $
-
-EAPI=4
-
-PYTHON_DEPEND="2:2.5"
-PYTHON_USE_WITH="ssl tk"
-
-inherit eutils portability python toolchain-funcs versionator
-
-PATCHSET="${PV##*_p}"
-MY_PN="${PN}mr"
-MY_PV="$(replace_version_separator 3 _ ${PV%%_p*})"
-MY_MAJOR="$(get_version_component_range 1-3)"
-
-DESCRIPTION="The Collaborative Computing Project for NMR"
-SRC_URI="http://www-old.ccpn.ac.uk/download/${MY_PN}/analysis${MY_PV}.tar.gz"
- [[ -n ${PATCHSET} ]] && SRC_URI="${SRC_URI} http://dev.gentoo.org/~jlec/distfiles/ccpn-update-${MY_MAJOR}-${PATCHSET}.patch.xz"
-HOMEPAGE="http://www.ccpn.ac.uk/ccpn"
-
-SLOT="0"
-LICENSE="|| ( CCPN LGPL-2.1 )"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="extendnmr +opengl"
-
-RDEPEND="
- dev-lang/tk[threads]
- dev-python/numpy
- dev-tcltk/tix
- =sci-libs/ccpn-data-"${MY_MAJOR}"*
- sci-biology/psipred
- x11-libs/libXext
- x11-libs/libX11
- opengl? (
- media-libs/freeglut
- dev-python/pyglet )"
-# We need to fix this
-# sci-chemistry/mdd
-DEPEND="${RDEPEND}"
-PDEPEND="
- extendnmr? (
- >=sci-chemistry/aria-2.3.2-r1
- sci-chemistry/prodecomp )"
-
-RESTRICT="mirror"
-
-S="${WORKDIR}"/${MY_PN}/${MY_PN}$(get_version_component_range 1-2 ${PV})
-
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
-}
-
-src_prepare() {
- [[ -n ${PATCHSET} ]] && \
- epatch "${WORKDIR}"/ccpn-update-${MY_MAJOR}-${PATCHSET}.patch
-
- epatch "${FILESDIR}"/${MY_PV}-parallel.patch
-
- sed \
- -e "/PSIPRED_DIR/s:'data':'share/psipred/data':g" \
- -e "s:weights_s:weights:g" \
- -i python/ccpnmr/analysis/wrappers/Psipred.py || die
-
- local tk_ver
- local myconf
-
- tk_ver="$(best_version dev-lang/tk | cut -d- -f3 | cut -d. -f1,2)"
-
- if use opengl; then
- GLUT_NEED_INIT="-DNEED_GLUT_INIT"
- IGNORE_GL_FLAG=""
- GL_FLAG="-DUSE_GL_TRUE"
- GL_DIR="${EPREFIX}/usr"
- GL_LIB="-lglut -lGLU -lGL"
- GL_INCLUDE_FLAGS="-I\$(GL_DIR)/include"
- GL_LIB_FLAGS="-L\$(GL_DIR)/$(get_libdir)"
-
- else
- IGNORE_GL_FLAG="-DIGNORE_GL"
- GL_FLAG="-DUSE_GL_FALSE"
- fi
-
- GLUT_NOT_IN_GL=""
- GLUT_FLAG="\$(GLUT_NEED_INIT) \$(GLUT_NOT_IN_GL)"
-
- rm -rf data model doc license || die
-
- sed \
- -e "s|/usr|${EPREFIX}/usr|g" \
- -e "s|^\(CC =\).*|\1 $(tc-getCC)|g" \
- -e "s|^\(OPT_FLAG =\).*|\1 ${CFLAGS}|g" \
- -e "s|^\(LINK_FLAGS =.*\)|\1 ${LDFLAGS}|g" \
- -e "s|^\(IGNORE_GL_FLAG =\).*|\1 ${IGNORE_GL_FLAG}|g" \
- -e "s|^\(GL_FLAG =\).*|\1 ${GL_FLAG}|g" \
- -e "s|^\(GL_DIR =\).*|\1 ${GL_DIR}|g" \
- -e "s|^\(GL_LIB =\).*|\1 ${GL_LIB}|g" \
- -e "s|^\(GL_LIB_FLAGS =\).*|\1 ${GL_LIB_FLAGS}|g" \
- -e "s|^\(GL_INCLUDE_FLAGS =\).*|\1 ${GL_INCLUDE_FLAGS}|g" \
- -e "s|^\(GLUT_NEED_INIT =\).*|\1 ${GLUT_NEED_INIT}|g" \
- -e "s|^\(GLUT_NOT_IN_GL =\).*|\1|g" \
- -e "s|^\(X11_LIB_FLAGS =\).*|\1 -L${EPREFIX}/usr/$(get_libdir)|g" \
- -e "s|^\(TCL_LIB_FLAGS =\).*|\1 -L${EPREFIX}/usr/$(get_libdir)|g" \
- -e "s|^\(TK_LIB_FLAGS =\).*|\1 -L${EPREFIX}/usr/$(get_libdir)|g" \
- -e "s|^\(PYTHON_INCLUDE_FLAGS =\).*|\1 -I${EPREFIX}/$(python_get_includedir)|g" \
- -e "s|^\(PYTHON_LIB =\).*|\1 $(python_get_library -l)|g" \
- c/environment_default.txt > c/environment.txt || die
-
- sed \
- -e 's:ln -s:cp -f:g' \
- -i $(find python -name linkSharedObjs) || die
-}
-
-src_compile() {
- emake -C c all
- emake -C c links
-}
-
-src_install() {
- local libdir
- local tkver
- local _wrapper
-
- find . -name "*.pyc" -type f -delete
-
- libdir=$(get_libdir)
- tkver=$(best_version dev-lang/tk | cut -d- -f3 | cut -d. -f1,2)
-
- _wrapper="analysis dangle dataShifter depositionFileImporter eci formatConverter pipe2azara xeasy2azara"
- use extendnmr && _wrapper="${_wrapper} extendNmr"
- for wrapper in ${_wrapper}; do
- sed \
- -e "s|gentoo_sitedir|${EPREFIX}$(python_get_sitedir)|g" \
- -e "s|gentoolibdir|${EPREFIX}/usr/${libdir}|g" \
- -e "s|gentootk|${EPREFIX}/usr/${libdir}/tk${tkver}|g" \
- -e "s|gentootcl|${EPREFIX}/usr/${libdir}/tclk${tkver}|g" \
- -e "s|gentoopython|$(PYTHON -a)|g" \
- -e "s|gentoousr|${EPREFIX}/usr|g" \
- -e "s|//|/|g" \
- "${FILESDIR}"/${wrapper} > "${T}"/${wrapper} || die "Fail fix ${wrapper}"
- dobin "${T}"/${wrapper}
- done
-
- local in_path=$(python_get_sitedir)/${PN}
- local files
- local pydocs
-
- pydocs="$(find python -name doc -type d)"
- rm -rf ${pydocs} || die
-
- for i in python/memops/format/compatibility/{Converters,part2/Converters2}.py; do
- sed \
- -e 's|#from __future__|from __future__|g' \
- -i ${i} || die
- done
-
- insinto ${in_path}
-
- dodir ${in_path}/c
-
- ebegin "Installing main files"
- doins -r python
- eend
-
- ebegin "Adjusting permissions"
-
- for _file in $(find "${ED}" -type f -name "*so"); do
- chmod 755 ${_file}
- done
- eend
-}
-
-pkg_postinst() {
- python_mod_optimize ${PN}
-}
-
-pkg_postrm() {
- python_mod_cleanup ${PN}
-}
diff --git a/sci-chemistry/ccpn/ccpn-2.2.2_p121112.ebuild b/sci-chemistry/ccpn/ccpn-2.2.2_p121112.ebuild
deleted file mode 100644
index 86faca1b84bd..000000000000
--- a/sci-chemistry/ccpn/ccpn-2.2.2_p121112.ebuild
+++ /dev/null
@@ -1,180 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccpn/ccpn-2.2.2_p121112.ebuild,v 1.1 2012/11/12 08:00:21 jlec Exp $
-
-EAPI=4
-
-PYTHON_DEPEND="2:2.5"
-PYTHON_USE_WITH="ssl tk"
-
-inherit eutils portability python toolchain-funcs versionator
-
-PATCHSET="${PV##*_p}"
-MY_PN="${PN}mr"
-MY_PV="$(replace_version_separator 3 _ ${PV%%_p*})"
-MY_MAJOR="$(get_version_component_range 1-3)"
-
-DESCRIPTION="The Collaborative Computing Project for NMR"
-SRC_URI="http://www-old.ccpn.ac.uk/download/${MY_PN}/analysis${MY_PV}.tar.gz"
- [[ -n ${PATCHSET} ]] && SRC_URI="${SRC_URI} http://dev.gentoo.org/~jlec/distfiles/ccpn-update-${MY_MAJOR}-${PATCHSET}.patch.xz"
-HOMEPAGE="http://www.ccpn.ac.uk/ccpn"
-
-SLOT="0"
-LICENSE="|| ( CCPN LGPL-2.1 )"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="extendnmr +opengl"
-
-RDEPEND="
- dev-lang/tk[threads]
- dev-python/numpy
- dev-tcltk/tix
- =sci-libs/ccpn-data-"${MY_MAJOR}"*
- sci-biology/psipred
- x11-libs/libXext
- x11-libs/libX11
- opengl? (
- media-libs/freeglut
- dev-python/pyglet )"
-# We need to fix this
-# sci-chemistry/mdd
-DEPEND="${RDEPEND}"
-PDEPEND="
- extendnmr? (
- >=sci-chemistry/aria-2.3.2-r1
- sci-chemistry/prodecomp )"
-
-RESTRICT="mirror"
-
-S="${WORKDIR}"/${MY_PN}/${MY_PN}$(get_version_component_range 1-2 ${PV})
-
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
-}
-
-src_prepare() {
- [[ -n ${PATCHSET} ]] && \
- epatch "${WORKDIR}"/ccpn-update-${MY_MAJOR}-${PATCHSET}.patch
-
- epatch "${FILESDIR}"/${MY_PV}-parallel.patch
-
- sed \
- -e "/PSIPRED_DIR/s:'data':'share/psipred/data':g" \
- -e "s:weights_s:weights:g" \
- -i python/ccpnmr/analysis/wrappers/Psipred.py || die
-
- local tk_ver
- local myconf
-
- tk_ver="$(best_version dev-lang/tk | cut -d- -f3 | cut -d. -f1,2)"
-
- if use opengl; then
- GLUT_NEED_INIT="-DNEED_GLUT_INIT"
- IGNORE_GL_FLAG=""
- GL_FLAG="-DUSE_GL_TRUE"
- GL_DIR="${EPREFIX}/usr"
- GL_LIB="-lglut -lGLU -lGL"
- GL_INCLUDE_FLAGS="-I\$(GL_DIR)/include"
- GL_LIB_FLAGS="-L\$(GL_DIR)/$(get_libdir)"
-
- else
- IGNORE_GL_FLAG="-DIGNORE_GL"
- GL_FLAG="-DUSE_GL_FALSE"
- fi
-
- GLUT_NOT_IN_GL=""
- GLUT_FLAG="\$(GLUT_NEED_INIT) \$(GLUT_NOT_IN_GL)"
-
- rm -rf data model doc license || die
-
- sed \
- -e "s|/usr|${EPREFIX}/usr|g" \
- -e "s|^\(CC =\).*|\1 $(tc-getCC)|g" \
- -e "s|^\(OPT_FLAG =\).*|\1 ${CFLAGS}|g" \
- -e "s|^\(LINK_FLAGS =.*\)|\1 ${LDFLAGS}|g" \
- -e "s|^\(IGNORE_GL_FLAG =\).*|\1 ${IGNORE_GL_FLAG}|g" \
- -e "s|^\(GL_FLAG =\).*|\1 ${GL_FLAG}|g" \
- -e "s|^\(GL_DIR =\).*|\1 ${GL_DIR}|g" \
- -e "s|^\(GL_LIB =\).*|\1 ${GL_LIB}|g" \
- -e "s|^\(GL_LIB_FLAGS =\).*|\1 ${GL_LIB_FLAGS}|g" \
- -e "s|^\(GL_INCLUDE_FLAGS =\).*|\1 ${GL_INCLUDE_FLAGS}|g" \
- -e "s|^\(GLUT_NEED_INIT =\).*|\1 ${GLUT_NEED_INIT}|g" \
- -e "s|^\(GLUT_NOT_IN_GL =\).*|\1|g" \
- -e "s|^\(X11_LIB_FLAGS =\).*|\1 -L${EPREFIX}/usr/$(get_libdir)|g" \
- -e "s|^\(TCL_LIB_FLAGS =\).*|\1 -L${EPREFIX}/usr/$(get_libdir)|g" \
- -e "s|^\(TK_LIB_FLAGS =\).*|\1 -L${EPREFIX}/usr/$(get_libdir)|g" \
- -e "s|^\(PYTHON_INCLUDE_FLAGS =\).*|\1 -I${EPREFIX}/$(python_get_includedir)|g" \
- -e "s|^\(PYTHON_LIB =\).*|\1 $(python_get_library -l)|g" \
- c/environment_default.txt > c/environment.txt || die
-
- sed \
- -e 's:ln -s:cp -f:g' \
- -i $(find python -name linkSharedObjs) || die
-}
-
-src_compile() {
- emake -C c all
- emake -C c links
-}
-
-src_install() {
- local libdir
- local tkver
- local _wrapper
-
- find . -name "*.pyc" -type f -delete
-
- libdir=$(get_libdir)
- tkver=$(best_version dev-lang/tk | cut -d- -f3 | cut -d. -f1,2)
-
- _wrapper="analysis dangle dataShifter depositionFileImporter eci formatConverter pipe2azara xeasy2azara"
- use extendnmr && _wrapper="${_wrapper} extendNmr"
- for wrapper in ${_wrapper}; do
- sed \
- -e "s|gentoo_sitedir|${EPREFIX}$(python_get_sitedir)|g" \
- -e "s|gentoolibdir|${EPREFIX}/usr/${libdir}|g" \
- -e "s|gentootk|${EPREFIX}/usr/${libdir}/tk${tkver}|g" \
- -e "s|gentootcl|${EPREFIX}/usr/${libdir}/tclk${tkver}|g" \
- -e "s|gentoopython|$(PYTHON -a)|g" \
- -e "s|gentoousr|${EPREFIX}/usr|g" \
- -e "s|//|/|g" \
- "${FILESDIR}"/${wrapper} > "${T}"/${wrapper} || die "Fail fix ${wrapper}"
- dobin "${T}"/${wrapper}
- done
-
- local in_path=$(python_get_sitedir)/${PN}
- local files
- local pydocs
-
- pydocs="$(find python -name doc -type d)"
- rm -rf ${pydocs} || die
-
- for i in python/memops/format/compatibility/{Converters,part2/Converters2}.py; do
- sed \
- -e 's|#from __future__|from __future__|g' \
- -i ${i} || die
- done
-
- insinto ${in_path}
-
- dodir ${in_path}/c
-
- ebegin "Installing main files"
- doins -r python
- eend
-
- ebegin "Adjusting permissions"
-
- for _file in $(find "${ED}" -type f -name "*so"); do
- chmod 755 ${_file}
- done
- eend
-}
-
-pkg_postinst() {
- python_mod_optimize ${PN}
-}
-
-pkg_postrm() {
- python_mod_cleanup ${PN}
-}
diff --git a/sci-chemistry/ccpn/ccpn-2.2.2_p121119.ebuild b/sci-chemistry/ccpn/ccpn-2.2.2_p121119.ebuild
deleted file mode 100644
index 3cff7cc2486f..000000000000
--- a/sci-chemistry/ccpn/ccpn-2.2.2_p121119.ebuild
+++ /dev/null
@@ -1,180 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccpn/ccpn-2.2.2_p121119.ebuild,v 1.1 2012/11/19 09:47:21 jlec Exp $
-
-EAPI=4
-
-PYTHON_DEPEND="2:2.5"
-PYTHON_USE_WITH="ssl tk"
-
-inherit eutils portability python toolchain-funcs versionator
-
-PATCHSET="${PV##*_p}"
-MY_PN="${PN}mr"
-MY_PV="$(replace_version_separator 3 _ ${PV%%_p*})"
-MY_MAJOR="$(get_version_component_range 1-3)"
-
-DESCRIPTION="The Collaborative Computing Project for NMR"
-SRC_URI="http://www-old.ccpn.ac.uk/download/${MY_PN}/analysis${MY_PV}.tar.gz"
- [[ -n ${PATCHSET} ]] && SRC_URI="${SRC_URI} http://dev.gentoo.org/~jlec/distfiles/ccpn-update-${MY_MAJOR}-${PATCHSET}.patch.xz"
-HOMEPAGE="http://www.ccpn.ac.uk/ccpn"
-
-SLOT="0"
-LICENSE="|| ( CCPN LGPL-2.1 )"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="extendnmr +opengl"
-
-RDEPEND="
- dev-lang/tk[threads]
- dev-python/numpy
- dev-tcltk/tix
- =sci-libs/ccpn-data-"${MY_MAJOR}"*
- sci-biology/psipred
- x11-libs/libXext
- x11-libs/libX11
- opengl? (
- media-libs/freeglut
- dev-python/pyglet )"
-# We need to fix this
-# sci-chemistry/mdd
-DEPEND="${RDEPEND}"
-PDEPEND="
- extendnmr? (
- >=sci-chemistry/aria-2.3.2-r1
- sci-chemistry/prodecomp )"
-
-RESTRICT="mirror"
-
-S="${WORKDIR}"/${MY_PN}/${MY_PN}$(get_version_component_range 1-2 ${PV})
-
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
-}
-
-src_prepare() {
- [[ -n ${PATCHSET} ]] && \
- epatch "${WORKDIR}"/ccpn-update-${MY_MAJOR}-${PATCHSET}.patch
-
- epatch "${FILESDIR}"/${MY_PV}-parallel.patch
-
- sed \
- -e "/PSIPRED_DIR/s:'data':'share/psipred/data':g" \
- -e "s:weights_s:weights:g" \
- -i python/ccpnmr/analysis/wrappers/Psipred.py || die
-
- local tk_ver
- local myconf
-
- tk_ver="$(best_version dev-lang/tk | cut -d- -f3 | cut -d. -f1,2)"
-
- if use opengl; then
- GLUT_NEED_INIT="-DNEED_GLUT_INIT"
- IGNORE_GL_FLAG=""
- GL_FLAG="-DUSE_GL_TRUE"
- GL_DIR="${EPREFIX}/usr"
- GL_LIB="-lglut -lGLU -lGL"
- GL_INCLUDE_FLAGS="-I\$(GL_DIR)/include"
- GL_LIB_FLAGS="-L\$(GL_DIR)/$(get_libdir)"
-
- else
- IGNORE_GL_FLAG="-DIGNORE_GL"
- GL_FLAG="-DUSE_GL_FALSE"
- fi
-
- GLUT_NOT_IN_GL=""
- GLUT_FLAG="\$(GLUT_NEED_INIT) \$(GLUT_NOT_IN_GL)"
-
- rm -rf data model doc license || die
-
- sed \
- -e "s|/usr|${EPREFIX}/usr|g" \
- -e "s|^\(CC =\).*|\1 $(tc-getCC)|g" \
- -e "s|^\(OPT_FLAG =\).*|\1 ${CFLAGS}|g" \
- -e "s|^\(LINK_FLAGS =.*\)|\1 ${LDFLAGS}|g" \
- -e "s|^\(IGNORE_GL_FLAG =\).*|\1 ${IGNORE_GL_FLAG}|g" \
- -e "s|^\(GL_FLAG =\).*|\1 ${GL_FLAG}|g" \
- -e "s|^\(GL_DIR =\).*|\1 ${GL_DIR}|g" \
- -e "s|^\(GL_LIB =\).*|\1 ${GL_LIB}|g" \
- -e "s|^\(GL_LIB_FLAGS =\).*|\1 ${GL_LIB_FLAGS}|g" \
- -e "s|^\(GL_INCLUDE_FLAGS =\).*|\1 ${GL_INCLUDE_FLAGS}|g" \
- -e "s|^\(GLUT_NEED_INIT =\).*|\1 ${GLUT_NEED_INIT}|g" \
- -e "s|^\(GLUT_NOT_IN_GL =\).*|\1|g" \
- -e "s|^\(X11_LIB_FLAGS =\).*|\1 -L${EPREFIX}/usr/$(get_libdir)|g" \
- -e "s|^\(TCL_LIB_FLAGS =\).*|\1 -L${EPREFIX}/usr/$(get_libdir)|g" \
- -e "s|^\(TK_LIB_FLAGS =\).*|\1 -L${EPREFIX}/usr/$(get_libdir)|g" \
- -e "s|^\(PYTHON_INCLUDE_FLAGS =\).*|\1 -I${EPREFIX}/$(python_get_includedir)|g" \
- -e "s|^\(PYTHON_LIB =\).*|\1 $(python_get_library -l)|g" \
- c/environment_default.txt > c/environment.txt || die
-
- sed \
- -e 's:ln -s:cp -f:g' \
- -i $(find python -name linkSharedObjs) || die
-}
-
-src_compile() {
- emake -C c all
- emake -C c links
-}
-
-src_install() {
- local libdir
- local tkver
- local _wrapper
-
- find . -name "*.pyc" -type f -delete
-
- libdir=$(get_libdir)
- tkver=$(best_version dev-lang/tk | cut -d- -f3 | cut -d. -f1,2)
-
- _wrapper="analysis dangle dataShifter depositionFileImporter eci formatConverter pipe2azara xeasy2azara"
- use extendnmr && _wrapper="${_wrapper} extendNmr"
- for wrapper in ${_wrapper}; do
- sed \
- -e "s|gentoo_sitedir|${EPREFIX}$(python_get_sitedir)|g" \
- -e "s|gentoolibdir|${EPREFIX}/usr/${libdir}|g" \
- -e "s|gentootk|${EPREFIX}/usr/${libdir}/tk${tkver}|g" \
- -e "s|gentootcl|${EPREFIX}/usr/${libdir}/tclk${tkver}|g" \
- -e "s|gentoopython|$(PYTHON -a)|g" \
- -e "s|gentoousr|${EPREFIX}/usr|g" \
- -e "s|//|/|g" \
- "${FILESDIR}"/${wrapper} > "${T}"/${wrapper} || die "Fail fix ${wrapper}"
- dobin "${T}"/${wrapper}
- done
-
- local in_path=$(python_get_sitedir)/${PN}
- local files
- local pydocs
-
- pydocs="$(find python -name doc -type d)"
- rm -rf ${pydocs} || die
-
- for i in python/memops/format/compatibility/{Converters,part2/Converters2}.py; do
- sed \
- -e 's|#from __future__|from __future__|g' \
- -i ${i} || die
- done
-
- insinto ${in_path}
-
- dodir ${in_path}/c
-
- ebegin "Installing main files"
- doins -r python
- eend
-
- ebegin "Adjusting permissions"
-
- for _file in $(find "${ED}" -type f -name "*so"); do
- chmod 755 ${_file}
- done
- eend
-}
-
-pkg_postinst() {
- python_mod_optimize ${PN}
-}
-
-pkg_postrm() {
- python_mod_cleanup ${PN}
-}
diff --git a/sci-chemistry/ccpn/ccpn-2.2.2_p120829.ebuild b/sci-chemistry/ccpn/ccpn-2.2.2_p130110.ebuild
index bf86ba66284f..71c969df6198 100644
--- a/sci-chemistry/ccpn/ccpn-2.2.2_p120829.ebuild
+++ b/sci-chemistry/ccpn/ccpn-2.2.2_p130110.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccpn/ccpn-2.2.2_p120829.ebuild,v 1.1 2012/08/29 06:24:14 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccpn/ccpn-2.2.2_p130110.ebuild,v 1.1 2013/01/10 17:41:33 jlec Exp $
EAPI=4
@@ -15,14 +15,15 @@ MY_PV="$(replace_version_separator 3 _ ${PV%%_p*})"
MY_MAJOR="$(get_version_component_range 1-3)"
DESCRIPTION="The Collaborative Computing Project for NMR"
-SRC_URI="http://www-old.ccpn.ac.uk/download/${MY_PN}/analysis${MY_PV}.tar.gz"
- [[ -n ${PATCHSET} ]] && SRC_URI="${SRC_URI} http://dev.gentoo.org/~jlec/distfiles/ccpn-update-${MY_MAJOR}-${PATCHSET}.patch.xz"
HOMEPAGE="http://www.ccpn.ac.uk/ccpn"
+SRC_URI="http://www-old.ccpn.ac.uk/download/${MY_PN}/analysis${MY_PV}.tar.gz"
+[[ -n ${PATCHSET} ]] \
+ && SRC_URI+=" http://dev.gentoo.org/~jlec/distfiles/ccpn-update-${MY_MAJOR}-${PATCHSET}.patch.xz"
SLOT="0"
LICENSE="|| ( CCPN LGPL-2.1 )"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="extendnmr +opengl"
+IUSE="+opengl"
RDEPEND="
dev-lang/tk[threads]
@@ -35,13 +36,7 @@ RDEPEND="
opengl? (
media-libs/freeglut
dev-python/pyglet )"
-# We need to fix this
-# sci-chemistry/mdd
DEPEND="${RDEPEND}"
-PDEPEND="
- extendnmr? (
- >=sci-chemistry/aria-2.3.2-r1
- sci-chemistry/prodecomp )"
RESTRICT="mirror"
@@ -102,6 +97,7 @@ src_prepare() {
-e "s|^\(GLUT_NOT_IN_GL =\).*|\1|g" \
-e "s|^\(X11_LIB_FLAGS =\).*|\1 -L${EPREFIX}/usr/$(get_libdir)|g" \
-e "s|^\(TCL_LIB_FLAGS =\).*|\1 -L${EPREFIX}/usr/$(get_libdir)|g" \
+ -e "s|^\(TK_LIB =\).*|\1 -ltk${tk_ver}|g" \
-e "s|^\(TK_LIB_FLAGS =\).*|\1 -L${EPREFIX}/usr/$(get_libdir)|g" \
-e "s|^\(PYTHON_INCLUDE_FLAGS =\).*|\1 -I${EPREFIX}/$(python_get_includedir)|g" \
-e "s|^\(PYTHON_LIB =\).*|\1 $(python_get_library -l)|g" \
@@ -127,8 +123,7 @@ src_install() {
libdir=$(get_libdir)
tkver=$(best_version dev-lang/tk | cut -d- -f3 | cut -d. -f1,2)
- _wrapper="analysis dangle dataShifter depositionFileImporter eci formatConverter pipe2azara xeasy2azara"
- use extendnmr && _wrapper="${_wrapper} extendNmr"
+ _wrapper="analysis dangle dataShifter depositionFileImporter eci formatConverter pipe2azara xeasy2azara extendNmr"
for wrapper in ${_wrapper}; do
sed \
-e "s|gentoo_sitedir|${EPREFIX}$(python_get_sitedir)|g" \
@@ -164,7 +159,6 @@ src_install() {
eend
ebegin "Adjusting permissions"
-
for _file in $(find "${ED}" -type f -name "*so"); do
chmod 755 ${_file}
done
diff --git a/sci-chemistry/ccpn/metadata.xml b/sci-chemistry/ccpn/metadata.xml
index d65c846daad4..8a82c7657734 100644
--- a/sci-chemistry/ccpn/metadata.xml
+++ b/sci-chemistry/ccpn/metadata.xml
@@ -1,11 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci-chemistry</herd>
- <maintainer>
- <email>jlec@gentoo.org</email>
- </maintainer>
- <use>
- <flag name="extendnmr">Install needed packages for extendNMR support</flag>
- </use>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="extendnmr">Install needed packages for extendNMR support</flag>
+ </use>
</pkgmetadata>