summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-09-18 09:21:09 +0000
committerJustin Lecher <jlec@gentoo.org>2013-09-18 09:21:09 +0000
commit620ee83caf0cfd9749bbddf0f6b65d17d36b2e22 (patch)
tree62d731cdfdaad30a6e596c354ca315c96772488e /sci-chemistry/coot
parentFix coreutils dep to be build-time. (diff)
downloadgentoo-2-620ee83caf0cfd9749bbddf0f6b65d17d36b2e22.tar.gz
gentoo-2-620ee83caf0cfd9749bbddf0f6b65d17d36b2e22.tar.bz2
gentoo-2-620ee83caf0cfd9749bbddf0f6b65d17d36b2e22.zip
sci-chemistry/coot: Drop old
(Portage version: 2.2.6/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-chemistry/coot')
-rw-r--r--sci-chemistry/coot/ChangeLog6
-rw-r--r--sci-chemistry/coot/coot-0.6.2-r1.ebuild166
-rw-r--r--sci-chemistry/coot/coot-0.6.2.ebuild162
3 files changed, 5 insertions, 329 deletions
diff --git a/sci-chemistry/coot/ChangeLog b/sci-chemistry/coot/ChangeLog
index c49a862b9628..9f54695f0d92 100644
--- a/sci-chemistry/coot/ChangeLog
+++ b/sci-chemistry/coot/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/coot
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/coot/ChangeLog,v 1.60 2013/09/15 08:31:02 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/coot/ChangeLog,v 1.61 2013/09/18 09:21:09 jlec Exp $
+
+ 18 Sep 2013; Justin Lecher <jlec@gentoo.org> -coot-0.6.2.ebuild,
+ -coot-0.6.2-r1.ebuild:
+ Drop old
15 Sep 2013; Agostino Sarubbo <ago@gentoo.org> coot-0.7.ebuild:
Stable for x86, wrt bug #477166
diff --git a/sci-chemistry/coot/coot-0.6.2-r1.ebuild b/sci-chemistry/coot/coot-0.6.2-r1.ebuild
deleted file mode 100644
index ce8397bd45d5..000000000000
--- a/sci-chemistry/coot/coot-0.6.2-r1.ebuild
+++ /dev/null
@@ -1,166 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/coot/coot-0.6.2-r1.ebuild,v 1.6 2013/08/26 07:52:29 jlec Exp $
-
-EAPI=3
-
-PYTHON_DEPEND="2"
-
-AUTOTOOLS_AUTORECONF="true"
-
-inherit autotools-utils flag-o-matic python toolchain-funcs versionator
-
-MY_S2_PV=$(replace_version_separator 2 - ${PV})
-MY_S2_P=${PN}-${MY_S2_PV/pre1/pre-1}
-MY_S_P=${MY_S2_P}-${PR/r/revision-}
-MY_PV=${PV}
-MY_P=${PN}-${MY_PV}
-
-DESCRIPTION="Crystallographic Object-Oriented Toolkit for model building, completion and validation"
-HOMEPAGE="http://www2.mrc-lmb.cam.ac.uk/personal/pemsley/coot/"
-SRC_URI="
- http://www.biop.ox.ac.uk/coot/software/source/releases/${MY_P}.tar.gz
- test? ( http://dev.gentoo.org/~jlec/distfiles/greg-data-${PV}.tar.gz )"
-
-SLOT="0"
-LICENSE="GPL-3"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="+openmp static-libs test"
-
-AUTOTOOLS_IN_SOURCE_BUILD=1
-
-SCIDEPS="
- >=sci-libs/ccp4-libs-6.1
- sci-libs/clipper
- >=sci-libs/coot-data-2
- >=sci-libs/gsl-1.3
- >=sci-libs/mmdb-1.23
- sci-libs/ssm
- <sci-libs/monomer-db-1
- sci-chemistry/reduce
- <sci-chemistry/refmac-5.6
- sci-chemistry/probe"
-
-XDEPS="
- gnome-base/libgnomecanvas
- gnome-base/librsvg:2
- media-libs/libpng
- media-libs/freeglut
- x11-libs/gtk+:2
- x11-libs/gtkglext"
-
-SCHEMEDEPS="
- dev-scheme/net-http
- dev-scheme/guile-gui
- >=dev-scheme/guile-lib-0.1.6
- dev-scheme/guile-www
- >=x11-libs/guile-gtk-2.1"
-
-RDEPEND="
- ${SCIDEPS}
- ${XDEPS}
- ${SCHEMEDEPS}
- dev-python/pygtk:2
- >=dev-libs/gmp-4.2.2-r2
- >=net-misc/curl-7.19.6
- net-dns/libidn"
-DEPEND="${RDEPEND}
- dev-lang/swig
- sys-devel/bc
- test? ( dev-scheme/greg )"
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
- if use openmp; then
- tc-has-openmp || die "Please use an OPENMP capable compiler"
- has_version '<sys-devel/libtool-2.4-r2' && append-ldflags $(no-as-needed)
- fi
- python_set_active_version 2
-}
-
-PATCHES=(
- "${FILESDIR}"/${PV}-clipper-config.patch
- "${FILESDIR}"/${PV}-mmdb-config.patch
- "${FILESDIR}"/${PV}-gl.patch
- "${FILESDIR}"/${PV}-test.patch
- "${FILESDIR}"/${PV}-ssm.patch
- "${FILESDIR}"/${PV}-libpng15.patch
- )
-
-src_prepare() {
- sed \
- -e "s:AM_COOT_SYS_BUILD_TYPE:COOT_SYS_BUILD_TYPE=Gentoo-Linux-$(PYTHON)-gtk2 ; AC_MSG_RESULT([\$COOT_SYS_BUILD_TYPE]); AC_SUBST(COOT_SYS_BUILD_TYPE):g" \
- -i configure.in || die
-
- autotools-utils_src_prepare
-}
-
-src_configure() {
- # All the --with's are used to activate various parts.
- # Yes, this is broken behavior.
- local myeconfargs=(
- --includedir='${prefix}/include/coot'
- --with-gtkcanvas-prefix="${EPREFIX}/usr"
- --with-gtkgl-prefix="${EPREFIX}/usr"
- --with-guile
- --with-python="${EPREFIX}/usr"
- --with-guile-gtk
- --with-gtk2
- --with-pygtk
- $(use_enable openmp)
- )
- autotools-utils_src_configure
-}
-
-src_compile() {
- autotools-utils_src_compile
- python_convert_shebangs $(python_get_version) "${S}"/src/coot_gtk2.py
- cp "${S}"/src/coot_gtk2.py python/coot.py || die
-}
-
-src_test() {
- source "${EPREFIX}/etc/profile.d/40ccp4.setup.sh"
- mkdir "${T}"/coot_test
-
- export COOT_STANDARD_RESIDUES="${S}/standard-residues.pdb"
- export COOT_SCHEME_DIR="${S}/scheme/"
- export COOT_RESOURCES_FILE="${S}/cootrc"
- export COOT_PIXMAPS_DIR="${S}/pixmaps"
- export COOT_DATA_DIR="${S}"
- export COOT_PYTHON_DIR="${S}/python"
- export PYTHONPATH="${COOT_PYTHON_DIR}:${PYTHONPATH}"
- export PYTHONHOME="${EPREFIX}"/usr
- export CCP4_SCR="${T}"/coot_test
- export CLIBD_MON="${EPREFIX}/usr/share/ccp4/data/monomers/"
- export SYMINFO="${S}/syminfo.lib"
-
- export COOT_TEST_DATA_DIR="${WORKDIR}"/data/greg-data
-
- cat > command-line-greg.scm <<- EOF
- (use-modules (ice-9 greg))
- (set! greg-tools (list "greg-tests"))
- (set! greg-debug #t)
- (set! greg-verbose 5)
- (let ((r (greg-test-run)))
- (if r
- (coot-real-exit 0)
- (coot-real-exit 1)))
- EOF
-
- einfo "Running test with following paths ..."
- einfo "COOT_STANDARD_RESIDUES $COOT_STANDARD_RESIDUES"
- einfo "COOT_SCHEME_DIR $COOT_SCHEME_DIR"
- einfo "COOT_RESOURCES_FILE $COOT_RESOURCES_FILE"
- einfo "COOT_PIXMAPS_DIR $COOT_PIXMAPS_DIR"
- einfo "COOT_DATA_DIR $COOT_DATA_DIR"
- einfo "COOT_PYTHON_DIR $COOT_PYTHON_DIR"
- einfo "PYTHONPATH $PYTHONPATH"
- einfo "PYTHONHOME $PYTHONHOME"
- einfo "CCP4_SCR ${CCP4_SCR}"
- einfo "CLIBD_MON ${CLIBD_MON}"
- einfo "SYMINFO ${SYMINFO}"
-
- "${S}"/src/coot-real --no-graphics --script command-line-greg.scm || die
- "${S}"/src/coot-real --no-graphics --script python-tests/coot_unittest.py || die
-}
diff --git a/sci-chemistry/coot/coot-0.6.2.ebuild b/sci-chemistry/coot/coot-0.6.2.ebuild
deleted file mode 100644
index f17d1f5542cb..000000000000
--- a/sci-chemistry/coot/coot-0.6.2.ebuild
+++ /dev/null
@@ -1,162 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/coot/coot-0.6.2.ebuild,v 1.13 2013/08/26 07:52:29 jlec Exp $
-
-EAPI=3
-
-PYTHON_DEPEND="2"
-
-inherit autotools base eutils flag-o-matic python toolchain-funcs versionator
-
-MY_S2_PV=$(replace_version_separator 2 - ${PV})
-MY_S2_P=${PN}-${MY_S2_PV/pre1/pre-1}
-MY_S_P=${MY_S2_P}-${PR/r/revision-}
-MY_PV=${PV}
-MY_P=${PN}-${MY_PV}
-
-DESCRIPTION="Crystallographic Object-Oriented Toolkit for model building, completion and validation"
-HOMEPAGE="http://www2.mrc-lmb.cam.ac.uk/personal/pemsley/coot/"
-SRC_URI="
- http://www.biop.ox.ac.uk/coot/software/source/releases/${MY_P}.tar.gz
- test? ( http://dev.gentoo.org/~jlec/distfiles/greg-data-${PV}.tar.gz )"
-
-SLOT="0"
-LICENSE="GPL-3"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="+openmp test"
-
-SCIDEPS="
- >=sci-libs/ccp4-libs-6.1
- sci-libs/clipper
- >=sci-libs/coot-data-2
- >=sci-libs/gsl-1.3
- >=sci-libs/mmdb-1.23
- sci-libs/ssm
- <sci-libs/monomer-db-1
- sci-chemistry/reduce
- <sci-chemistry/refmac-5.6
- sci-chemistry/probe"
-
-XDEPS="
- gnome-base/libgnomecanvas
- gnome-base/librsvg:2
- media-libs/libpng
- media-libs/freeglut
- x11-libs/gtk+:2
- x11-libs/gtkglext"
-
-SCHEMEDEPS="
- dev-scheme/net-http
- dev-scheme/guile-gui
- >=dev-scheme/guile-lib-0.1.6
- dev-scheme/guile-www
- >=x11-libs/guile-gtk-2.1"
-
-RDEPEND="
- ${SCIDEPS}
- ${XDEPS}
- ${SCHEMEDEPS}
- dev-python/pygtk:2
- >=dev-libs/gmp-4.2.2-r2
- >=net-misc/curl-7.19.6
- net-dns/libidn"
-DEPEND="${RDEPEND}
- dev-lang/swig
- sys-devel/bc
- test? ( dev-scheme/greg )"
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
- if use openmp; then
- tc-has-openmp || die "Please use an OPENMP capable compiler"
- has_version '<sys-devel/libtool-2.4-r2' && append-ldflags $(no-as-needed)
- fi
- python_set_active_version 2
-}
-
-PATCHES=(
- "${FILESDIR}"/${PV}-clipper-config.patch
- "${FILESDIR}"/${PV}-mmdb-config.patch
- "${FILESDIR}"/${PV}-gl.patch
- "${FILESDIR}"/${PV}-test.patch
- "${FILESDIR}"/${PV}-ssm.patch
- "${FILESDIR}"/${PV}-libpng15.patch
- )
-
-src_prepare() {
- sed \
- -e "s:AM_COOT_SYS_BUILD_TYPE:COOT_SYS_BUILD_TYPE=Gentoo-Linux-$(PYTHON)-gtk2 ; AC_MSG_RESULT([\$COOT_SYS_BUILD_TYPE]); AC_SUBST(COOT_SYS_BUILD_TYPE):g" \
- -i configure.in || die
-
- base_src_prepare
-
- eautoreconf
-}
-
-src_configure() {
- # All the --with's are used to activate various parts.
- # Yes, this is broken behavior.
- econf \
- --includedir='${prefix}/include/coot' \
- --with-gtkcanvas-prefix="${EPREFIX}/usr" \
- --with-gtkgl-prefix="${EPREFIX}/usr" \
- --with-guile \
- --with-python="${EPREFIX}/usr" \
- --with-guile-gtk \
- --with-gtk2 \
- --with-pygtk \
- $(use_enable openmp)
-}
-
-src_compile() {
- emake || die "emake failed"
- python_convert_shebangs $(python_get_version) src/coot_gtk2.py
- cp "${S}"/src/coot_gtk2.py python/coot.py || die
-}
-
-src_test() {
- source "${EPREFIX}/etc/profile.d/40ccp4.setup.sh"
- mkdir "${T}"/coot_test
-
- export COOT_STANDARD_RESIDUES="${S}/standard-residues.pdb"
- export COOT_SCHEME_DIR="${S}/scheme/"
- export COOT_RESOURCES_FILE="${S}/cootrc"
- export COOT_PIXMAPS_DIR="${S}/pixmaps"
- export COOT_DATA_DIR="${S}"
- export COOT_PYTHON_DIR="${S}/python"
- export PYTHONPATH="${COOT_PYTHON_DIR}:${PYTHONPATH}"
- export PYTHONHOME="${EPREFIX}"/usr
- export CCP4_SCR="${T}"/coot_test
- export CLIBD_MON="${EPREFIX}/usr/share/ccp4/data/monomers/"
- export SYMINFO="${S}/syminfo.lib"
-
- export COOT_TEST_DATA_DIR="${WORKDIR}"/data/greg-data
-
- cat > command-line-greg.scm <<- EOF
- (use-modules (ice-9 greg))
- (set! greg-tools (list "greg-tests"))
- (set! greg-debug #t)
- (set! greg-verbose 5)
- (let ((r (greg-test-run)))
- (if r
- (coot-real-exit 0)
- (coot-real-exit 1)))
- EOF
-
- einfo "Running test with following paths ..."
- einfo "COOT_STANDARD_RESIDUES $COOT_STANDARD_RESIDUES"
- einfo "COOT_SCHEME_DIR $COOT_SCHEME_DIR"
- einfo "COOT_RESOURCES_FILE $COOT_RESOURCES_FILE"
- einfo "COOT_PIXMAPS_DIR $COOT_PIXMAPS_DIR"
- einfo "COOT_DATA_DIR $COOT_DATA_DIR"
- einfo "COOT_PYTHON_DIR $COOT_PYTHON_DIR"
- einfo "PYTHONPATH $PYTHONPATH"
- einfo "PYTHONHOME $PYTHONHOME"
- einfo "CCP4_SCR ${CCP4_SCR}"
- einfo "CLIBD_MON ${CLIBD_MON}"
- einfo "SYMINFO ${SYMINFO}"
-
- "${S}"/src/coot-real --no-graphics --script command-line-greg.scm || die
- "${S}"/src/coot-real --no-graphics --script python-tests/coot_unittest.py || die
-}