summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2005-12-03 04:25:44 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2005-12-03 04:25:44 +0000
commit8117b7b0721cdcdbfde027ce9fa41d1949df1c4c (patch)
tree0b030c8d48d1a37c32e02fb8a69b49af50122fbe /sci-chemistry/gopenmol
parentpatch from nelchael for draft/templates folder (diff)
downloadgentoo-2-8117b7b0721cdcdbfde027ce9fa41d1949df1c4c.tar.gz
gentoo-2-8117b7b0721cdcdbfde027ce9fa41d1949df1c4c.tar.bz2
gentoo-2-8117b7b0721cdcdbfde027ce9fa41d1949df1c4c.zip
(#53333) New molecular graphics package for visualizing and analyzing structures. Based on ebuild by Dirk-Jan Heijs <heijs@phys.rug.nl>, with updates and fixes by me.
(Portage version: 2.0.53)
Diffstat (limited to 'sci-chemistry/gopenmol')
-rw-r--r--sci-chemistry/gopenmol/ChangeLog13
-rw-r--r--sci-chemistry/gopenmol/Manifest3
-rw-r--r--sci-chemistry/gopenmol/files/3.00-include-config-for-plugins.patch11
-rw-r--r--sci-chemistry/gopenmol/files/digest-gopenmol-3.001
-rw-r--r--sci-chemistry/gopenmol/gopenmol-3.00.ebuild63
-rw-r--r--sci-chemistry/gopenmol/metadata.xml9
6 files changed, 100 insertions, 0 deletions
diff --git a/sci-chemistry/gopenmol/ChangeLog b/sci-chemistry/gopenmol/ChangeLog
new file mode 100644
index 000000000000..f0c980b08a1a
--- /dev/null
+++ b/sci-chemistry/gopenmol/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for sci-chemistry/gopenmol
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gopenmol/ChangeLog,v 1.1 2005/12/03 04:25:44 spyderous Exp $
+
+*gopenmol-3.00 (03 Dec 2005)
+
+ 03 Dec 2005; Donnie Berkholz <spyderous@gentoo.org>;
+ +files/3.00-include-config-for-plugins.patch, +metadata.xml,
+ +gopenmol-3.00.ebuild:
+ (#53333) New molecular graphics package for visualizing and analyzing
+ structures. Based on ebuild by Dirk-Jan Heijs <heijs@phys.rug.nl>, with
+ updates and fixes by me.
+
diff --git a/sci-chemistry/gopenmol/Manifest b/sci-chemistry/gopenmol/Manifest
new file mode 100644
index 000000000000..86ca974fd471
--- /dev/null
+++ b/sci-chemistry/gopenmol/Manifest
@@ -0,0 +1,3 @@
+MD5 804493c5ad07a3849352770e90549266 files/3.00-include-config-for-plugins.patch 383
+MD5 396f13264bc2c98dcc3782af54bae392 files/digest-gopenmol-3.00 73
+MD5 5a3e9d7bb21b3eb2b0715a0421e8582c gopenmol-3.00.ebuild 1140
diff --git a/sci-chemistry/gopenmol/files/3.00-include-config-for-plugins.patch b/sci-chemistry/gopenmol/files/3.00-include-config-for-plugins.patch
new file mode 100644
index 000000000000..a8602d07a03e
--- /dev/null
+++ b/sci-chemistry/gopenmol/files/3.00-include-config-for-plugins.patch
@@ -0,0 +1,11 @@
+--- gOpenMol-3.00.orig/src/plugins/Makefile 2005-12-02 19:38:08.000000000 -0800
++++ gOpenMol-3.00/src/plugins/Makefile 2005-12-02 19:37:29.000000000 -0800
+@@ -8,6 +8,8 @@
+ # Coded by: Eero Häkkinen
+ ##############################################################################
+
++include config.mk
++
+ build-all: build FORCE ;
+
+ all install install-local uninstall: FORCE
diff --git a/sci-chemistry/gopenmol/files/digest-gopenmol-3.00 b/sci-chemistry/gopenmol/files/digest-gopenmol-3.00
new file mode 100644
index 000000000000..8669525a5f7b
--- /dev/null
+++ b/sci-chemistry/gopenmol/files/digest-gopenmol-3.00
@@ -0,0 +1 @@
+MD5 4e12ee6680c093a3bf056dde1d28fea2 gopenmol-3.00-linux.tar.gz 29615195
diff --git a/sci-chemistry/gopenmol/gopenmol-3.00.ebuild b/sci-chemistry/gopenmol/gopenmol-3.00.ebuild
new file mode 100644
index 000000000000..ca6664fc640e
--- /dev/null
+++ b/sci-chemistry/gopenmol/gopenmol-3.00.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gopenmol/gopenmol-3.00.ebuild,v 1.1 2005/12/03 04:25:44 spyderous Exp $
+
+inherit eutils
+
+DESCRIPTION="gOpenMol is a tool for the visualization and analysis of molecular structures"
+HOMEPAGE="http://www.csc.fi/gopenmol"
+SRC_URI="${HOMEPAGE}/distribute/${P}-linux.tar.gz"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND="=dev-lang/tcl-8.4*
+ =dev-lang/tk-8.4*
+ dev-tcltk/bwidget
+ virtual/opengl
+ virtual/glut
+ media-libs/jpeg
+ dev-lang/python
+ || ( (
+ x11-libs/libXmu
+ x11-libs/libICE
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libXi
+ x11-libs/libXxf86vm
+ )
+ virtual/x11
+ )"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/gOpenMol-${PV}/src"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${PV}-include-config-for-plugins.patch
+}
+
+src_compile() {
+ econf || die "./configure failed"
+
+ emake || die "emake failed"
+
+ # Plugins are not build by default
+ cd ${S}/plugins
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall || die
+
+ cd ${S}/plugins
+ einstall || die
+
+ dosed /usr/bin/rungOpenMol
+}
+
+pkg_postinst() {
+ einfo "Run gOpenMol using the rungOpenMol script."
+}
diff --git a/sci-chemistry/gopenmol/metadata.xml b/sci-chemistry/gopenmol/metadata.xml
new file mode 100644
index 000000000000..211b8bd0f0a4
--- /dev/null
+++ b/sci-chemistry/gopenmol/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+<email>spyderous@gentoo.org</email>
+<name>Donnie Berkholz</name>
+</maintainer>
+</pkgmetadata>