summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2005-12-06 09:09:25 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2005-12-06 09:09:25 +0000
commit544340b92560f7325ea78c7b9175d5b7a8a1a6af (patch)
tree0adad5e1b1fa9ce3e7919a1fdb918b51af0d9f33 /sci-chemistry/mopac7/mopac7-1.10.ebuild
parentFix GStreamer dependencies (diff)
downloadgentoo-2-544340b92560f7325ea78c7b9175d5b7a8a1a6af.tar.gz
gentoo-2-544340b92560f7325ea78c7b9175d5b7a8a1a6af.tar.bz2
gentoo-2-544340b92560f7325ea78c7b9175d5b7a8a1a6af.zip
New version. GCC-4 and 64-bit fixes, as well as new libmopac7.h
(Portage version: 2.0.53)
Diffstat (limited to 'sci-chemistry/mopac7/mopac7-1.10.ebuild')
-rw-r--r--sci-chemistry/mopac7/mopac7-1.10.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sci-chemistry/mopac7/mopac7-1.10.ebuild b/sci-chemistry/mopac7/mopac7-1.10.ebuild
new file mode 100644
index 000000000000..d02ec982310d
--- /dev/null
+++ b/sci-chemistry/mopac7/mopac7-1.10.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mopac7/mopac7-1.10.ebuild,v 1.1 2005/12/06 09:09:25 spyderous Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Autotooled, updated version of a powerful, fast semi-empirical package"
+HOMEPAGE="http://sourceforge.net/projects/mopac7/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+LICENSE="mopac7"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+DEPEND="dev-libs/libf2c
+ sys-devel/autoconf
+ sys-devel/automake
+ sys-devel/libtool"
+RDEPEND="dev-libs/libf2c"
+
+src_compile() {
+ libtoolize --copy --force
+
+ # This is absolutely required to avoid odd errors on MAIN__() not existing
+ # and to build the mopac7 binary, not just the library.
+ einfo "Adding required LDFLAGS for configure"
+ econf LDFLAGS="-Xlinker -defsym -Xlinker MAIN__=main" || die "econf failed"
+
+ # We need the appended LDFLAGS to activate building of the mopac7 binary,
+ # but they break the actual linking of it. Something's obviously broken.
+ einfo "Removing LDFLAGS, as they break the build"
+ sed -i "/^LDFLAGS/d" src/Makefile.in
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ sed -i "s:./src/mopac7:mopac7:g" run_mopac7
+ dobin run_mopac7 src/.libs/mopac7
+ dodoc AUTHORS README ChangeLog
+}