summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-07-05 13:50:48 +0000
committerJustin Lecher <jlec@gentoo.org>2012-07-05 13:50:48 +0000
commit7eee0eb9c8998b2c85584529f1101b41a88cfff7 (patch)
tree1d512d6875d1b6ff5020c1537c477554976bd078 /sci-chemistry/mosflm
parentKeyword ~mips (diff)
downloadgentoo-2-7eee0eb9c8998b2c85584529f1101b41a88cfff7.tar.gz
gentoo-2-7eee0eb9c8998b2c85584529f1101b41a88cfff7.tar.bz2
gentoo-2-7eee0eb9c8998b2c85584529f1101b41a88cfff7.zip
sci-chemistry/mosflm: Version Bump, drop old
(Portage version: 2.2.0_alpha116/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/mosflm')
-rw-r--r--sci-chemistry/mosflm/ChangeLog8
-rw-r--r--sci-chemistry/mosflm/files/7.0.8-parallel.patch92
-rw-r--r--sci-chemistry/mosflm/mosflm-7.0.7.ebuild69
-rw-r--r--sci-chemistry/mosflm/mosflm-7.0.8.ebuild (renamed from sci-chemistry/mosflm/mosflm-7.0.7-r1.ebuild)10
4 files changed, 106 insertions, 73 deletions
diff --git a/sci-chemistry/mosflm/ChangeLog b/sci-chemistry/mosflm/ChangeLog
index aba96cfc2954..3674ece42625 100644
--- a/sci-chemistry/mosflm/ChangeLog
+++ b/sci-chemistry/mosflm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/mosflm
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mosflm/ChangeLog,v 1.16 2012/06/19 06:21:16 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mosflm/ChangeLog,v 1.17 2012/07/05 13:50:48 jlec Exp $
+
+*mosflm-7.0.8 (05 Jul 2012)
+
+ 05 Jul 2012; Justin Lecher <jlec@gentoo.org> +files/7.0.8-parallel.patch,
+ -mosflm-7.0.7.ebuild, -mosflm-7.0.7-r1.ebuild, +mosflm-7.0.8.ebuild:
+ Version Bump, drop old
*mosflm-7.0.7-r2 (19 Jun 2012)
diff --git a/sci-chemistry/mosflm/files/7.0.8-parallel.patch b/sci-chemistry/mosflm/files/7.0.8-parallel.patch
new file mode 100644
index 000000000000..38c6fc45a5c0
--- /dev/null
+++ b/sci-chemistry/mosflm/files/7.0.8-parallel.patch
@@ -0,0 +1,92 @@
+ Makefile | 21 ++++++++++-----------
+ cbf/Makefile | 9 +++++++--
+ 2 files changed, 17 insertions(+), 13 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 3d2f543..2219d8d 100644
+--- a/Makefile
++++ b/Makefile
+@@ -22,8 +22,8 @@ DPSLIBS = lib/DPSLIB.a
+ CBFLIBS = cbf/lib/libcbf.a
+ JPGLIBS = jpg/libjpeg.a
+
+-all: $(DPSLIBS) $(CBFLIBS) $(JPGLIBS)
+- cd mosflm ; make
++all: $(DPSLIBS)
++ $(MAKE) -C mosflm
+
+ dpslibs:
+ @-find . -name "*a" -delete
+@@ -32,22 +32,21 @@ dpslibs:
+
+ cbflibs:
+ @-find ./cbf -name "*.a" -delete
+- cd cbf ; make all ; if [ -f $(RANLIB) ]; \
+- then $(RANLIB) lib/libcbf.a; fi
++ $(MAKE) -C cbf all
+
+ jpglibs:
+- cd jpg ; if [ ! -f Makefile ]; then ./configure ; fi; make libjpeg.a
++ cd jpg ; if [ ! -f Makefile ]; then ./configure ; fi; $(MAKE) libjpeg.a
+
+ ${DPSLIBS}:
+- make dpslibs
++ $(MAKE) dpslibs
+
+ ${CBFLIBS}:
+- make cbflibs
++ $(MAKE) cbflibs
+
+ ${JPGLIBS}:
+- make jpglibs
++ $(MAKE) jpglibs
+
+-libs: ${DPSLIBS} ${CBFLIBS} ${JPGLIBS}
++libs: ${DPSLIBS} ${CBFLIBS}
+ @echo "****************************************************************"
+ @echo " Making libraries for system ${HOSTTYPE}"
+ @echo "****************************************************************"
+@@ -56,11 +55,11 @@ ipmosflm: libs
+ @echo "****************************************************************"
+ @echo " Making IPMOSFLM for system ${HOSTTYPE}"
+ @echo "****************************************************************"
+- cd mosflm ; make ipmosflm
++ $(MAKE) -C mosflm ipmosflm
+
+ force:
+ @-rm -f bin/ipmosflm
+- make ipmosflm
++ $(MAKE) ipmosflm
+
+ install:
+ @echo "the executable is in ${MOSHOME}/bin/ipmosflm"
+diff --git a/cbf/Makefile b/cbf/Makefile
+index e61497c..c3c94ac 100644
+--- a/cbf/Makefile
++++ b/cbf/Makefile
+@@ -362,6 +362,8 @@ HEADERS = $(INCLUDE)/cbf.h \
+ $(EXAMPLES)/img.h \
+ $(INCLUDE)/md5.h
+
++OBJ = $(subst .c,.o,$(SOURCE))
++
+ #
+ # Compile the library and examples
+ #
+@@ -379,11 +381,14 @@ $(INSTALLDIR):
+ $(LIB):
+ mkdir $(LIB)
+
++
++.c.o: $(SOURCE) $(HEADERS)
++ $(CC) $(CFLAGS) $(INCLUDES) $(WARNINGS) -c $<
++
+ #
+ # CBF library
+ #
+-$(LIB)/libcbf.a: $(SOURCE) $(HEADERS) $(COMMONDEP)
+- $(CC) $(CFLAGS) $(INCLUDES) $(WARNINGS) -c $(SOURCE)
++$(LIB)/libcbf.a: $(OBJ) $(COMMONDEP)
+ $(AR) cr $@ *.o
+ rm *.o
+ if [ -f $(RANLIB) ]; then $(RANLIB) $@ ; fi
diff --git a/sci-chemistry/mosflm/mosflm-7.0.7.ebuild b/sci-chemistry/mosflm/mosflm-7.0.7.ebuild
deleted file mode 100644
index ac34106262ff..000000000000
--- a/sci-chemistry/mosflm/mosflm-7.0.7.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mosflm/mosflm-7.0.7.ebuild,v 1.1 2011/09/07 15:21:32 jlec Exp $
-
-EAPI=4
-
-inherit eutils fortran-2 toolchain-funcs versionator
-
-MY_PV="$(delete_all_version_separators)"
-MY_P="${PN}${MY_PV}"
-
-DESCRIPTION="A program for integrating single crystal diffraction data from area detectors"
-HOMEPAGE="http://www.mrc-lmb.cam.ac.uk/harry/mosflm/"
-SRC_URI="${HOMEPAGE}ver${MY_PV}/build-it-yourself/${MY_P}.tgz"
-
-LICENSE="ccp4"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-RDEPEND="
- virtual/fortran
-
- app-shells/tcsh
- virtual/jpeg
- sci-libs/ccp4-libs
- sys-libs/ncurses
- x11-libs/libxdl_view"
-DEPEND="${RDEPEND}"
-# Needs older version as current, perhaps we can fix that next release
-# sci-libs/cbflib
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
-# See DEPEND
-# sed -e "s:../cbf/lib/libcbf.a:${EPREFIX}/usr/$(get_libdir)/libcbf.a:g" \
- sed -e "s:../jpg/libjpeg.a:-ljpeg:g" \
- -i ${PN}/Makefile || die
-
- epatch \
- "${FILESDIR}"/7.0.6-Makefile.patch \
- "${FILESDIR}"/7.0.6-parallel.patch \
- "${FILESDIR}"/7.0.6-impl-dec.patch
- rm test.f || die
-}
-
-src_compile() {
- emake \
- MOSHOME="${S}" \
- DPS="${S}" \
- FC=$(tc-getFC) \
- FLINK=$(tc-getFC) \
- CC=$(tc-getCC) \
- AR_FLAGS=vru \
- MOSLIBS='-lccp4f -lccp4c -lxdl_view -lcurses -lXt -lmmdb -lccif -lstdc++' \
- MCFLAGS="-O0 -fno-second-underscore" \
- MOSFLAGS="${FFLAGS} -fno-second-underscore" \
- FFLAGS="${FFLAGS:- -O2} -fno-second-underscore" \
- CFLAGS="${CFLAGS}" \
- MOSCFLAGS="${CFLAGS}" \
- LFLAGS="${LDFLAGS}"
-}
-
-src_install() {
- exeinto /usr/libexec/ccp4/bin/
- doexe bin/ipmosflm
- dosym ../libexec/ccp4/bin/ip${PN} /usr/bin/ip${PN}
-}
diff --git a/sci-chemistry/mosflm/mosflm-7.0.7-r1.ebuild b/sci-chemistry/mosflm/mosflm-7.0.8.ebuild
index bb6f9f3b70dc..278ca25bdeea 100644
--- a/sci-chemistry/mosflm/mosflm-7.0.7-r1.ebuild
+++ b/sci-chemistry/mosflm/mosflm-7.0.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mosflm/mosflm-7.0.7-r1.ebuild,v 1.1 2012/04/28 07:58:26 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mosflm/mosflm-7.0.8.ebuild,v 1.1 2012/07/05 13:50:48 jlec Exp $
EAPI=4
@@ -40,9 +40,13 @@ src_prepare() {
-e '/jinclude.h/d' \
-i mosflm/mosflm_jpeg.c || die
+ cp DATETIME.C mosflm/datetime.c
+
epatch \
"${FILESDIR}"/${PV}-parallel.patch \
- "${FILESDIR}"/7.0.6-impl-dec.patch
+ "${FILESDIR}"/7.0.6-impl-dec.patch \
+ "${FILESDIR}"/${PN}-7.0.7-buffer-overflow.patch \
+ "${FILESDIR}"/${PN}-7.0.7-impl-dec.patch
rm -rf test.f {cbf,jpg}/*.{h,c} || die
}
@@ -58,7 +62,7 @@ src_compile() {
MOSLIBS='-lccp4f -lccp4c -lxdl_view -lcurses -lXt -lmmdb -lccif -lstdc++' \
MCFLAGS="-O0 -fno-second-underscore" \
MOSFLAGS="${FFLAGS} -fno-second-underscore" \
- FFLAGS="${FFLAGS:- -O2} -fno-second-underscore" \
+ FFLAGS="${FFLAGS} -fno-second-underscore" \
CFLAGS="${CFLAGS}" \
MOSCFLAGS="${CFLAGS}" \
LFLAGS="${LDFLAGS}"