summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-03-11 12:18:12 +0000
committerJustin Lecher <jlec@gentoo.org>2011-03-11 12:18:12 +0000
commit9c51d5a44534944d444cdf9fdfed89141ff48680 (patch)
tree5b445d8aac876b8f8b627f49ca677cf6700ac6a3 /sci-chemistry/p3d/p3d-0.4.3.ebuild
parentx86 stable per bug 358025 (diff)
downloadgentoo-2-9c51d5a44534944d444cdf9fdfed89141ff48680.tar.gz
gentoo-2-9c51d5a44534944d444cdf9fdfed89141ff48680.tar.bz2
gentoo-2-9c51d5a44534944d444cdf9fdfed89141ff48680.zip
Corrected to upstream Version, thanks flameeyes for telling me how
(Portage version: 2.2.0_alpha26/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/p3d/p3d-0.4.3.ebuild')
-rw-r--r--sci-chemistry/p3d/p3d-0.4.3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sci-chemistry/p3d/p3d-0.4.3.ebuild b/sci-chemistry/p3d/p3d-0.4.3.ebuild
new file mode 100644
index 000000000000..7b27d43ea9a5
--- /dev/null
+++ b/sci-chemistry/p3d/p3d-0.4.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/p3d/p3d-0.4.3.ebuild,v 1.1 2011/03/11 12:18:11 jlec Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils versionator
+
+MY_P="${PN}-$(replace_version_separator 3 -)"
+GITHUB_ID="gb8b9a75"
+
+DESCRIPTION="Python module for structural bioinformatics"
+HOMEPAGE="http://p3d.fufezan.net"
+SRC_URI="https://nodeload.github.com/fu/${PN}/tarball/${PV} -> ${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-3"
+IUSE="examples"
+
+src_prepare() {
+ mv fu* ${P}
+ distutils_src_prepare
+}
+
+src_install() {
+ distutils_src_install
+ if use examples; then
+ insinto /usr/share/${PN}
+ doins -r pdbs exampleScripts
+ fi
+}