summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-05-11 10:44:32 +0000
committerJustin Lecher <jlec@gentoo.org>2014-05-11 10:44:32 +0000
commitd7907960a2b501db55ece471c2d9ece330d0c0ad (patch)
tree4552b6f15791e3fbfadbb9c927c31c26024cc06e /sci-chemistry/propka/propka-3.1_p140511.ebuild
parentImport of e18 from the overlay, including version bump to 0.18.7 (diff)
downloadgentoo-2-d7907960a2b501db55ece471c2d9ece330d0c0ad.tar.gz
gentoo-2-d7907960a2b501db55ece471c2d9ece330d0c0ad.tar.bz2
gentoo-2-d7907960a2b501db55ece471c2d9ece330d0c0ad.zip
sci-chemistry/propka: New package written by me
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-chemistry/propka/propka-3.1_p140511.ebuild')
-rw-r--r--sci-chemistry/propka/propka-3.1_p140511.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sci-chemistry/propka/propka-3.1_p140511.ebuild b/sci-chemistry/propka/propka-3.1_p140511.ebuild
new file mode 100644
index 000000000000..2e35e24d0039
--- /dev/null
+++ b/sci-chemistry/propka/propka-3.1_p140511.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/propka/propka-3.1_p140511.ebuild,v 1.1 2014/05/11 10:44:32 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Prediction of the pKa values of ionizable groups in proteins and protein-ligand complexes"
+HOMEPAGE="http://propka.ki.ku.dk/"
+SRC_URI="http://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
+
+SLOT="0"
+LICENSE="all-rights-reserved"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+python_prepare_all() {
+ sed -e "/exclude/s:scripts:\', \'Tests:g" \
+ -i setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ cd Tests || die
+ ${PYTHON} runtest.py || die
+}