summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-22 22:09:16 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-22 22:09:16 +0000
commite9641b52df911cd2d1f33c3dc7740e79ab76c317 (patch)
treee560df5e9e23895a076faafb96b5c92b19180176 /sci-chemistry/pymol-plugins-msms
parentold (diff)
downloadgentoo-2-e9641b52df911cd2d1f33c3dc7740e79ab76c317.tar.gz
gentoo-2-e9641b52df911cd2d1f33c3dc7740e79ab76c317.tar.bz2
gentoo-2-e9641b52df911cd2d1f33c3dc7740e79ab76c317.zip
Restrict Jython ABIs. Simplify installation.
(Portage version: 2.2.0_alpha28_p4/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/pymol-plugins-msms')
-rw-r--r--sci-chemistry/pymol-plugins-msms/pymol-plugins-msms-100415.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/sci-chemistry/pymol-plugins-msms/pymol-plugins-msms-100415.ebuild b/sci-chemistry/pymol-plugins-msms/pymol-plugins-msms-100415.ebuild
index cda68386e9e1..63eb8e827b0f 100644
--- a/sci-chemistry/pymol-plugins-msms/pymol-plugins-msms-100415.ebuild
+++ b/sci-chemistry/pymol-plugins-msms/pymol-plugins-msms-100415.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol-plugins-msms/pymol-plugins-msms-100415.ebuild,v 1.2 2011/03/22 21:09:25 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol-plugins-msms/pymol-plugins-msms-100415.ebuild,v 1.3 2011/03/22 22:09:16 arfrever Exp $
EAPI="3"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
inherit eutils python
@@ -35,15 +35,14 @@ src_prepare() {
-e "s:GENTOOMSMS:${EPREFIX}/opt/bin/msms:g" \
-e "s:GENTOOXYZRN:${EPREFIX}/usr/bin/pdb_to_xyzrn:g" \
-i ${A} || die
- python_copy_sources
}
src_install() {
installation() {
- insinto $(python_get_sitedir)/pmg_tk/startup/
- doins ${P}.py || die
+ insinto $(python_get_sitedir)/pmg_tk/startup
+ doins ${P}.py
}
- python_execute_function -s installation
+ python_execute_function installation
}
pkg_postinst() {