summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-02-01 21:48:58 +0000
committerJustin Lecher <jlec@gentoo.org>2010-02-01 21:48:58 +0000
commitab6db68722f3ac1825d753d4168ec31c601ea445 (patch)
tree4cc3dfb3067523ce86d94033b66c87a914a2ef93 /sci-chemistry/pymol
parentMarking vim-core-7.2.303 ppc for bug 301975 (diff)
downloadgentoo-2-ab6db68722f3ac1825d753d4168ec31c601ea445.tar.gz
gentoo-2-ab6db68722f3ac1825d753d4168ec31c601ea445.tar.bz2
gentoo-2-ab6db68722f3ac1825d753d4168ec31c601ea445.zip
vmd and numpy added to IUSE
apbs plugin support now depends on sci-chemistry/pymol-apbs-plugin (Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/pymol')
-rw-r--r--sci-chemistry/pymol/ChangeLog9
-rw-r--r--sci-chemistry/pymol/files/pymol-1.2.2-vmd.patch33
-rw-r--r--sci-chemistry/pymol/metadata.xml2
-rw-r--r--sci-chemistry/pymol/pymol-1.2.2-r1.ebuild108
4 files changed, 151 insertions, 1 deletions
diff --git a/sci-chemistry/pymol/ChangeLog b/sci-chemistry/pymol/ChangeLog
index 8e3da3dcf330..ce97881c561c 100644
--- a/sci-chemistry/pymol/ChangeLog
+++ b/sci-chemistry/pymol/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-chemistry/pymol
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol/ChangeLog,v 1.51 2010/02/01 20:42:43 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol/ChangeLog,v 1.52 2010/02/01 21:48:57 jlec Exp $
+
+*pymol-1.2.2-r1 (01 Feb 2010)
+
+ 01 Feb 2010; Justin Lecher (jlec) <jlec@gentoo.org>
+ +pymol-1.2.2-r1.ebuild, +files/pymol-1.2.2-vmd.patch, metadata.xml:
+ vmd and numpy added to IUSE
+ apbs plugin support now depends on sci-chemistry/pymol-apbs-plugin
01 Feb 2010; Justin Lecher (jlec) <jlec@gentoo.org> pymol-1.2.1.ebuild,
pymol-1.2.2.ebuild:
diff --git a/sci-chemistry/pymol/files/pymol-1.2.2-vmd.patch b/sci-chemistry/pymol/files/pymol-1.2.2-vmd.patch
new file mode 100644
index 000000000000..1355abe22093
--- /dev/null
+++ b/sci-chemistry/pymol/files/pymol-1.2.2-vmd.patch
@@ -0,0 +1,33 @@
+Index: setup.py
+===================================================================
+--- setup.py (revision 3887)
++++ setup.py (working copy)
+@@ -123,8 +123,8 @@
+ "/usr/include/freetype2",
+ # "/users/warren/ext/include",
+ # VMD plugin support
+-# "contrib/uiuc/plugins/include",
+-# "contrib/uiuc/plugins/molfile_plugin/src",
++ "contrib/uiuc/plugins/include",
++ "contrib/uiuc/plugins/molfile_plugin/src",
+ ]
+ libs=["GL","GLU","glut","png","z","freetype",
+ # "Xxf86vm"
+@@ -143,7 +143,7 @@
+ # Numeric Python support
+ # ("_PYMOL_NUMPY",None),
+ # VMD plugin support
+-# ("_PYMOL_VMD_PLUGINS",None)
++ ("_PYMOL_VMD_PLUGINS",None)
+ ]
+ ext_comp_args=["-ffast-math","-funroll-loops","-O3"]
+ ext_link_args=[]
+@@ -290,7 +290,7 @@
+ "layer5/main.c"
+ # VMD plugin support
+ # switch the 0 to 1 to activate the additional source code
+- ] + 0 * [
++ ] + 1 * [
+ # (incomplete support -- only TRJ, TRR, XTC, DCD so far...)
+ 'contrib/uiuc/plugins/molfile_plugin/src/PlugIOManagerInit.c',
+ 'contrib/uiuc/plugins/molfile_plugin/src/avsplugin.cpp',
diff --git a/sci-chemistry/pymol/metadata.xml b/sci-chemistry/pymol/metadata.xml
index 41c9ec230233..4a1b6bfe8bb6 100644
--- a/sci-chemistry/pymol/metadata.xml
+++ b/sci-chemistry/pymol/metadata.xml
@@ -7,6 +7,8 @@
</maintainer>
<use>
<flag name="apbs">Install the apbs plugin</flag>
+ <flag name="numpy">Compile numpy support</flag>
<flag name="shaders">Build with Shaders support - good for high-end 3D video cards.</flag>
+ <flag name="vmd">Enable vmd module for trajectories</flag>
</use>
</pkgmetadata>
diff --git a/sci-chemistry/pymol/pymol-1.2.2-r1.ebuild b/sci-chemistry/pymol/pymol-1.2.2-r1.ebuild
new file mode 100644
index 000000000000..82d774f32f18
--- /dev/null
+++ b/sci-chemistry/pymol/pymol-1.2.2-r1.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol/pymol-1.2.2-r1.ebuild,v 1.1 2010/02/01 21:48:57 jlec Exp $
+
+EAPI="2"
+
+inherit distutils
+
+PYTHON_MODNAME="chempy pmg_tk pymol"
+REV="3859"
+
+DESCRIPTION="A Python-extensible molecular graphics system."
+HOMEPAGE="http://pymol.sourceforge.net/"
+SRC_URI="http://pymol.svn.sourceforge.net/viewvc/pymol/trunk/pymol.tar.gz?view=tar&pathrev=${REV} -> ${P}.tar.gz"
+
+LICENSE="PSF-2.2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="apbs numpy shaders vmd"
+
+DEPEND=">=dev-lang/python-2.4[tk]
+ dev-python/numpy
+ dev-python/pmw
+ media-libs/freetype:2
+ media-libs/libpng
+ media-video/mpeg-tools
+ sys-libs/zlib
+ virtual/glut
+ apbs? (
+ dev-libs/maloc
+ sci-chemistry/apbs
+ sci-chemistry/pdb2pqr
+ sci-chemistry/pymol-apbs-plugin
+ )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${PN}
+
+pkg_setup(){
+ python_version
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/1.2.1/${PN}-1.2.1-data-path.patch \
+ || die "Failed to apply data-path.patch"
+
+ # Turn off splash screen. Please do make a project contribution
+ # if you are able though. #299020
+ epatch "${FILESDIR}"/1.2.1/nosplash-gentoo.patch
+
+ # Respect CFLAGS
+ sed -i \
+ -e "s:\(ext_comp_args=\).*:\1[]:g" \
+ "${S}"/setup.py || die "Failed running sed on setup.py"
+
+ use shaders && epatch "${FILESDIR}"/${P}-shaders.patch
+
+ if use apbs; then
+ cp -f "${WORKDIR}"/apbs_tools.py.${APBS_PATCH} modules/pmg_tk/startup/apbs_tools.py \
+ || die "Failed to copy apbs_tools.py"
+
+ sed "s:LIBANDPYTHON:$(python_get_libdir):g" \
+ -i modules/pmg_tk/startup/apbs_tools.py \
+ || die "Failed running sed on apbs_tools.py"
+ fi
+
+ use vmd && epatch "${FILESDIR}"/${P}-vmd.patch
+
+ use numpy && \
+ sed \
+ -e '/PYMOL_NUMPY/s:^#::g' \
+ -i setup.py
+}
+
+src_configure() {
+ :
+}
+
+src_install() {
+ distutils_src_install
+
+ # These environment variables should not go in the wrapper script, or else
+ # it will be impossible to use the PyMOL libraries from Python.
+ cat >> "${T}"/20pymol <<- EOF
+ PYMOL_PATH=$(python_get_sitedir)/${PN}
+ PYMOL_DATA="/usr/share/pymol/data"
+ PYMOL_SCRIPTS="/usr/share/pymol/scripts"
+ EOF
+
+ doenvd "${T}"/20pymol || die "Failed to install env.d file."
+
+ cat >> "${T}"/pymol <<- EOF
+ #!/bin/sh
+ ${python} -O \${PYMOL_PATH}/__init__.py \$*
+ EOF
+
+ dobin "${T}"/pymol || die "Failed to install wrapper."
+
+ insinto /usr/share/pymol
+ doins -r test data scripts || die "no shared data"
+
+ insinto /usr/share/pymol/examples
+ doins -r examples || die "Failed to install docs."
+
+ dodoc DEVELOPERS README || die "Failed to install docs."
+
+ rm "${D}"$(python_get_sitedir)/pmg_tk/startup/apbs_tools.py
+}