summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2008-07-08 03:06:29 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2008-07-08 03:06:29 +0000
commitf3330b294a5e003dcf659366b12cfd577bd037ba (patch)
treee8b171200e523cad1afbbd483ccbc70113beb22a /sci-chemistry/raster3d
parentCorrected install to remove extraneous frontends when USE=fax is not set (diff)
downloadgentoo-2-f3330b294a5e003dcf659366b12cfd577bd037ba.tar.gz
gentoo-2-f3330b294a5e003dcf659366b12cfd577bd037ba.tar.bz2
gentoo-2-f3330b294a5e003dcf659366b12cfd577bd037ba.zip
(#231118) Bump. Small cleanup of make->emake so MAKEOPTS are respected.
(Portage version: 2.2_rc1/cvs/Linux 2.6.26-rc8 x86_64)
Diffstat (limited to 'sci-chemistry/raster3d')
-rw-r--r--sci-chemistry/raster3d/ChangeLog10
-rw-r--r--sci-chemistry/raster3d/raster3d-2.7s.ebuild58
2 files changed, 66 insertions, 2 deletions
diff --git a/sci-chemistry/raster3d/ChangeLog b/sci-chemistry/raster3d/ChangeLog
index 29228fa38b07..03528b7b950c 100644
--- a/sci-chemistry/raster3d/ChangeLog
+++ b/sci-chemistry/raster3d/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/raster3d
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/raster3d/ChangeLog,v 1.13 2007/09/10 12:55:59 markusle Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/raster3d/ChangeLog,v 1.14 2008/07/08 03:06:28 dberkholz Exp $
+
+*raster3d-2.7s (08 Jul 2008)
+
+ 08 Jul 2008; Donnie Berkholz <dberkholz@gentoo.org>;
+ +raster3d-2.7s.ebuild:
+ (#231118) Bump. Small cleanup of make->emake so MAKEOPTS are respected.
*raster3d-2.7d (08 Sep 2007)
diff --git a/sci-chemistry/raster3d/raster3d-2.7s.ebuild b/sci-chemistry/raster3d/raster3d-2.7s.ebuild
new file mode 100644
index 000000000000..e61fab78b017
--- /dev/null
+++ b/sci-chemistry/raster3d/raster3d-2.7s.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/raster3d/raster3d-2.7s.ebuild,v 1.1 2008/07/08 03:06:29 dberkholz Exp $
+
+inherit toolchain-funcs fortran
+
+NAME="Raster3D"
+
+DESCRIPTION="a set of tools for generating high quality raster images of proteins or other molecules"
+LICENSE="as-is"
+HOMEPAGE="http://www.bmsc.washington.edu/raster3d/raster3d.html"
+SRC_URI="http://www.bmsc.washington.edu/${PN}/${NAME}_${PV}.tar.gz"
+
+SLOT="0"
+IUSE=""
+KEYWORDS="~ppc ~x86"
+
+RDEPEND="media-libs/jpeg
+ media-libs/libpng
+ media-libs/tiff"
+
+DEPEND="${RDEPEND}
+ x11-misc/imake"
+
+S="${WORKDIR}/${NAME}_${PV}"
+
+src_compile() {
+ cd "${S}"
+
+ # fix Makefile to honor user's CFLAGS/FFLAGS
+ sed -e "s:gcc:$(tc-getCC):" \
+ -e "s:g77:${FORTRANC}:" \
+ -e "s:-g -m486 -w:${CFLAGS}:" \
+ -e "s:-g -O -w -malign-double:${FFLAGS} -w:" \
+ -i Makefile || die "Failed to patch makefile"
+
+ sed -e "s:prefix = /usr/local:prefix = /usr:" \
+ -i Makefile.template || \
+ die "Failed to patch makefile.template"
+
+ emake linux || die "Failed to make linux target."
+ emake all || die "Failed to make all target."
+}
+
+src_install() {
+ emake prefix="${D}"/usr \
+ bindir="${D}"/usr/bin \
+ datadir="${D}"/usr/share/Raster3D/materials \
+ mandir="${D}"/usr/share/man/man1 \
+ htmldir="${D}"/usr/share/Raster3D/html \
+ examdir="${D}"/usr/share/Raster3D/examples \
+ install || die "Failed to install application."
+
+ dodir /etc/env.d
+ echo -e "R3D_LIB=/usr/share/${NAME}/materials" > \
+ "${D}"/etc/env.d/10raster3d || \
+ die "Failed to install env file."
+}