summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-06-25 17:21:42 +0000
committerJustin Lecher <jlec@gentoo.org>2010-06-25 17:21:42 +0000
commit7a04e2da1351fa3c5f2bdcdb801731eb75153e36 (patch)
tree98965136ee145e595d37151c91d94938a05670e4 /sci-chemistry/wxmacmolplt
parentRemoved forced pic (diff)
downloadgentoo-2-7a04e2da1351fa3c5f2bdcdb801731eb75153e36.tar.gz
gentoo-2-7a04e2da1351fa3c5f2bdcdb801731eb75153e36.tar.bz2
gentoo-2-7a04e2da1351fa3c5f2bdcdb801731eb75153e36.zip
Removed old, fixes for gl handling and flash support
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/wxmacmolplt')
-rw-r--r--sci-chemistry/wxmacmolplt/ChangeLog10
-rw-r--r--sci-chemistry/wxmacmolplt/files/wxmacmolplt-7.4-flash.patch28
-rw-r--r--sci-chemistry/wxmacmolplt/files/wxmacmolplt-7.4-glew.patch39
-rw-r--r--sci-chemistry/wxmacmolplt/wxmacmolplt-7.3.ebuild34
-rw-r--r--sci-chemistry/wxmacmolplt/wxmacmolplt-7.4-r1.ebuild (renamed from sci-chemistry/wxmacmolplt/wxmacmolplt-7.3-r1.ebuild)21
-rw-r--r--sci-chemistry/wxmacmolplt/wxmacmolplt-7.4.ebuild40
6 files changed, 88 insertions, 84 deletions
diff --git a/sci-chemistry/wxmacmolplt/ChangeLog b/sci-chemistry/wxmacmolplt/ChangeLog
index 34f74256cd24..f1a9b9d70e51 100644
--- a/sci-chemistry/wxmacmolplt/ChangeLog
+++ b/sci-chemistry/wxmacmolplt/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-chemistry/wxmacmolplt
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/wxmacmolplt/ChangeLog,v 1.6 2010/06/25 09:57:43 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/wxmacmolplt/ChangeLog,v 1.7 2010/06/25 17:21:42 jlec Exp $
+
+*wxmacmolplt-7.4-r1 (25 Jun 2010)
+
+ 25 Jun 2010; Justin Lecher <jlec@gentoo.org> -wxmacmolplt-7.3.ebuild,
+ -wxmacmolplt-7.3-r1.ebuild, -wxmacmolplt-7.4.ebuild,
+ +wxmacmolplt-7.4-r1.ebuild, +files/wxmacmolplt-7.4-flash.patch,
+ +files/wxmacmolplt-7.4-glew.patch:
+ Removed old, fixes for gl handling and flash support
25 Jun 2010; Justin Lecher <jlec@gentoo.org> wxmacmolplt-7.4.ebuild:
Restrict ming to <0.4
diff --git a/sci-chemistry/wxmacmolplt/files/wxmacmolplt-7.4-flash.patch b/sci-chemistry/wxmacmolplt/files/wxmacmolplt-7.4-flash.patch
new file mode 100644
index 000000000000..954a47fb4fd9
--- /dev/null
+++ b/sci-chemistry/wxmacmolplt/files/wxmacmolplt-7.4-flash.patch
@@ -0,0 +1,28 @@
+--- src/swfexport.cpp.orig 2008-12-09 03:29:53.000000000 +0100
++++ src/swfexport.cpp 2010-06-25 14:29:41.788052169 +0200
+@@ -204,11 +204,11 @@
+ movie->nextFrame();
+ movie->remove(di);
+ movie->remove(textDI);
+- delete di;
+- delete textDI;
++ //delete di;
++ //delete textDI;
+ if(includeEP) {
+ movie->remove(di2);
+- delete di2;
++ // delete di2;
+ }
+ }
+
+@@ -366,8 +366,8 @@
+ movie->nextFrame();
+ movie->remove(di);
+ movie->remove(textDI);
+- delete di;
+- delete textDI;
++ //delete di;
++ //delete textDI;
+
+ for (iatm=0; iatm<(lFrame->NumAtoms); iatm++) {
+ lAtoms[iatm].Position.x += offsetFactor * (ModeOffset[iatm].x); \ No newline at end of file
diff --git a/sci-chemistry/wxmacmolplt/files/wxmacmolplt-7.4-glew.patch b/sci-chemistry/wxmacmolplt/files/wxmacmolplt-7.4-glew.patch
new file mode 100644
index 000000000000..95ae3da3eed4
--- /dev/null
+++ b/sci-chemistry/wxmacmolplt/files/wxmacmolplt-7.4-glew.patch
@@ -0,0 +1,39 @@
+diff --git a/configure.ac b/configure.ac
+index 5e88d06..311abfe 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -20,7 +20,7 @@ case "${host}" in
+ ;;
+ *)
+ HOST=LINUX
+- LIBGL="-lGL -lGLU"
++ LIBGL=`pkg-config --libs glu glew`
+ ;;
+ esac
+ AM_CONDITIONAL(HOST_IS_MSW, [test "x$HOST" == xMSW])
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 4d47ea3..3cb6614 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -24,8 +24,6 @@ wxmacmolplt_SOURCES = \
+ frequenciesdialog.cpp frequenciesdialog.h \
+ GaussHermite.cpp GaussHermite.h \
+ Geometries.cpp Geometries.h \
+- glew.cpp glew.h \
+- glxew.h wglew.h \
+ glf.cpp glf.h \
+ GlobalExceptions.h \
+ Globals.h \
+diff --git a/src/mmp_gl.h b/src/mmp_gl.h
+index daa1eb7..1345b90 100644
+--- a/src/mmp_gl.h
++++ b/src/mmp_gl.h
+@@ -1,7 +1,7 @@
+ #ifndef MMP_GL_H
+ #define MMP_GL_H
+
+-#include "glew.h"
++#include <GL/glew.h>
+ #include <wx/wx.h>
+ #include <wx/glcanvas.h>
+ #include <string>
diff --git a/sci-chemistry/wxmacmolplt/wxmacmolplt-7.3.ebuild b/sci-chemistry/wxmacmolplt/wxmacmolplt-7.3.ebuild
deleted file mode 100644
index d58b4e53de1f..000000000000
--- a/sci-chemistry/wxmacmolplt/wxmacmolplt-7.3.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/wxmacmolplt/wxmacmolplt-7.3.ebuild,v 1.4 2010/03/09 11:39:54 abcd Exp $
-
-EAPI="2"
-WX_GTK_VER=2.8
-
-inherit base eutils wxwidgets
-
-DESCRIPTION="Chemical 3D graphics program with GAMESS input builder"
-HOMEPAGE="http://www.scl.ameslab.gov/MacMolPlt/"
-
-SRC_URI="http://www.scl.ameslab.gov/MacMolPlt/download/${P}.tar.gz"
-LICENSE="GPL-2"
-
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-
-IUSE="flash"
-
-DEPEND="x11-libs/wxGTK:2.8[X,opengl]
- flash? ( media-libs/ming )"
-
-RDEPEND="${DEPEND}"
-
-src_configure() {
- econf $(use_with flash ming)
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "install failed"
- doicon resources/${PN}.png
- make_desktop_entry ${PN} wxMacMolPlt ${PN} "Science;Education"
-}
diff --git a/sci-chemistry/wxmacmolplt/wxmacmolplt-7.3-r1.ebuild b/sci-chemistry/wxmacmolplt/wxmacmolplt-7.4-r1.ebuild
index ee589e27e9db..2b603d9ba716 100644
--- a/sci-chemistry/wxmacmolplt/wxmacmolplt-7.3-r1.ebuild
+++ b/sci-chemistry/wxmacmolplt/wxmacmolplt-7.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/wxmacmolplt/wxmacmolplt-7.3-r1.ebuild,v 1.3 2010/03/09 11:39:54 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/wxmacmolplt/wxmacmolplt-7.4-r1.ebuild,v 1.1 2010/06/25 17:21:42 jlec Exp $
EAPI="2"
WX_GTK_VER=2.8
@@ -9,21 +9,24 @@ inherit base eutils autotools wxwidgets
DESCRIPTION="Chemical 3D graphics program with GAMESS input builder"
HOMEPAGE="http://www.scl.ameslab.gov/MacMolPlt/"
-
SRC_URI="http://www.scl.ameslab.gov/MacMolPlt/download/${P}.tar.gz"
-LICENSE="GPL-2"
+LICENSE="GPL-2"
KEYWORDS="~amd64 ~x86"
SLOT="0"
-
IUSE="flash"
-DEPEND="x11-libs/wxGTK:2.8[X,opengl]
- flash? ( media-libs/ming )"
-
-RDEPEND="${DEPEND}"
+RDEPEND="
+ >=media-libs/glew-1.5.3
+ media-libs/mesa
+ x11-libs/wxGTK:2.8[X,opengl]
+ flash? ( <media-libs/ming-0.4 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
src_prepare() {
+ epatch "${FILESDIR}"/${P}-glew.patch
+ epatch "${FILESDIR}"/${P}-flash.patch
sed -i -e "/^dist_doc_DATA/d" Makefile.am \
|| die "Failed to disable installation of LICENSE file"
eautoreconf
@@ -35,6 +38,6 @@ src_configure() {
src_install() {
emake DESTDIR="${D}" install || die "install failed"
- doicon resources/${PN}.png
+ doicon resources/${PN}.png || die
make_desktop_entry ${PN} wxMacMolPlt ${PN} "Science;Education"
}
diff --git a/sci-chemistry/wxmacmolplt/wxmacmolplt-7.4.ebuild b/sci-chemistry/wxmacmolplt/wxmacmolplt-7.4.ebuild
deleted file mode 100644
index bb9d1213ac86..000000000000
--- a/sci-chemistry/wxmacmolplt/wxmacmolplt-7.4.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/wxmacmolplt/wxmacmolplt-7.4.ebuild,v 1.4 2010/06/25 09:57:43 jlec Exp $
-
-EAPI="2"
-WX_GTK_VER=2.8
-
-inherit base eutils autotools wxwidgets
-
-DESCRIPTION="Chemical 3D graphics program with GAMESS input builder"
-HOMEPAGE="http://www.scl.ameslab.gov/MacMolPlt/"
-
-SRC_URI="http://www.scl.ameslab.gov/MacMolPlt/download/${P}.tar.gz"
-LICENSE="GPL-2"
-
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-
-IUSE="flash"
-
-DEPEND="x11-libs/wxGTK:2.8[X,opengl]
- flash? ( <media-libs/ming-0.4 )"
-
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- sed -i -e "/^dist_doc_DATA/d" Makefile.am \
- || die "Failed to disable installation of LICENSE file"
- eautoreconf
-}
-
-src_configure() {
- econf $(use_with flash ming)
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "install failed"
- doicon resources/${PN}.png
- make_desktop_entry ${PN} wxMacMolPlt ${PN} "Science;Education"
-}