summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-03-26 11:20:40 +0000
committerJustin Lecher <jlec@gentoo.org>2014-03-26 11:20:40 +0000
commit0f057197d64bd84b95255eef0aa40abf3f6dd4c3 (patch)
treeed2535ddc32d732ecfea5334018f4f8e371fcb14 /sci-chemistry
parentStable for amd64 wrt bug #504558 (diff)
downloadgentoo-2-0f057197d64bd84b95255eef0aa40abf3f6dd4c3.tar.gz
gentoo-2-0f057197d64bd84b95255eef0aa40abf3f6dd4c3.tar.bz2
gentoo-2-0f057197d64bd84b95255eef0aa40abf3f6dd4c3.zip
sci-chemistry/ball: Version BUmp
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/ball/ChangeLog13
-rw-r--r--sci-chemistry/ball/ball-1.4.1-r1.ebuild8
-rw-r--r--sci-chemistry/ball/ball-1.4.2.ebuild82
-rw-r--r--sci-chemistry/ball/files/ball-1.4.2-Fix-compilation-of-sipModularWidget.patch40
-rw-r--r--sci-chemistry/ball/files/ball-1.4.2-PDBFile-Fix-compilation-with-gcc-4.8.patch28
-rw-r--r--sci-chemistry/ball/files/ball-1.4.2-QT4_EXTRACT_OPTIONS-CMake-macro-changed-in-CMake-2.8.patch44
6 files changed, 208 insertions, 7 deletions
diff --git a/sci-chemistry/ball/ChangeLog b/sci-chemistry/ball/ChangeLog
index af2208ce4d81..86793ce83543 100644
--- a/sci-chemistry/ball/ChangeLog
+++ b/sci-chemistry/ball/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sci-chemistry/ball
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ball/ChangeLog,v 1.12 2013/09/05 19:03:42 mgorny Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ball/ChangeLog,v 1.13 2014/03/26 11:20:39 jlec Exp $
+
+*ball-1.4.2 (26 Mar 2014)
+
+ 26 Mar 2014; Justin Lecher <jlec@gentoo.org> ball-1.4.1-r1.ebuild,
+ +ball-1.4.2.ebuild,
+ +files/ball-1.4.2-Fix-compilation-of-sipModularWidget.patch,
+ +files/ball-1.4.2-PDBFile-Fix-compilation-with-gcc-4.8.patch,
+ +files/ball-1.4.2-QT4_EXTRACT_OPTIONS-CMake-macro-changed-in-CMake-2.8.patch:
+ Version BUmp
05 Sep 2013; Michał Górny <mgorny@gentoo.org> ball-1.4.1-r1.ebuild:
Clean up PYTHON_COMPAT from old implementations.
diff --git a/sci-chemistry/ball/ball-1.4.1-r1.ebuild b/sci-chemistry/ball/ball-1.4.1-r1.ebuild
index c6eaa4f0bb2f..ba23080fc497 100644
--- a/sci-chemistry/ball/ball-1.4.1-r1.ebuild
+++ b/sci-chemistry/ball/ball-1.4.1-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ball/ball-1.4.1-r1.ebuild,v 1.6 2013/09/05 19:03:42 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ball/ball-1.4.1-r1.ebuild,v 1.7 2014/03/26 11:20:39 jlec Exp $
EAPI=5
@@ -61,9 +61,7 @@ PATCHES=(
)
pkg_setup() {
- use python \
- && python_set_active_version 2 \
- && python_pkg_setup
+ use python && python-single-r1_pkg_setup
}
src_configure() {
diff --git a/sci-chemistry/ball/ball-1.4.2.ebuild b/sci-chemistry/ball/ball-1.4.2.ebuild
new file mode 100644
index 000000000000..3c8129aa4d6b
--- /dev/null
+++ b/sci-chemistry/ball/ball-1.4.2.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ball/ball-1.4.2.ebuild,v 1.1 2014/03/26 11:20:39 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit cmake-utils python-single-r1
+
+DESCRIPTION="Biochemical Algorithms Library"
+HOMEPAGE="http://www.ball-project.org/"
+SRC_URI="http://www.ball-project.org/Downloads/v${PV}/BALL-${PV}.tar.xz"
+
+SLOT="0"
+LICENSE="LGPL-2 GPL-3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="cuda mpi +python sql test +threads +webkit"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ dev-cpp/eigen:3
+ dev-libs/boost
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtopengl:4
+ dev-qt/qttest:4
+ dev-qt/qtwebkit:4
+ media-libs/glew
+ sci-libs/fftw:3.0[threads?]
+ sci-libs/gsl
+ sci-libs/libsvm
+ sci-mathematics/lpsolve
+ virtual/opengl
+ x11-libs/libX11
+ cuda? ( dev-util/nvidia-cuda-toolkit )
+ mpi? ( virtual/mpi )
+ python? ( ${PYTHON_DEPS} )
+ sql? ( dev-qt/qtsql:4 )
+ webkit? ( dev-qt/qtwebkit:4 )"
+DEPEND="${RDEPEND}
+ dev-python/sip
+ sys-devel/bison
+ virtual/yacc"
+
+S="${WORKDIR}"/BALL-${PV}
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.4.1-multilib.patch
+ "${FILESDIR}"/${PN}-1.4.1-missing-signed.patch
+ "${FILESDIR}"/${P}-PDBFile-Fix-compilation-with-gcc-4.8.patch
+ "${FILESDIR}"/${P}-QT4_EXTRACT_OPTIONS-CMake-macro-changed-in-CMake-2.8.patch
+ "${FILESDIR}"/${PN}-1.4.1-BondOrder.xml.patch
+ "${FILESDIR}"/${P}-Fix-compilation-of-sipModularWidget.patch
+ )
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_use threads FFTW_THREADS)
+ $(cmake-utils_use cuda MT_ENABLE_CUDA)
+ $(cmake-utils_use mpi MT_ENABLE_MPI)
+ $(cmake-utils_use sql BALL_HAS_QTSQL)
+ $(cmake-utils_use_use webkit USE_QTWEBKIT)
+ $(cmake-utils_use python BALL_PYTHON_SUPPORT)
+ )
+ cmake-utils_src_configure
+ local i
+ for i in "${S}"/data/*; do
+ ln -sf "${i}" "${BUILD_DIR}"/source/TEST/ || die
+ ln -sf "${i}" "${S}"/source/TEST/ || die
+ done
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ use test && cmake-utils_src_make build_tests
+}
diff --git a/sci-chemistry/ball/files/ball-1.4.2-Fix-compilation-of-sipModularWidget.patch b/sci-chemistry/ball/files/ball-1.4.2-Fix-compilation-of-sipModularWidget.patch
new file mode 100644
index 000000000000..3ec2f6e983a8
--- /dev/null
+++ b/sci-chemistry/ball/files/ball-1.4.2-Fix-compilation-of-sipModularWidget.patch
@@ -0,0 +1,40 @@
+From da49802f8620562f91ac2c947520dccd223ee26b Mon Sep 17 00:00:00 2001
+From: Andreas Hildebrandt <andreas.hildebrandt@uni-mainz.de>
+Date: Wed, 15 Jan 2014 17:42:01 +0100
+Subject: [PATCH] Fix compilation of sipModularWidget
+
+---
+ source/PYTHON/EXTENSIONS/VIEW/modularWidget.sip | 10 +++++-----
+ 1 file changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/source/PYTHON/EXTENSIONS/VIEW/modularWidget.sip b/source/PYTHON/EXTENSIONS/VIEW/modularWidget.sip
+index 522b0ed..7b8ba3e 100644
+--- a/source/PYTHON/EXTENSIONS/VIEW/modularWidget.sip
++++ b/source/PYTHON/EXTENSIONS/VIEW/modularWidget.sip
+@@ -22,18 +22,18 @@ class ModularWidget
+ static Size countInstances();
+ static ModularWidget* getInstance(Position);
+
+- ModularWidget(const char* = "<ModularWidget>") throw();
+- ModularWidget(const ModularWidget&) throw();
++ ModularWidget(const char* = "<ModularWidget>");
++ ModularWidget(const ModularWidget&);
+ ~ModularWidget() throw();
+
+- virtual void destroy() throw();
+- virtual void clear() throw();
++// virtual void destroy();
++ virtual void clear();
+
+ static void registerWidget(ModularWidget*) throw(NullPointer);
+ // virtual void initializeWidget(MainControl&);
+ // virtual void finalizeWidget(MainControl&);
+ virtual void checkMenu(MainControl&) throw();
+-// virtual void initializePreferencesTab(Preferences&) throw();
++// virtual void initializePreferencesTab(Preferences&);
+ // virtual void finalizePreferencesTab(Preferences&) throw();
+ virtual void applyPreferences() throw();
+ virtual void fetchPreferences(INIFile&) throw();
+--
+1.9.1
+
diff --git a/sci-chemistry/ball/files/ball-1.4.2-PDBFile-Fix-compilation-with-gcc-4.8.patch b/sci-chemistry/ball/files/ball-1.4.2-PDBFile-Fix-compilation-with-gcc-4.8.patch
new file mode 100644
index 000000000000..f6b8ff45fa7f
--- /dev/null
+++ b/sci-chemistry/ball/files/ball-1.4.2-PDBFile-Fix-compilation-with-gcc-4.8.patch
@@ -0,0 +1,28 @@
+From e7cc50705bed20e160bd4b637b23f57270f580a8 Mon Sep 17 00:00:00 2001
+From: Daniel Stoeckel <dstoeckel@bioinf.uni-sb.de>
+Date: Sat, 6 Apr 2013 01:06:55 +0200
+Subject: [PATCH] PDBFile:Fix compilation with gcc 4.8
+
+Apparently the automatic conversion from boost::shared_ptr<CrystalInfo>
+to boost::shared_ptr<PersistentObject> is no longer supported.
+Just change the type of the pointer and work around this issue.
+---
+ source/FORMAT/PDBFileDetails.C | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/source/FORMAT/PDBFileDetails.C b/source/FORMAT/PDBFileDetails.C
+index 97c2572..aedc5db 100644
+--- a/source/FORMAT/PDBFileDetails.C
++++ b/source/FORMAT/PDBFileDetails.C
+@@ -901,7 +901,7 @@ namespace BALL
+ {
+ if (!(current_protein_->hasProperty("CRYSTALINFO")))
+ {
+- boost::shared_ptr<CrystalInfo> temp_ptr(new CrystalInfo());
++ boost::shared_ptr<PersistentObject> temp_ptr(new CrystalInfo());
+ current_protein_->setProperty(NamedProperty("CRYSTALINFO", temp_ptr));
+ }
+
+--
+1.9.1
+
diff --git a/sci-chemistry/ball/files/ball-1.4.2-QT4_EXTRACT_OPTIONS-CMake-macro-changed-in-CMake-2.8.patch b/sci-chemistry/ball/files/ball-1.4.2-QT4_EXTRACT_OPTIONS-CMake-macro-changed-in-CMake-2.8.patch
new file mode 100644
index 000000000000..615a92290805
--- /dev/null
+++ b/sci-chemistry/ball/files/ball-1.4.2-QT4_EXTRACT_OPTIONS-CMake-macro-changed-in-CMake-2.8.patch
@@ -0,0 +1,44 @@
+From 1e76c9cb1920e9176b725269985c7eb43126d188 Mon Sep 17 00:00:00 2001
+From: Luis de la Garza <delagarza@informatik.uni-tuebingen.de>
+Date: Fri, 22 Nov 2013 15:18:55 +0100
+Subject: [PATCH] QT4_EXTRACT_OPTIONS CMake macro changed in CMake 2.8.12;
+ fixed BALLMacros.cmake
+
+---
+ cmake/BALLMacros.cmake | 14 ++++++++++----
+ 1 file changed, 10 insertions(+), 4 deletions(-)
+
+diff --git a/cmake/BALLMacros.cmake b/cmake/BALLMacros.cmake
+index f81ab89..0ac1b87 100644
+--- a/cmake/BALLMacros.cmake
++++ b/cmake/BALLMacros.cmake
+@@ -6,16 +6,22 @@
+ ### minor modifications (marked with ## BALL ###)
+ ###
+ MACRO(QT4_WRAP_UI_BALL outfiles )
+- QT4_EXTRACT_OPTIONS(ui_files ui_options ${ARGN})
+-
+- ### BALL ###
++ # since 2.8.12 qt4_extract_options has an additional argument
++ # copied fix from OpenMS
++ IF(${CMAKE_VERSION} VERSION_LESS "2.8.12")
++ QT4_EXTRACT_OPTIONS(ui_files ui_options ${ARGN})
++ ELSE()
++ QT4_EXTRACT_OPTIONS(ui_files ui_options ui_target ${ARGN})
++ ENDIF()
++
++ ### BALL ###
+ # create output directory (will not exist for out-of-source builds)
+ FILE(MAKE_DIRECTORY ${PROJECT_BINARY_DIR}/include/BALL/VIEW/UIC/)
+
+ FOREACH (it ${ui_files})
+ GET_FILENAME_COMPONENT(outfile ${it} NAME_WE)
+ GET_FILENAME_COMPONENT(infile ${it} ABSOLUTE)
+- ### BALL ###
++ ### BALL ###
+ SET(outfile ${PROJECT_BINARY_DIR}/include/BALL/VIEW/UIC/ui_${outfile}.h)
+ ADD_CUSTOM_COMMAND(OUTPUT ${outfile}
+ COMMAND ${QT_UIC_EXECUTABLE}
+--
+1.9.1
+