summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2008-05-29 13:29:10 +0000
committerMarkus Dittrich <markusle@gentoo.org>2008-05-29 13:29:10 +0000
commit44a568fc45f410f54599af876ac0c862dcb5158d (patch)
tree6609c65fc15a4eb25f27d490ff1011eee855bda4 /sci-chemistry
parentRemoving mask on catalyst 2.0.6 for wide-spread use. (diff)
downloadgentoo-2-44a568fc45f410f54599af876ac0c862dcb5158d.tar.gz
gentoo-2-44a568fc45f410f54599af876ac0c862dcb5158d.tar.bz2
gentoo-2-44a568fc45f410f54599af876ac0c862dcb5158d.zip
Version bump. Also fixed sed problems and added check for X useflag for cairo (see bug #223875).
(Portage version: 2.1.5.2)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/gperiodic/ChangeLog11
-rw-r--r--sci-chemistry/gperiodic/gperiodic-2.0.10.ebuild64
-rw-r--r--sci-chemistry/gperiodic/gperiodic-2.0.7.ebuild14
3 files changed, 83 insertions, 6 deletions
diff --git a/sci-chemistry/gperiodic/ChangeLog b/sci-chemistry/gperiodic/ChangeLog
index 2eeb0fe146b4..cf5308838247 100644
--- a/sci-chemistry/gperiodic/ChangeLog
+++ b/sci-chemistry/gperiodic/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-chemistry/gperiodic
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gperiodic/ChangeLog,v 1.6 2006/09/20 05:09:00 dberkholz Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gperiodic/ChangeLog,v 1.7 2008/05/29 13:29:10 markusle Exp $
+
+*gperiodic-2.0.10 (29 May 2008)
+
+ 29 May 2008; Markus Dittrich <markusle@gentoo.org> gperiodic-2.0.7.ebuild,
+ +gperiodic-2.0.10.ebuild:
+ Version bump. Also fixed sed problems and added check for X useflag for
+ cairo (see bug #223875).
20 Sep 2006; Donnie Berkholz <dberkholz@gentoo.org>; metadata.xml:
(#148281) Change herd to sci-chemistry from sci.
diff --git a/sci-chemistry/gperiodic/gperiodic-2.0.10.ebuild b/sci-chemistry/gperiodic/gperiodic-2.0.10.ebuild
new file mode 100644
index 000000000000..56bbf366476d
--- /dev/null
+++ b/sci-chemistry/gperiodic/gperiodic-2.0.10.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gperiodic/gperiodic-2.0.10.ebuild,v 1.1 2008/05/29 13:29:10 markusle Exp $
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="Periodic table application for Linux"
+SRC_URI="http://www.acclab.helsinki.fi/~frantz/software/${P}.tar.gz"
+HOMEPAGE="http://www.acclab.helsinki.fi/~frantz/software/gperiodic.php"
+
+KEYWORDS="~x86 ~amd64"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="nls"
+
+RDEPEND=">=sys-libs/ncurses-5.2
+ =x11-libs/gtk+-2*
+ nls? ( sys-devel/gettext )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ if ! built_with_use x11-libs/cairo X; then
+ die "gperiodic needs x11-libs/cairo emerged with USE=\"X\""
+ fi
+}
+
+src_compile() {
+ # The author has removed "unnecessary automake/autoconf setup"
+
+ sed -i -e "s|-DGTK_DISABLE_DEPRECATED|${CFLAGS}|" Makefile
+ sed -i -e "/make clean/d" Makefile
+ sed -i -e "s|CC=gcc|CC=$(tc-getCC)|" Makefile
+ if ! use nls; then
+ sed -i -e "/make -C po/d" Makefile
+ fi
+ emake || die "emake failed!"
+}
+
+src_install() {
+ sed -i -e "s|/usr/bin|${D}/usr/bin|" Makefile
+ sed -i -e "s|/usr/share|${D}/usr/share|" Makefile
+ sed -i -e "s|/usr/share|${D}/usr/share|" po/Makefile
+
+ # Create directories - Makefile is quite broken.
+ dodir /usr/bin
+ dodir /usr/share/pixmaps
+ dodir /usr/share/applications
+
+ make install || die "make install failed."
+
+ # Fix permissions
+ chmod 644 "${D}/usr/share/pixmaps/*"
+ chmod 644 "${D}/usr/share/applications/*"
+
+ # Fix the chemistry category in the .desktop file, bug 97202.
+ sed -i -e "s|Chemestry|Chemistry|" "${D}/usr/share/applications/gperiodic.desktop"
+
+ # The man page seems to have been removed too.
+# doman man/gperiodic.1
+ dodoc AUTHORS ChangeLog README NEWS
+ newdoc po/README README.translation
+}
diff --git a/sci-chemistry/gperiodic/gperiodic-2.0.7.ebuild b/sci-chemistry/gperiodic/gperiodic-2.0.7.ebuild
index b6f03287be70..81229d39e038 100644
--- a/sci-chemistry/gperiodic/gperiodic-2.0.7.ebuild
+++ b/sci-chemistry/gperiodic/gperiodic-2.0.7.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gperiodic/gperiodic-2.0.7.ebuild,v 1.5 2008/04/21 01:58:30 je_fro Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gperiodic/gperiodic-2.0.7.ebuild,v 1.6 2008/05/29 13:29:10 markusle Exp $
-inherit toolchain-funcs
+inherit toolchain-funcs eutils
DESCRIPTION="Periodic table application for Linux"
SRC_URI="http://www.acclab.helsinki.fi/~frantz/software/${P}.tar.gz"
@@ -20,14 +20,20 @@ RDEPEND=">=sys-libs/ncurses-5.2
DEPEND="${RDEPEND}
dev-util/pkgconfig"
+pkg_setup() {
+ if ! built_with_use x11-libs/cairo X; then
+ die "gperiodic needs x11-libs/cairo emerged with USE=\"X\""
+ fi
+}
+
src_compile() {
# The author has removed "unnecessary automake/autoconf setup"
sed -i -e "s|-DGTK_DISABLE_DEPRECATED|${CFLAGS}|" Makefile
- sed -i -e "|make clean|d" Makefile
+ sed -i -e "/make clean/d" Makefile
sed -i -e "s|CC=gcc|CC=$(tc-getCC)|" Makefile
if ! use nls; then
- sed -i -e "|make -C po|d" Makefile
+ sed -i -e "/make -C po/d" Makefile
fi
emake || die "emake failed!"
}