summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2011-01-10 12:37:33 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2011-01-10 12:37:33 +0000
commit6c6aac54378fe203d9e7f3c03e6127830bd86126 (patch)
treee39bc53150ebe96a28eb47c2f1fd3936cf465b37 /sci-chemistry
parentStable on amd64 wrt bug 344677 (diff)
downloadgentoo-2-6c6aac54378fe203d9e7f3c03e6127830bd86126.tar.gz
gentoo-2-6c6aac54378fe203d9e7f3c03e6127830bd86126.tar.bz2
gentoo-2-6c6aac54378fe203d9e7f3c03e6127830bd86126.zip
Correct dependencies, fix library install path wrt #351246, fix doc install path. Drop old.
(Portage version: 2.2.0_alpha10_p22/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/molsketch/ChangeLog11
-rw-r--r--sci-chemistry/molsketch/molsketch-0.2.0-r1.ebuild (renamed from sci-chemistry/molsketch/molsketch-0.2.0.ebuild)21
2 files changed, 24 insertions, 8 deletions
diff --git a/sci-chemistry/molsketch/ChangeLog b/sci-chemistry/molsketch/ChangeLog
index 31418b264414..bddea432fcfd 100644
--- a/sci-chemistry/molsketch/ChangeLog
+++ b/sci-chemistry/molsketch/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-chemistry/molsketch
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molsketch/ChangeLog,v 1.1 2010/11/02 09:20:03 jlec Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molsketch/ChangeLog,v 1.2 2011/01/10 12:37:32 xarthisius Exp $
+
+*molsketch-0.2.0-r1 (10 Jan 2011)
+
+ 10 Jan 2011; Kacper Kowalik <xarthisius@gentoo.org> -molsketch-0.2.0.ebuild,
+ +molsketch-0.2.0-r1.ebuild:
+ Correct dependencies, fix library install path wrt #351246, fix doc install
+ path. Drop old.
02 Nov 2010; Justin Lecher <jlec@gentoo.org> +molsketch-0.2.0.ebuild,
+metadata.xml:
diff --git a/sci-chemistry/molsketch/molsketch-0.2.0.ebuild b/sci-chemistry/molsketch/molsketch-0.2.0-r1.ebuild
index a676604b130f..6f478e67ba45 100644
--- a/sci-chemistry/molsketch/molsketch-0.2.0.ebuild
+++ b/sci-chemistry/molsketch/molsketch-0.2.0-r1.ebuild
@@ -1,16 +1,16 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molsketch/molsketch-0.2.0.ebuild,v 1.1 2010/11/02 09:20:03 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molsketch/molsketch-0.2.0-r1.ebuild,v 1.1 2011/01/10 12:37:32 xarthisius Exp $
EAPI=3
-inherit cmake-utils
+inherit cmake-utils multilib
-MY_P="${P/m/M}-Source"
+MY_P=${P/m/M}-Source
DESCRIPTION="A drawing tool for 2D molecular structures"
HOMEPAGE="http://molsketch.sourceforge.net/"
-SRC_URI="mirror://sourceforge/molsketch/${MY_P}.tar.gz"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
@@ -20,11 +20,20 @@ IUSE=""
DEPEND="sci-chemistry/openbabel
x11-libs/qt-core:4
x11-libs/qt-gui:4
- x11-libs/qt-assistant:4"
+ x11-libs/qt-test:4
+ || ( >=x11-libs/qt-assistant-4.7.0:4[compat]
+ <x11-libs/qt-assistant-4.7.0:4 )"
RDEPEND="${DEPEND}"
S=${WORKDIR}/${MY_P}
+src_prepare() {
+ sed -e "/LIBRARY DESTINATION/ s/lib/$(get_libdir)/g" \
+ -i libmolsketch/src/CMakeLists.txt || die #351246
+ sed -e "s:doc/molsketch:doc/${PF}:g" \
+ -i molsketch/src/{CMakeLists.txt,mainwindow.cpp} || die
+}
+
src_configure() {
local mycmakeargs="
-DOPENBABEL2_INCLUDE_DIR=${EPREFIX}/usr/include/openbabel-2.0"