summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-03-07 19:33:39 +0000
committerJustin Lecher <jlec@gentoo.org>2012-03-07 19:33:39 +0000
commitb125bbd57b3f298f177c75dc6fcda41574237458 (patch)
tree9c918961c1957cf0c8b1db49d82fe3c06af18e69 /sci-chemistry
parentAdd nls use flag to pull in translations. (diff)
downloadgentoo-2-b125bbd57b3f298f177c75dc6fcda41574237458.tar.gz
gentoo-2-b125bbd57b3f298f177c75dc6fcda41574237458.tar.bz2
gentoo-2-b125bbd57b3f298f177c75dc6fcda41574237458.zip
Fix sandbox violation, #407311
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/coot/ChangeLog6
-rw-r--r--sci-chemistry/coot/coot-0.6.2-r1.ebuild10
-rw-r--r--sci-chemistry/coot/coot-0.6.2.ebuild8
-rw-r--r--sci-chemistry/coot/coot-0.7_pre4040.ebuild6
4 files changed, 25 insertions, 5 deletions
diff --git a/sci-chemistry/coot/ChangeLog b/sci-chemistry/coot/ChangeLog
index 957c8f24cffd..4bda510b5d15 100644
--- a/sci-chemistry/coot/ChangeLog
+++ b/sci-chemistry/coot/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/coot
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/coot/ChangeLog,v 1.51 2012/03/06 15:31:19 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/coot/ChangeLog,v 1.52 2012/03/07 19:33:39 jlec Exp $
+
+ 07 Mar 2012; Justin Lecher <jlec@gentoo.org> coot-0.6.2.ebuild,
+ coot-0.6.2-r1.ebuild, coot-0.7_pre4040.ebuild:
+ Fix sandbox violation, #407311
*coot-0.7_pre4040 (06 Mar 2012)
diff --git a/sci-chemistry/coot/coot-0.6.2-r1.ebuild b/sci-chemistry/coot/coot-0.6.2-r1.ebuild
index be31a70d7af9..5d608187faed 100644
--- a/sci-chemistry/coot/coot-0.6.2-r1.ebuild
+++ b/sci-chemistry/coot/coot-0.6.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/coot/coot-0.6.2-r1.ebuild,v 1.3 2012/03/06 15:31:19 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/coot/coot-0.6.2-r1.ebuild,v 1.4 2012/03/07 19:33:39 jlec Exp $
EAPI=3
@@ -88,6 +88,14 @@ PATCHES=(
"${FILESDIR}"/${PV}-libpng15.patch
)
+src_prepare() {
+ sed \
+ -e "s:AM_COOT_SYS_BUILD_TYPE:COOT_SYS_BUILD_TYPE=Gentoo-Linux-$(PYTHON)-gtk2 ; AC_MSG_RESULT([\$COOT_SYS_BUILD_TYPE]); AC_SUBST(COOT_SYS_BUILD_TYPE):g" \
+ -i configure.in || die
+
+ autotools-utils_src_prepare
+}
+
src_configure() {
# All the --with's are used to activate various parts.
# Yes, this is broken behavior.
diff --git a/sci-chemistry/coot/coot-0.6.2.ebuild b/sci-chemistry/coot/coot-0.6.2.ebuild
index bd9066f1e5f6..427b9d35a441 100644
--- a/sci-chemistry/coot/coot-0.6.2.ebuild
+++ b/sci-chemistry/coot/coot-0.6.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/coot/coot-0.6.2.ebuild,v 1.10 2011/10/08 16:22:59 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/coot/coot-0.6.2.ebuild,v 1.11 2012/03/07 19:33:39 jlec Exp $
EAPI=3
@@ -85,6 +85,10 @@ PATCHES=(
)
src_prepare() {
+ sed \
+ -e "s:AM_COOT_SYS_BUILD_TYPE:COOT_SYS_BUILD_TYPE=Gentoo-Linux-$(PYTHON)-gtk2 ; AC_MSG_RESULT([\$COOT_SYS_BUILD_TYPE]); AC_SUBST(COOT_SYS_BUILD_TYPE):g" \
+ -i configure.in || die
+
base_src_prepare
eautoreconf
diff --git a/sci-chemistry/coot/coot-0.7_pre4040.ebuild b/sci-chemistry/coot/coot-0.7_pre4040.ebuild
index 519ac27bad9f..2a7e3fccbfb3 100644
--- a/sci-chemistry/coot/coot-0.7_pre4040.ebuild
+++ b/sci-chemistry/coot/coot-0.7_pre4040.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/coot/coot-0.7_pre4040.ebuild,v 1.1 2012/03/06 15:31:19 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/coot/coot-0.7_pre4040.ebuild,v 1.2 2012/03/07 19:33:39 jlec Exp $
EAPI=4
@@ -90,6 +90,10 @@ PATCHES=(
)
src_prepare() {
+ sed \
+ -e "s:AM_COOT_SYS_BUILD_TYPE:COOT_SYS_BUILD_TYPE=Gentoo-Linux-$(PYTHON)-gtk2 ; AC_MSG_RESULT([\$COOT_SYS_BUILD_TYPE]); AC_SUBST(COOT_SYS_BUILD_TYPE):g" \
+ -i configure.in || die
+
autotools-utils_src_prepare
cat >> src/svn-revision.cc <<- EOF