summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2006-03-15 08:55:45 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2006-03-15 08:55:45 +0000
commitdf5994ffff525373689d6368ec5270c10ec7ce5a (patch)
treec724bff543ba0d01651d6b9bf98e80732e6163f3 /sci-chemistry
parentWhitespace fix. (diff)
downloadgentoo-2-df5994ffff525373689d6368ec5270c10ec7ce5a.tar.gz
gentoo-2-df5994ffff525373689d6368ec5270c10ec7ce5a.tar.bz2
gentoo-2-df5994ffff525373689d6368ec5270c10ec7ce5a.zip
Remove USE=X, it screws up modular X and doesn't do anything at all.
(Portage version: 2.1_pre6-r2)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/mpqc/ChangeLog8
-rw-r--r--sci-chemistry/mpqc/mpqc-2.2.2.ebuild11
-rw-r--r--sci-chemistry/mpqc/mpqc-2.2.3.ebuild12
3 files changed, 14 insertions, 17 deletions
diff --git a/sci-chemistry/mpqc/ChangeLog b/sci-chemistry/mpqc/ChangeLog
index 00b464601c04..c159f792d361 100644
--- a/sci-chemistry/mpqc/ChangeLog
+++ b/sci-chemistry/mpqc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/mpqc
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mpqc/ChangeLog,v 1.8 2005/11/20 18:15:19 markusle Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mpqc/ChangeLog,v 1.9 2006/03/15 08:55:45 spyderous Exp $
+
+ 15 Mar 2006; Donnie Berkholz <spyderous@gentoo.org>; mpqc-2.2.2.ebuild,
+ mpqc-2.2.3.ebuild:
+ Remove USE=X, it screws up modular X and doesn't do anything at all.
20 Nov 2005; Markus Dittrich <markusle@gentoo.org> mpqc-2.3.0.ebuild:
Reworked install process to avoid sandbox violations. This fixes bug #113056.
diff --git a/sci-chemistry/mpqc/mpqc-2.2.2.ebuild b/sci-chemistry/mpqc/mpqc-2.2.2.ebuild
index ebf8814ef480..5693e7a00c62 100644
--- a/sci-chemistry/mpqc/mpqc-2.2.2.ebuild
+++ b/sci-chemistry/mpqc/mpqc-2.2.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mpqc/mpqc-2.2.2.ebuild,v 1.2 2004/12/29 16:30:31 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mpqc/mpqc-2.2.2.ebuild,v 1.3 2006/03/15 08:55:45 spyderous Exp $
DESCRIPTION="The Massively Parallel Quantum Chemistry Program"
HOMEPAGE="http://www.mpqc.org/"
@@ -11,19 +11,16 @@ LICENSE="GPL-2"
SLOT="0"
# Should work on x86, amd64 and ppc, at least
KEYWORDS="x86 ~ppc amd64"
-IUSE="doc X"
+IUSE="doc"
DEPEND="sys-devel/flex
sci-libs/blas
sci-libs/lapack
- dev-lang/perl
- X? ( virtual/x11 )"
+ dev-lang/perl"
src_compile() {
CFLAGS_SAVE=${CFLAGS}; CXXFLAGS_SAVE=${CXXFLAGS}
myconf="${myconf} --prefix=/usr"
- use X && myconf="${myconf} --x-includes=/usr/X11R6/include \
- --x-libraries=/usr/X11R6/lib"
./configure ${myconf} || die "configure failed"
sed -e "s:^CFLAGS =.*$:CFLAGS=${CFLAGS_SAVE}:" \
-e "s:^FFLAGS =.*$:FFLAGS=${CFLAGS_SAVE}:" \
diff --git a/sci-chemistry/mpqc/mpqc-2.2.3.ebuild b/sci-chemistry/mpqc/mpqc-2.2.3.ebuild
index 05e16bab23ee..6b2efe7d22c8 100644
--- a/sci-chemistry/mpqc/mpqc-2.2.3.ebuild
+++ b/sci-chemistry/mpqc/mpqc-2.2.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mpqc/mpqc-2.2.3.ebuild,v 1.3 2005/06/11 16:24:38 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mpqc/mpqc-2.2.3.ebuild,v 1.4 2006/03/15 08:55:45 spyderous Exp $
inherit fortran
@@ -13,21 +13,17 @@ LICENSE="GPL-2"
SLOT="0"
# Should work on x86, amd64 and ppc, at least
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="doc X threads"
+IUSE="doc threads"
DEPEND="sys-devel/flex
virtual/blas
virtual/lapack
dev-lang/perl
- >=sys-apps/sed-4
- X? ( virtual/x11 )"
+ >=sys-apps/sed-4"
src_compile() {
CFLAGS_SAVE=${CFLAGS}; CXXFLAGS_SAVE=${CXXFLAGS}
myconf="${myconf} --prefix=/usr"
- use X \
- && myconf="${myconf} --x-includes=/usr/X11R6/include \
- --x-libraries=/usr/X11R6/lib"
# only shared will work on ppc64 - bug #62124
if use ppc64; then