summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2013-01-02 20:26:48 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2013-01-02 20:26:48 +0000
commit048e7b18e26954300b3b73586e881c0c0b7b1084 (patch)
treede2f085e4619cbebec7e54ac9d7a16338c73a22b /sci-electronics/klayout
parentremove old version (diff)
downloadgentoo-2-048e7b18e26954300b3b73586e881c0c0b7b1084.tar.gz
gentoo-2-048e7b18e26954300b3b73586e881c0c0b7b1084.tar.bz2
gentoo-2-048e7b18e26954300b3b73586e881c0c0b7b1084.zip
Version bump; does not build without ruby anymore
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 7887F787)
Diffstat (limited to 'sci-electronics/klayout')
-rw-r--r--sci-electronics/klayout/ChangeLog11
-rw-r--r--sci-electronics/klayout/files/klayout-0.21.10-gcc46.patch11
-rw-r--r--sci-electronics/klayout/klayout-0.21.19.ebuild74
-rw-r--r--sci-electronics/klayout/klayout-0.22.4.ebuild (renamed from sci-electronics/klayout/klayout-0.22.ebuild)34
4 files changed, 23 insertions, 107 deletions
diff --git a/sci-electronics/klayout/ChangeLog b/sci-electronics/klayout/ChangeLog
index 44a3dad52ffa..3ecdeb515b4e 100644
--- a/sci-electronics/klayout/ChangeLog
+++ b/sci-electronics/klayout/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-electronics/klayout
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/klayout/ChangeLog,v 1.11 2012/09/22 22:22:57 dilfridge Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/klayout/ChangeLog,v 1.12 2013/01/02 20:26:48 dilfridge Exp $
+
+*klayout-0.22.4 (02 Jan 2013)
+
+ 02 Jan 2013; Andreas K. Huettel <dilfridge@gentoo.org>
+ -files/klayout-0.21.10-gcc46.patch, -klayout-0.21.19.ebuild,
+ -klayout-0.22.ebuild, +klayout-0.22.4.ebuild:
+ Version bump; does not build without ruby anymore
*klayout-0.22 (22 Sep 2012)
diff --git a/sci-electronics/klayout/files/klayout-0.21.10-gcc46.patch b/sci-electronics/klayout/files/klayout-0.21.10-gcc46.patch
deleted file mode 100644
index 4041af6d6c45..000000000000
--- a/sci-electronics/klayout/files/klayout-0.21.10-gcc46.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -ruN klayout-0.21.10.orig/src/tlStableVector.h klayout-0.21.10/src/tlStableVector.h
---- klayout-0.21.10.orig/src/tlStableVector.h 2011-05-07 20:53:35.000000000 +0200
-+++ klayout-0.21.10/src/tlStableVector.h 2011-05-29 10:34:20.000000000 +0200
-@@ -25,6 +25,7 @@
- #ifndef HDR_tlStableVector
- #define HDR_tlStableVector
-
-+#include <stddef.h>
- #include <vector>
- #include <iterator>
-
diff --git a/sci-electronics/klayout/klayout-0.21.19.ebuild b/sci-electronics/klayout/klayout-0.21.19.ebuild
deleted file mode 100644
index 2a3b7095a5b5..000000000000
--- a/sci-electronics/klayout/klayout-0.21.19.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/klayout/klayout-0.21.19.ebuild,v 1.1 2012/07/22 17:11:19 dilfridge Exp $
-
-EAPI=3
-
-USE_RUBY="ruby18"
-# note: define maximally ONE implementation here
-
-RUBY_OPTIONAL=yes
-
-inherit eutils multilib toolchain-funcs ruby-ng
-
-DESCRIPTION="Viewer and editor for GDS and OASIS integrated circuit layouts"
-HOMEPAGE="http://www.klayout.de/"
-SRC_URI="http://www.klayout.de/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="ruby"
-
-RDEPEND="
- x11-libs/qt-gui:4[qt3support]
- ruby? ( $(ruby_implementations_depend) )
-"
-DEPEND="${RDEPEND}"
-
-all_ruby_prepare() {
- # now we generate the stub build configuration file for the home-brew build system
- cp "${FILESDIR}/${PN}-0.21.7-Makefile.conf.linux-gentoo" "${S}/config/Makefile.conf.linux-gentoo" || die
-}
-
-each_ruby_configure() {
- local rbflags
-
- if use ruby ; then
- rbflags="-rblib $(ruby_get_libruby) -rbinc $(ruby_get_hdrdir)"
- fi
-
- ./build.sh \
- -dry-run \
- -platform linux-gentoo \
- -bin bin \
- -qtbin /usr/bin \
- -qtinc /usr/include/qt4 \
- -qtlib /usr/$(get_libdir)/qt4 \
- ${rbflags} || die "Configuration failed"
-}
-
-each_ruby_compile() {
- cd build.linux-gentoo
- tc-export CC CXX AR LD RANLIB
- export AR="${AR} -r"
- emake all || die "Build failed"
-}
-
-each_ruby_install() {
- cd build.linux-gentoo
- emake install || die "make install failed"
-
- cd ..
- dobin bin/klayout || die
-
- insinto /usr/share/${PN}/testdata/gds
- doins testdata/gds/*.gds || die "Installation of gds testdata failed"
- insinto /usr/share/${PN}/testdata/oasis
- doins testdata/oasis/*.oas testdata/oasis/*.ot || die "Installation of oasis testdata failed"
-
- if use ruby; then
- insinto /usr/share/${PN}
- doins -r testdata/ruby || die "Installation of ruby testdata failed"
- fi
-}
diff --git a/sci-electronics/klayout/klayout-0.22.ebuild b/sci-electronics/klayout/klayout-0.22.4.ebuild
index aa7b92450cb2..1f4da6174bdc 100644
--- a/sci-electronics/klayout/klayout-0.22.ebuild
+++ b/sci-electronics/klayout/klayout-0.22.4.ebuild
@@ -1,14 +1,13 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/klayout/klayout-0.22.ebuild,v 1.1 2012/09/22 22:22:57 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/klayout/klayout-0.22.4.ebuild,v 1.1 2013/01/02 20:26:48 dilfridge Exp $
-EAPI=3
+EAPI=5
USE_RUBY="ruby18"
# note: define maximally ONE implementation here
-RUBY_OPTIONAL=yes
-
+RUBY_OPTIONAL=no
inherit eutils multilib toolchain-funcs ruby-ng
DESCRIPTION="Viewer and editor for GDS and OASIS integrated circuit layouts"
@@ -18,11 +17,11 @@ SRC_URI="http://www.klayout.de/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="ruby"
+IUSE=""
RDEPEND="
x11-libs/qt-gui:4[qt3support]
- ruby? ( $(ruby_implementations_depend) )
+ $(ruby_implementations_depend)
"
DEPEND="${RDEPEND}"
@@ -33,10 +32,7 @@ all_ruby_prepare() {
each_ruby_configure() {
local rbflags
-
- if use ruby ; then
- rbflags="-rblib $(ruby_get_libruby) -rbinc $(ruby_get_hdrdir)"
- fi
+ rbflags="-rblib $(ruby_get_libruby) -rbinc $(ruby_get_hdrdir)"
./build.sh \
-dry-run \
@@ -52,23 +48,21 @@ each_ruby_compile() {
cd build.linux-gentoo
tc-export CC CXX AR LD RANLIB
export AR="${AR} -r"
- emake all || die "Build failed"
+ emake all
}
each_ruby_install() {
cd build.linux-gentoo
- emake install || die "make install failed"
+ emake install
cd ..
- dobin bin/klayout || die
+ dobin bin/klayout
insinto /usr/share/${PN}/testdata/gds
- doins testdata/gds/*.gds || die "Installation of gds testdata failed"
+ doins testdata/gds/*.gds
insinto /usr/share/${PN}/testdata/oasis
- doins testdata/oasis/*.oas testdata/oasis/*.ot || die "Installation of oasis testdata failed"
+ doins testdata/oasis/*.oas testdata/oasis/*.ot
- if use ruby; then
- insinto /usr/share/${PN}
- doins -r testdata/ruby || die "Installation of ruby testdata failed"
- fi
+ insinto /usr/share/${PN}
+ doins -r testdata/ruby
}