summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2012-06-13 14:26:03 +0000
committerMichael Weber <xmw@gentoo.org>2012-06-13 14:26:03 +0000
commita4e8e129984fc78033dcb538f75f6aac3a6e297c (patch)
tree50ec11c7c564e0fe7a7095823cded3b89d7ede7f /sci-electronics/magic/files
parentMask beta versions of sci-electronics/xcircuit for testing (diff)
downloadgentoo-2-a4e8e129984fc78033dcb538f75f6aac3a6e297c.tar.gz
gentoo-2-a4e8e129984fc78033dcb538f75f6aac3a6e297c.tar.bz2
gentoo-2-a4e8e129984fc78033dcb538f75f6aac3a6e297c.zip
Version bump (thanks euscan)
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'sci-electronics/magic/files')
-rw-r--r--sci-electronics/magic/files/magic-8.0.109-ldflags.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/sci-electronics/magic/files/magic-8.0.109-ldflags.patch b/sci-electronics/magic/files/magic-8.0.109-ldflags.patch
new file mode 100644
index 000000000000..f471aa7bcff3
--- /dev/null
+++ b/sci-electronics/magic/files/magic-8.0.109-ldflags.patch
@@ -0,0 +1,27 @@
+--- magic-8.0.109/scripts/defs.mak.in
++++ magic-8.0.109/scripts/defs.mak.in
+@@ -53,7 +53,7 @@
+ M4 = @M4@
+ RANLIB = @RANLIB@
+ SHDLIB_EXT = @SHDLIB_EXT@
+-LDDL_FLAGS = @LDDL_FLAGS@
++LDDL_FLAGS = ${LDFLAGS} @LDDL_FLAGS@
+ LD_RUN_PATH = @LD_RUN_PATH@
+ LIB_SPECS = @LIB_SPECS@
+ WISH_EXE = @WISH_EXE@
+--- magic-8.0.109/tcltk/Makefile
++++ magic-8.0.109/tcltk/Makefile
+@@ -43,11 +43,11 @@
+ (cd $(DESTDIR)${TCLDIR}; chmod 0755 tkcon.tcl tkshell.tcl)
+
+ magicexec: magicexec.c ${MAGICDIR}/defs.mak
+- ${CC} ${CFLAGS} -pg ${CPPFLAGS} ${DFLAGS} magicexec.c -o magicexec \
++ ${CC} ${CFLAGS} -pg ${CPPFLAGS} ${DFLAGS} ${LDFLAGS} magicexec.c -o magicexec \
+ ${LD_RUN_PATH} ${LIBS} ${LIB_SPECS}
+
+ magicdnull: magicdnull.c ${MAGICDIR}/defs.mak
+- ${CC} ${CFLAGS} ${CPPFLAGS} ${DFLAGS} magicdnull.c -o magicdnull \
++ ${CC} ${CFLAGS} ${CPPFLAGS} ${DFLAGS} ${LDFLAGS} magicdnull.c -o magicdnull \
+ ${LD_RUN_PATH} ${LIBS} ${LIB_SPECS}
+
+ magic.tcl: magic.tcl.in ${MAGICDIR}/defs.mak