summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2007-09-06 19:25:53 +0000
committerHanno Böck <hanno@gentoo.org>2007-09-06 19:25:53 +0000
commit870a3b5a3922c9b5fcbb740f4f295deb3c09f0b5 (patch)
tree70c6768f04db051c06bd294a747cfe82ae6818af /sci-geosciences/gebabbel/gebabbel-0.3.ebuild
parentFix manpath (diff)
downloadgentoo-2-870a3b5a3922c9b5fcbb740f4f295deb3c09f0b5.tar.gz
gentoo-2-870a3b5a3922c9b5fcbb740f4f295deb3c09f0b5.tar.bz2
gentoo-2-870a3b5a3922c9b5fcbb740f4f295deb3c09f0b5.zip
gebabbel - frontend for gpsbabel
(Portage version: 2.1.3.7)
Diffstat (limited to 'sci-geosciences/gebabbel/gebabbel-0.3.ebuild')
-rw-r--r--sci-geosciences/gebabbel/gebabbel-0.3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sci-geosciences/gebabbel/gebabbel-0.3.ebuild b/sci-geosciences/gebabbel/gebabbel-0.3.ebuild
new file mode 100644
index 000000000000..b0664cd9b2a1
--- /dev/null
+++ b/sci-geosciences/gebabbel/gebabbel-0.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gebabbel/gebabbel-0.3.ebuild,v 1.1 2007/09/06 19:25:53 hanno Exp $
+
+inherit eutils
+
+DESCRIPTION="QT-Frontend to load and convert gps tracks with gpsbabel"
+HOMEPAGE="http://gebabbel.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/Gebabbel-${PV}-Src.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=">=x11-libs/qt-4.3.0
+ sci-geosciences/gpsbabel"
+
+S="${WORKDIR}/Gebabbel-${PV}"
+
+pkg_setup() {
+ if ! built_with_use 'x11-libs/qt' 'accessibility'; then
+ eerror "You must build qt with accessibility support"
+ die "x11-libs/qt built without accessibility"
+ fi
+}
+
+src_unpack() {
+ unpack "${A}" || die
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-fix.diff"
+}
+
+src_compile() {
+ qmake || die
+ emake || die
+}
+
+src_install() {
+ dobin bin/gebabbel || die
+ dodoc CHANGELOG || die
+}