summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-05-16 10:43:42 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-05-16 10:43:42 +0000
commite5b866d71c96d3c30c4d9c1f96f811320fe57283 (patch)
tree94db35de95b53f39982d9337a678bf08e3561d80 /sci-geosciences/gpsd/files
parentRewrite /bin/sh symlink atomically, bug #367241 (diff)
downloadgentoo-2-e5b866d71c96d3c30c4d9c1f96f811320fe57283.tar.gz
gentoo-2-e5b866d71c96d3c30c4d9c1f96f811320fe57283.tar.bz2
gentoo-2-e5b866d71c96d3c30c4d9c1f96f811320fe57283.zip
Version bump to latest. Drop older. Fixes bug #362979.
(Portage version: 2.2.0_alpha33/cvs/Linux x86_64)
Diffstat (limited to 'sci-geosciences/gpsd/files')
-rw-r--r--sci-geosciences/gpsd/files/2.96-fix-ldflags.patch21
-rw-r--r--sci-geosciences/gpsd/files/2.96-fix-tests.patch23
-rw-r--r--sci-geosciences/gpsd/files/gpsd-2.33-duplicate-device-add-hang.patch26
-rw-r--r--sci-geosciences/gpsd/files/gpsd-2.33-hotplug-background-fix.patch54
4 files changed, 44 insertions, 80 deletions
diff --git a/sci-geosciences/gpsd/files/2.96-fix-ldflags.patch b/sci-geosciences/gpsd/files/2.96-fix-ldflags.patch
new file mode 100644
index 000000000000..f643a359df8f
--- /dev/null
+++ b/sci-geosciences/gpsd/files/2.96-fix-ldflags.patch
@@ -0,0 +1,21 @@
+diff -urN gpsd-2.96.old/Makefile.am gpsd-2.96/Makefile.am
+--- gpsd-2.96.old/Makefile.am 2011-05-16 11:41:11.763256750 +0200
++++ gpsd-2.96/Makefile.am 2011-05-16 11:44:02.742119221 +0200
+@@ -130,7 +130,7 @@
+ libgps_VERSION_REVISION = 0
+ libgps_VERSION_AGE = 0
+ libgps_VERSION_NUMBER = $(libgps_VERSION_CURRENT):$(libgps_VERSION_REVISION):$(libgps_VERSION_AGE)
+-libgps_la_LDFLAGS = -version-number $(libgps_VERSION_NUMBER)
++libgps_la_LDFLAGS = $(LDFLAGS) -version-number $(libgps_VERSION_NUMBER)
+ lib_LTLIBRARIES = libgps.la libgpsd.la
+
+ libgps_SONAME = $(shell expr $(libgps_VERSION_CURRENT) - $(libgps_VERSION_AGE))
+@@ -425,7 +425,7 @@
+ # Build test_qgpsmm
+ #
+ test_qgpsmm_SOURCES = test_gpsmm.cpp
+-test_qgpsmm_LDFLAGS = -Wl,-rpath,$(srcdir)/libQgpsmm/binaries
++test_qgpsmm_LDFLAGS = $(LDFLAGS) -Wl,-rpath,$(srcdir)/libQgpsmm/binaries
+ test_qgpsmm_LDADD = $(LIBC) $(LIBUSB) $(QtNetwork_LIBS) libgps.la -LlibQgpsmm/binaries -lQgpsmm
+ test_qgpsmm_DEPENDENCIES = libQgpsmm/binaries/libQgpsmm.so
+ endif
diff --git a/sci-geosciences/gpsd/files/2.96-fix-tests.patch b/sci-geosciences/gpsd/files/2.96-fix-tests.patch
new file mode 100644
index 000000000000..38aec0024b0c
--- /dev/null
+++ b/sci-geosciences/gpsd/files/2.96-fix-tests.patch
@@ -0,0 +1,23 @@
+diff -urN gpsd-2.96.old//Makefile.am gpsd-2.96//Makefile.am
+--- gpsd-2.96.old//Makefile.am 2011-05-16 11:41:11.763256750 +0200
++++ gpsd-2.96//Makefile.am 2011-05-16 12:37:34.095971771 +0200
+@@ -615,8 +615,8 @@
+ pkgconfigdir = $(libdir)/pkgconfig
+
+ # These are not distributed
+-libgps: libgps_core.c gps.h .libs/libgps.a
+- $(CC) $(CFLAGS) -o libgps $(LIBM) -DTESTMAIN $(LIBPTHREAD) -g libgps_core.c .libs/libgps.a
++libgps: libgps_core.c gps.h .libs/libgps.so
++ $(CC) $(CFLAGS) $(LDFLAGS) -o libgps $(LIBM) -DTESTMAIN $(LIBPTHREAD) -g libgps_core.c .libs/libgps.so
+
+
+ # Report splint warnings
+@@ -720,7 +720,7 @@
+
+ # Use make REGRESSOPTS=-u to force running with UDP rather than pty devices
+
+-run_regress_driver = PYTHON=$(PYTHON) $(srcdir)/regress-driver $(REGRESSOPTS)
++run_regress_driver = PYTHON=$(PYTHON) LD_LIBRARY_PATH="./.libs/" $(srcdir)/regress-driver $(REGRESSOPTS)
+
+ # Regression-test the daemon
+ gps-regress: gpsd stamp-python
diff --git a/sci-geosciences/gpsd/files/gpsd-2.33-duplicate-device-add-hang.patch b/sci-geosciences/gpsd/files/gpsd-2.33-duplicate-device-add-hang.patch
deleted file mode 100644
index 5e3d957a478a..000000000000
--- a/sci-geosciences/gpsd/files/gpsd-2.33-duplicate-device-add-hang.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-If you try to add the same device twice with the hotplug script, gpsd does not
-send any error back to the script, leading to it waiting forever on recv(), and
-blocking gpsd from progressing in it's select loop.
-
-This patch makes the daemon write back an error to the control socket (in
-addition the the normal debug output), so that the hotplug script does not
-block for the socket, and everything proceeds much better.
-
-Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
-
-diff -Nuar --exclude '*~' gpsd-2.33.orig/gpsd.c gpsd-2.33/gpsd.c
---- gpsd-2.33.orig/gpsd.c 2006-06-09 05:34:09.000000000 -0700
-+++ gpsd-2.33/gpsd.c 2006-08-13 15:42:25.152204904 -0700
-@@ -1048,9 +1048,10 @@
- (void)write(sfd, "ERROR\n", 6);
- } else if (buf[0] == '+') {
- p = snarfline(buf+1, &stash);
-- if (find_device(stash))
-+ if (find_device(stash)) {
- gpsd_report(1,"<= control(%d): %s already active \n", sfd, stash);
-- else {
-+ (void)write(sfd, "ERROR\n", 6);
-+ } else {
- gpsd_report(1,"<= control(%d): adding %s \n", sfd, stash);
- if (open_device(stash))
- (void)write(sfd, "OK\n", 3);
diff --git a/sci-geosciences/gpsd/files/gpsd-2.33-hotplug-background-fix.patch b/sci-geosciences/gpsd/files/gpsd-2.33-hotplug-background-fix.patch
deleted file mode 100644
index 03963ed6e5b8..000000000000
--- a/sci-geosciences/gpsd/files/gpsd-2.33-hotplug-background-fix.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-In recent versions of udev, the gpsd script runs in series with the task that
-creates the real /dev/ttyUSB0 device node. Unfortuntely, the gpsd script runs
-BEFORE the creation of the node, and the node is not created until after you
-kill the gpsd script, because the gpsd script waits forever for the node to
-appear.
-
-This is a race condition, and is best fixed by running the actual wait/hotplug
-portion in the background.
-
-Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
-
-diff -Nuar --exclude '*~' gpsd-2.33.orig/gpsd.hotplug gpsd-2.33/gpsd.hotplug
---- gpsd-2.33.orig/gpsd.hotplug 2005-06-27 11:53:00.000000000 -0700
-+++ gpsd-2.33/gpsd.hotplug 2006-08-13 18:35:03.382383884 -0700
-@@ -56,7 +56,7 @@
- return action
-
- def hotplug(action, devpath):
-- #syslog.syslog("ACTION=%s" % action)
-+ #syslog.syslog("ACTION=%s DEVPATH=%s" % (action,devpath))
- if not devpath:
- syslog.syslog("No device")
- else:
-@@ -88,16 +88,18 @@
- return
-
- if __name__ == '__main__':
-- syslog.openlog('gpsd.hotplug', 0, syslog.LOG_DAEMON)
-- try:
-- if len(sys.argv) == 1: # Called as hotplug script
-- hotplug(os.getenv("ACTION"), os.getenv("DEVPATH"))
-- else: # Called by hand for testing
-- gpsd_control(sys.argv[1], sys.argv[2])
-- except:
-- (exc_type, exc_value, exc_traceback) = sys.exc_info()
-- syslog.syslog("gpsd.hotplug: exception %s yields %s" % (exc_type, exc_value))
-- raise exc_type, exc_value, exc_traceback
-- #syslog.syslog("gpsd.hotplug ends")
-- syslog.closelog()
-+ pid = os.fork()
-+ if not pid:
-+ syslog.openlog('gpsd.hotplug', 0, syslog.LOG_DAEMON)
-+ try:
-+ if len(sys.argv) == 1: # Called as hotplug script
-+ hotplug(os.getenv("ACTION"), os.getenv("DEVPATH"))
-+ else: # Called by hand for testing
-+ gpsd_control(sys.argv[1], sys.argv[2])
-+ except:
-+ (exc_type, exc_value, exc_traceback) = sys.exc_info()
-+ syslog.syslog("gpsd.hotplug: exception %s yields %s" % (exc_type, exc_value))
-+ raise exc_type, exc_value, exc_traceback
-+ #syslog.syslog("gpsd.hotplug ends")
-+ syslog.closelog()
-