summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-06-17 09:39:38 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-06-17 09:39:38 +0000
commitfab02296a57fc242a2621f847e203c7c0e94a088 (patch)
tree6ea4a4eac6e4907fc2991aefced99d41c28fbbd9 /sci-geosciences/gpsd
parentFix vala dependency and vala logic in the 9999 ebuild (diff)
downloadgentoo-2-fab02296a57fc242a2621f847e203c7c0e94a088.tar.gz
gentoo-2-fab02296a57fc242a2621f847e203c7c0e94a088.tar.bz2
gentoo-2-fab02296a57fc242a2621f847e203c7c0e94a088.zip
Install udev rules. Fixes bug #369125.
(Portage version: 2.2.0_alpha38/cvs/Linux x86_64)
Diffstat (limited to 'sci-geosciences/gpsd')
-rw-r--r--sci-geosciences/gpsd/ChangeLog8
-rw-r--r--sci-geosciences/gpsd/gpsd-2.96-r1.ebuild (renamed from sci-geosciences/gpsd/gpsd-2.96.ebuild)13
2 files changed, 17 insertions, 4 deletions
diff --git a/sci-geosciences/gpsd/ChangeLog b/sci-geosciences/gpsd/ChangeLog
index b0e409d029dd..35c41ca84d7c 100644
--- a/sci-geosciences/gpsd/ChangeLog
+++ b/sci-geosciences/gpsd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-geosciences/gpsd
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/ChangeLog,v 1.68 2011/06/04 08:03:01 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/ChangeLog,v 1.69 2011/06/17 09:39:38 scarabeus Exp $
+
+*gpsd-2.96-r1 (17 Jun 2011)
+
+ 17 Jun 2011; Tomáš Chvátal <scarabeus@gentoo.org> -gpsd-2.96.ebuild,
+ +gpsd-2.96-r1.ebuild:
+ Install udev rules. Fixes bug #369125.
04 Jun 2011; Tomáš Chvátal <scarabeus@gentoo.org> gpsd-2.96.ebuild:
Drop unused variable and double definition.
diff --git a/sci-geosciences/gpsd/gpsd-2.96.ebuild b/sci-geosciences/gpsd/gpsd-2.96-r1.ebuild
index bee372d08be3..4b5f984e662e 100644
--- a/sci-geosciences/gpsd/gpsd-2.96.ebuild
+++ b/sci-geosciences/gpsd/gpsd-2.96-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/gpsd-2.96.ebuild,v 1.3 2011/06/04 08:03:01 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/gpsd-2.96-r1.ebuild,v 1.1 2011/06/17 09:39:38 scarabeus Exp $
EAPI=3
@@ -24,7 +24,7 @@ for protocol in ${GPSD_PROTOCOLS}; do
IUSE_GPSD_PROTOCOLS+=" gpsd_protocols_${protocol}"
done
-IUSE="${IUSE_GPSD_PROTOCOLS} dbus ipv6 ntp qt4"
+IUSE="${IUSE_GPSD_PROTOCOLS} dbus ipv6 ntp qt4 udev"
# those harddeps are de-facto automagicall
RDEPEND="
@@ -69,7 +69,7 @@ src_configure() {
myopts+=" $(use_enable gpsd_protocols_${protocol} ${protocol})"
done
- if ! use qt4 ; then
+ if ! use qt4 ; then
myopts+=" --disable-libQgpsmm --disable-libgpsmm"
fi
@@ -93,6 +93,13 @@ src_install() {
# no it can't be done using emake cause it is non-compliant
make DESTDIR="${D}" install || die
+ if use udev ; then
+ insinto /lib/udev/rules.d/
+ newins gpsd.rules 25-gpsd.rules
+ exeinto /lib/udev/
+ doexe gpsd.hotplug{,.wrapper}
+ fi
+
# needs this header for libQgpsmm
if use qt4 ; then
insinto /usr/include