summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2008-05-04 01:07:37 +0000
committerSteve Arnold <nerdboy@gentoo.org>2008-05-04 01:07:37 +0000
commit841dd975b4539c18f74ffc47b4c91999153b1573 (patch)
tree395a9da7f387fd9979b7ee862ab3c90f63607860 /sci-geosciences/grass
parentgcc-4.3 bug fix as per bug #216227 (diff)
downloadgentoo-2-841dd975b4539c18f74ffc47b4c91999153b1573.tar.gz
gentoo-2-841dd975b4539c18f74ffc47b4c91999153b1573.tar.bz2
gentoo-2-841dd975b4539c18f74ffc47b4c91999153b1573.zip
updated for changed include path in latest ffmpeg
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'sci-geosciences/grass')
-rw-r--r--sci-geosciences/grass/ChangeLog7
-rw-r--r--sci-geosciences/grass/grass-6.2.3.ebuild18
2 files changed, 20 insertions, 5 deletions
diff --git a/sci-geosciences/grass/ChangeLog b/sci-geosciences/grass/ChangeLog
index eb5f4fc2667a..4e2c968dc48a 100644
--- a/sci-geosciences/grass/ChangeLog
+++ b/sci-geosciences/grass/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-geosciences/grass
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/ChangeLog,v 1.51 2008/05/01 05:19:47 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/ChangeLog,v 1.52 2008/05/04 01:07:37 nerdboy Exp $
+
+ 04 May 2008; Steve Arnold <nerdboy@gentoo.org> grass-6.2.3.ebuild:
+ Updated for changed include path in latest ffmpeg. Still needs testing,
+ but it builds and runs; so far I've only found avcodec included in the
+ source.
*grass-6.2.3 (01 May 2008)
diff --git a/sci-geosciences/grass/grass-6.2.3.ebuild b/sci-geosciences/grass/grass-6.2.3.ebuild
index a3491625f536..31026c4bf4cb 100644
--- a/sci-geosciences/grass/grass-6.2.3.ebuild
+++ b/sci-geosciences/grass/grass-6.2.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/grass-6.2.3.ebuild,v 1.2 2008/05/01 16:37:40 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/grass-6.2.3.ebuild,v 1.3 2008/05/04 01:07:37 nerdboy Exp $
inherit eutils autotools fdo-mime versionator
@@ -33,7 +33,7 @@ RDEPEND=">=sys-devel/make-3.80
sys-apps/man-db )
sci-libs/gdal
>=sci-libs/proj-4.4.7
- ffmpeg? ( media-video/ffmpeg )
+ ffmpeg? ( >=media-video/ffmpeg-0.4.9_p20080326 )
fftw? ( sci-libs/fftw )
gmath? ( virtual/blas
virtual/lapack )
@@ -105,6 +105,15 @@ pkg_setup() {
ewarn "GRASS OpenGL support needs X (will also pull in Tcl/Tk)."
die "Please set the X useflag."
fi
+
+ if use ffmpeg; then
+ ewarn "This version requires the newest ffmpeg, which is a major"
+ ewarn "ABI change (and may break things). You should definitely"
+ ewarn "rebuild everything that uses ffmpeg if you haven't already"
+ ewarn "done so, and be prepared for possible breakage..."
+ ewarn "Hit Ctrl-C now if you're not ready to do this."
+ epause 10
+ fi
}
src_unpack() {
@@ -151,7 +160,8 @@ src_compile() {
fi
if use ffmpeg; then
- myconf="${myconf} --with-ffmpeg --with-ffmpeg-includes=/usr/include/ffmpeg \
+ myconf="${myconf} --with-ffmpeg \
+ --with-ffmpeg-includes=/usr/include/libavcodec \
--with-ffmpeg-libs=/usr/$(get_libdir)"
else
myconf="${myconf} --without-ffmpeg"
@@ -201,7 +211,7 @@ src_install() {
PREFIX="${D}"usr INST_DIR="${D}"usr/${MY_PM} \
|| die "make install failed!"
- #
+ # get rid of DESTDIR in script path
sed -i -e "s@${D}@/@" "${D}"usr/bin/${MY_PM}
# Grass Extension Manager conflicts with ruby gems