summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2011-11-13 02:19:49 +0000
committerSteve Arnold <nerdboy@gentoo.org>2011-11-13 02:19:49 +0000
commita9848deef40347c0129ff1056712a917ba804b25 (patch)
tree6d9005783243ebd14dcd2de06c748bb9632a8882 /sci-geosciences/mapnik
parentmasking the newer mapnik2 (diff)
downloadgentoo-2-a9848deef40347c0129ff1056712a917ba804b25.tar.gz
gentoo-2-a9848deef40347c0129ff1056712a917ba804b25.tar.bz2
gentoo-2-a9848deef40347c0129ff1056712a917ba804b25.zip
Added mapnik2 ebuild (currently masked due to gpsdrive breakage).
(Portage version: 2.1.10.32/cvs/Linux x86_64)
Diffstat (limited to 'sci-geosciences/mapnik')
-rw-r--r--sci-geosciences/mapnik/ChangeLog9
-rw-r--r--sci-geosciences/mapnik/files/mapnik-2.0.0-gentoo.patch65
-rw-r--r--sci-geosciences/mapnik/mapnik-2.0.0.ebuild122
-rw-r--r--sci-geosciences/mapnik/metadata.xml1
4 files changed, 196 insertions, 1 deletions
diff --git a/sci-geosciences/mapnik/ChangeLog b/sci-geosciences/mapnik/ChangeLog
index ef1e1ec88f4e..d00ee3969a70 100644
--- a/sci-geosciences/mapnik/ChangeLog
+++ b/sci-geosciences/mapnik/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-geosciences/mapnik
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/mapnik/ChangeLog,v 1.27 2011/09/26 07:45:56 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/mapnik/ChangeLog,v 1.28 2011/11/13 02:19:47 nerdboy Exp $
+
+*mapnik-2.0.0 (13 Nov 2011)
+
+ 13 Nov 2011; Steve Arnold <nerdboy@gentoo.org> +mapnik-2.0.0.ebuild,
+ +files/mapnik-2.0.0-gentoo.patch:
+ Added mapnik2 ebuild, however, it breaks current gpsdrive, so it will be
+ package.amsked for the time being. Unmask if you want to try it.
26 Sep 2011; Steve Arnold <nerdboy@gentoo.org> mapnik-0.7.1-r1.ebuild,
+files/mapnik-0.7.1-libpng1.5.4.patch:
diff --git a/sci-geosciences/mapnik/files/mapnik-2.0.0-gentoo.patch b/sci-geosciences/mapnik/files/mapnik-2.0.0-gentoo.patch
new file mode 100644
index 000000000000..e463cf33b9de
--- /dev/null
+++ b/sci-geosciences/mapnik/files/mapnik-2.0.0-gentoo.patch
@@ -0,0 +1,65 @@
+--- SConstruct.orig 2011-11-06 09:52:20.000000000 -0800
++++ SConstruct 2011-11-06 09:55:03.000000000 -0800
+@@ -314,9 +313,9 @@
+ ('LINK_PRIORITY','Priority list in which to sort library and include paths (default order is internal, other, frameworks, user, then system - see source of `sort_paths` function for more detail)',','.join(DEFAULT_LINK_PRIORITY)),
+
+ # Install Variables
+- ('PREFIX', 'The install path "prefix"', '/usr/local'),
++ ('PREFIX', 'The install path "prefix"', '/usr'),
+ ('PYTHON_PREFIX','Custom install path "prefix" for python bindings (default of no prefix)',''),
+- ('DESTDIR', 'The root directory to install into. Useful mainly for binary package building', '/'),
++ ('DESTDIR', 'The root directory to install into. Useful mainly for binary package building', '${D}'),
+ ('PATH_INSERT', 'A custom path to append to the $PATH env to prioritize usage of shell programs like pkg-config will be used if multiple are present on the system', ''),
+
+ # Boost variables
+@@ -342,15 +341,17 @@
+ PathVariable('JPEG_LIBS', 'Search path for libjpeg library files', '/usr/' + LIBDIR_SCHEMA, PathVariable.PathAccept),
+ PathVariable('TIFF_INCLUDES', 'Search path for libtiff include files', '/usr/include', PathVariable.PathAccept),
+ PathVariable('TIFF_LIBS', 'Search path for libtiff library files', '/usr/' + LIBDIR_SCHEMA, PathVariable.PathAccept),
+- PathVariable('PROJ_INCLUDES', 'Search path for PROJ.4 include files', '/usr/local/include', PathVariable.PathAccept),
+- PathVariable('PROJ_LIBS', 'Search path for PROJ.4 library files', '/usr/local/' + LIBDIR_SCHEMA, PathVariable.PathAccept),
++ PathVariable('PROJ_INCLUDES', 'Search path for PROJ.4 include files', '/usr/include', PathVariable.PathAccept),
++ PathVariable('PROJ_LIBS', 'Search path for PROJ.4 library files', '/usr/' + LIBDIR_SCHEMA, PathVariable.PathAccept),
++ PathVariable('AGG_INCLUDES', 'Search path for AGG include files', '/usr/include/agg2', PathVariable.PathAccept),
++ PathVariable('AGG_LIBS', 'Search path for AGG library files', '/usr/' + LIBDIR_SCHEMA, PathVariable.PathAccept),
+ ('PKG_CONFIG_PATH', 'Use this path to point pkg-config to .pc files instead of the PKG_CONFIG_PATH environment setting',''),
+
+ # Variables affecting rendering back-ends
+
+ BoolVariable('RENDERING_STATS', 'Output rendering statistics during style processing', 'False'),
+
+- BoolVariable('INTERNAL_LIBAGG', 'Use provided libagg', 'True'),
++ BoolVariable('INTERNAL_LIBAGG', 'Use provided libagg', 'False'),
+
+ BoolVariable('SVG_RENDERER', 'build support for native svg renderer', 'False'),
+
+@@ -1098,6 +1099,7 @@
+ ['z', 'zlib.h', True,'C'],
+ ['proj', 'proj_api.h', True,'C'],
+ [env['ICU_LIB_NAME'],'unicode/unistr.h',True,'C++'],
++ ['agg','agg2/agg_config.h' , True,'C++'],
+ ]
+
+ if env['JPEG']:
+--- src/build.py.orig 2011-11-05 18:30:33.000000000 -0700
++++ src/build.py 2011-11-05 18:31:14.000000000 -0700
+@@ -37,9 +37,6 @@
+ elif not silent:
+ print stderr
+
+-def ldconfig(*args,**kwargs):
+- call('ldconfig')
+-
+ if env['LINKING'] == 'static':
+ lib_env.Append(CXXFLAGS="-fPIC")
+
+@@ -326,9 +323,6 @@
+ if 'uninstall' not in COMMAND_LINE_TARGETS:
+ result = env.InstallAs(target=target, source=mapnik)
+ env.Alias(target='install', source=result)
+- if result:
+- env.AddPostAction(result, ldconfig)
+-
+
+ # Install symlinks
+ target1 = os.path.join(env['MAPNIK_LIB_BASE_DEST'], "%s.%d.%d" % (os.path.basename(str(mapnik[0])),major, minor))
diff --git a/sci-geosciences/mapnik/mapnik-2.0.0.ebuild b/sci-geosciences/mapnik/mapnik-2.0.0.ebuild
new file mode 100644
index 000000000000..9814f6f3098e
--- /dev/null
+++ b/sci-geosciences/mapnik/mapnik-2.0.0.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/mapnik/mapnik-2.0.0.ebuild,v 1.1 2011/11/13 02:19:45 nerdboy Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="python? 2"
+inherit eutils python scons-utils toolchain-funcs
+
+DESCRIPTION="A Free Toolkit for developing mapping applications."
+HOMEPAGE="http://www.mapnik.org/"
+SRC_URI="mirror://berlios/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="bidi cairo debug doc gdal nobfonts postgres python sqlite"
+
+RDEPEND="dev-libs/boost
+ net-misc/curl
+ media-libs/libpng
+ media-libs/jpeg
+ media-libs/tiff
+ sys-libs/zlib
+ media-libs/freetype
+ dev-lang/python
+ sci-libs/proj
+ dev-libs/libxml2
+ dev-libs/icu
+ x11-libs/agg[truetype]
+ postgres? (
+ >=dev-db/postgresql-base-8.3
+ >=dev-db/postgis-1.5.2
+ sci-libs/geos
+ )
+ python? ( dev-libs/boost[python] )
+ gdal? ( sci-libs/gdal )
+ python? ( dev-lang/python )
+ bidi? ( dev-libs/fribidi )
+ cairo? (
+ x11-libs/cairo
+ dev-cpp/cairomm
+ python? ( dev-python/pycairo )
+ )
+ sqlite? ( dev-db/sqlite:3 )
+ nobfonts? ( media-fonts/dejavu )"
+
+DEPEND="${RDEPEND}
+ doc? ( dev-python/epydoc )
+ dev-util/scons"
+
+#EPATCH_OPTS="-F 3"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_configure() {
+ local PLUGINS=shape,raster,postgis,osm
+ use sqlite && PLUGINS+=,sqlite
+
+ SCONOPTS="
+ CC=$(tc-getCC)
+ CXX=$(tc-getCXX)
+ INPUT_PLUGINS=${PLUGINS}
+ PREFIX=/usr
+ XMLPARSER=libxml2
+ PROJ_INCLUDES=/usr/include
+ PROJ_LIBS=/usr/lib
+ $(use_scons nobfonts SYSTEM_FONTS /usr/share/fonts '')
+ $(use_scons python BINDINGS all none)
+ $(use_scons bidi BIDI)
+ $(use_scons cairo CAIRO)
+ $(use_scons debug DEBUG)
+ $(use_scons debug XML_DEBUG)
+ $(use_scons doc DEMO)
+ $(use_scons doc SAMPLE_INPUT_PLUGINS)
+ CUSTOM_LDFLAGS=${LDFLAGS}
+ CUSTOM_LDFLAGS+=-L${D}/usr/$(get_libdir)"
+
+ # force user flags, optimization level
+ sed -i -e "s:\-O%s:${CXXFLAGS}:" \
+ -i -e "s:env\['OPTIMIZATION'\]\,::" \
+ SConstruct || die "sed 3 failed"
+
+ scons $SCONOPTS configure || die "scons configure failed"
+}
+
+src_compile() {
+ scons ${MAKEOPTS} shared=1 || die "scons compile failed"
+}
+
+src_install() {
+ #the lib itself still seems to need a DESTDIR definition
+ scons DESTDIR="${D}" install || die "scons install failed"
+
+ if use python ; then
+ fperms 0644 "$(python_get_sitedir)"/mapnik2/paths.py
+ dobin utils/stats/mapdef_stats.py
+ insinto /usr/share/doc/${PF}/examples
+ doins utils/ogcserver/*
+ fi
+
+ dodoc AUTHORS README || die
+
+ # this is known to depend on mod_python and should not have a
+ # "die" after the epydoc script (see bug #370575)
+ if use doc; then
+ export PYTHONPATH="${D}$(python_get_sitedir):$(python_get_sitedir)"
+ pushd docs/epydoc_config > /dev/null
+ ./build_epydoc.sh
+ popd > /dev/null
+ dohtml -r docs/api_docs/python/* || die "API doc install failed"
+ fi
+}
+
+pkg_postinst() {
+ elog ""
+ elog "See the home page or wiki (http://trac.mapnik.org/) for more info"
+ elog "or the installed examples for the default mapnik ogcserver config."
+ elog ""
+}
diff --git a/sci-geosciences/mapnik/metadata.xml b/sci-geosciences/mapnik/metadata.xml
index 8bc5a12828ed..c7936c18745b 100644
--- a/sci-geosciences/mapnik/metadata.xml
+++ b/sci-geosciences/mapnik/metadata.xml
@@ -12,5 +12,6 @@
</longdescription>
<use>
<flag name='gdal'>Enable <pkg>sci-libs/gdal</pkg> library support</flag>
+ <flag name='nobfonts'>Enable Dejavu fonts instead of built-in fonts</flag>
</use>
</pkgmetadata>