summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2009-07-28 03:22:29 +0000
committerSteve Arnold <nerdboy@gentoo.org>2009-07-28 03:22:29 +0000
commitd7889bb485bc14534c1a54712020c19f38828d3b (patch)
tree4577620b422457f02f4ec9725c79c80612428bef /sci-geosciences
parentversion bump (diff)
downloadgentoo-2-d7889bb485bc14534c1a54712020c19f38828d3b.tar.gz
gentoo-2-d7889bb485bc14534c1a54712020c19f38828d3b.tar.bz2
gentoo-2-d7889bb485bc14534c1a54712020c19f38828d3b.zip
Updated build to work around libtool funkiness (see bug #278340).
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/gpsd/ChangeLog5
-rw-r--r--sci-geosciences/gpsd/gpsd-2.39.ebuild18
2 files changed, 10 insertions, 13 deletions
diff --git a/sci-geosciences/gpsd/ChangeLog b/sci-geosciences/gpsd/ChangeLog
index 0a8c2fccea01..5e80ba3f6d1d 100644
--- a/sci-geosciences/gpsd/ChangeLog
+++ b/sci-geosciences/gpsd/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-geosciences/gpsd
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/ChangeLog,v 1.40 2009/07/18 17:47:15 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/ChangeLog,v 1.41 2009/07/28 03:22:29 nerdboy Exp $
+
+ 28 Jul 2009; Steve Arnold <nerdboy@gentoo.org> gpsd-2.39.ebuild:
+ Updated build to work around libtool funkiness (see bug #278340).
*gpsd-2.39 (18 Jul 2009)
diff --git a/sci-geosciences/gpsd/gpsd-2.39.ebuild b/sci-geosciences/gpsd/gpsd-2.39.ebuild
index 7efc6bcfb757..151362c8601b 100644
--- a/sci-geosciences/gpsd/gpsd-2.39.ebuild
+++ b/sci-geosciences/gpsd/gpsd-2.39.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/gpsd-2.39.ebuild,v 1.1 2009/07/18 17:47:15 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/gpsd-2.39.ebuild,v 1.2 2009/07/28 03:22:29 nerdboy Exp $
inherit autotools eutils distutils flag-o-matic
@@ -31,7 +31,8 @@ RDEPEND="X? (
>=dev-libs/glib-2.6
dev-libs/dbus-glib )
ntp? ( net-misc/ntp )
- usb? ( virtual/dev-manager )"
+ usb? ( virtual/dev-manager )
+ sys-libs/ncurses"
DEPEND="${RDEPEND}
X? (
@@ -40,7 +41,6 @@ DEPEND="${RDEPEND}
)
!minimal? (
dev-libs/libxslt
- sys-libs/ncurses
)"
src_unpack() {
@@ -63,24 +63,18 @@ src_unpack() {
src_compile() {
- local my_conf="--enable-shared --with-pic --enable-static \
- --disable-fast-install"
+ local my_conf="--enable-shared --with-pic --enable-static"
# --enable-superstar2 is missing a header file
use python && distutils_python_version
- if use ntp; then
- my_conf="${my_conf} --enable-ntpshm --enable-pps"
- else
- my_conf="${my_conf} --disable-ntpshm --disable-pps"
+ if ! use ntp; then
+ my_conf="${my_conf} --disable-pps --disable-ntpshm"
fi
if use minimal; then
local max_clients="5"
local max_devices="2"
- if ! use ntp; then
- my_conf="${my_conf} --disable-pps --disable-ntpshm"
- fi
my_conf="${my_conf} --enable-squelch --without-x \
--enable-max-devices=${max_devices} \
--enable-max-clients=${max_clients}"