summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2004-12-29 16:17:54 +0000
committerOlivier Fisette <ribosome@gentoo.org>2004-12-29 16:17:54 +0000
commit2e4741501f48f455725f5419b3fb2f8c2df8bc4d (patch)
tree2ca4b75747ed27906b382b725c7a91ddd57e67a6 /sci-libs/blas/blas-19980702-r1.ebuild
parentupstream md5sum changed (diff)
downloadgentoo-2-2e4741501f48f455725f5419b3fb2f8c2df8bc4d.tar.gz
gentoo-2-2e4741501f48f455725f5419b3fb2f8c2df8bc4d.tar.bz2
gentoo-2-2e4741501f48f455725f5419b3fb2f8c2df8bc4d.zip
Moved from app-sci/blas to sci-libs/blas.
Diffstat (limited to 'sci-libs/blas/blas-19980702-r1.ebuild')
-rw-r--r--sci-libs/blas/blas-19980702-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sci-libs/blas/blas-19980702-r1.ebuild b/sci-libs/blas/blas-19980702-r1.ebuild
new file mode 100644
index 000000000000..faefd1444d66
--- /dev/null
+++ b/sci-libs/blas/blas-19980702-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas/blas-19980702-r1.ebuild,v 1.1 2004/12/29 16:17:54 ribosome Exp $
+
+DESCRIPTION="Basic Linear Algebra Subprograms"
+HOMEPAGE="http://www.netlib.org/blas/"
+SRC_URI="http://www.netlib.org/blas/${PN}.tgz"
+
+LICENSE="public-domain"
+IUSE=""
+SLOT="0"
+KEYWORDS="-* amd64 ~ppc64"
+
+DEPEND="virtual/libc"
+
+S=${WORKDIR}
+
+src_compile() {
+ cp ${FILESDIR}/Makefile ./
+ # ncessary on amd64 to make libblas.a linkable
+ use amd64 && CFLAGS="${CFLAGS} -fPIC"
+ FC="g77" FFLAGS="${CFLAGS}" make static
+}
+
+src_install() {
+ dolib.a libblas.a
+}