summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2014-01-14 18:03:16 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2014-01-14 18:03:16 +0000
commit88a5b4f54aad34ab456202ed2ea94d650edc8238 (patch)
tree8e46f1ca6ac8d57ef828fe3f094d5fdbd0ae18e1 /sci-libs/coinor-dylp/coinor-dylp-1.9.4.ebuild
parentUnmask nvidia-drivers-331.38 since the signal mask bug is hopefully fixed there (diff)
downloadgentoo-2-88a5b4f54aad34ab456202ed2ea94d650edc8238.tar.gz
gentoo-2-88a5b4f54aad34ab456202ed2ea94d650edc8238.tar.bz2
gentoo-2-88a5b4f54aad34ab456202ed2ea94d650edc8238.zip
Initial import in main tree
(Portage version: 2.2.8-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-libs/coinor-dylp/coinor-dylp-1.9.4.ebuild')
-rw-r--r--sci-libs/coinor-dylp/coinor-dylp-1.9.4.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/sci-libs/coinor-dylp/coinor-dylp-1.9.4.ebuild b/sci-libs/coinor-dylp/coinor-dylp-1.9.4.ebuild
new file mode 100644
index 000000000000..5465a7493040
--- /dev/null
+++ b/sci-libs/coinor-dylp/coinor-dylp-1.9.4.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/coinor-dylp/coinor-dylp-1.9.4.ebuild,v 1.1 2014/01/14 18:03:16 bicatali Exp $
+
+EAPI=5
+
+inherit autotools-utils multilib
+
+MYPN=DyLP
+
+DESCRIPTION="COIN-OR using the dynamic simplex linear programming solver"
+HOMEPAGE="https://projects.coin-or.org/DyLP/"
+SRC_URI="http://www.coin-or.org/download/source/${MYPN}/${MYPN}-${PV}.tgz"
+
+LICENSE="EPL-1.0"
+SLOT="0/1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples static-libs test"
+
+RDEPEND="sci-libs/coinor-osi"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen[dot] )
+ test? ( sci-libs/coinor-sample )"
+
+S="${WORKDIR}/${MYPN}-${PV}/${MYPN}"
+
+src_prepare() {
+ # as-needed fix
+ # hack to avoid eautoreconf (coinor has its own weird autotools)
+ sed -i \
+ -e 's:\(libOsiDylp_la_LIBADD.*=.*\)$:\1 $(top_builddir)/src/Dylp/libDylp.la @OSIDYLPLIB_LIBS@:g' \
+ src/OsiDylp/Makefile.in || die
+ sed -i \
+ -e 's:\(libDylpStdLib_la_LIBADD.*=.*\)$:\1 @DYLPLIB_LIBS@:g' \
+ src/DylpStdLib/Makefile.in || die
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with doc dot)
+ )
+ PKG_CONFIG_PATH+="${ED}"/usr/$(get_libdir)/pkgconfig \
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile all $(use doc && echo doxydoc)
+}
+
+src_test() {
+ pushd "${BUILD_DIR}" > /dev/null || die
+ emake test
+ popd > /dev/null || die
+}
+
+src_install() {
+ use doc && HTML_DOC=("${BUILD_DIR}/doxydocs/html/")
+ autotools-utils_src_install
+ # already installed
+ rm "${ED}"/usr/share/coin/doc/${MYPN}/{README,AUTHORS,LICENSE} || die
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}