summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-02-05 18:02:34 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-02-05 18:02:34 +0000
commit2e2f76ed005eebefef05e8afe1982ac66d10cda5 (patch)
treefb36138bdee768027ca1b140407ac52a35460d6c /sci-libs/colamd
parent Initial import. Closing bug #53394. (diff)
downloadgentoo-2-2e2f76ed005eebefef05e8afe1982ac66d10cda5.tar.gz
gentoo-2-2e2f76ed005eebefef05e8afe1982ac66d10cda5.tar.bz2
gentoo-2-2e2f76ed005eebefef05e8afe1982ac66d10cda5.zip
Initial import. Thanks to Justin Bronder for his work, see bug #173900
(Portage version: 2.1.4)
Diffstat (limited to 'sci-libs/colamd')
-rw-r--r--sci-libs/colamd/ChangeLog10
-rw-r--r--sci-libs/colamd/Manifest5
-rw-r--r--sci-libs/colamd/colamd-2.7.1.ebuild30
-rw-r--r--sci-libs/colamd/files/colamd-2.7.1-autotools.patch58
-rw-r--r--sci-libs/colamd/metadata.xml17
5 files changed, 120 insertions, 0 deletions
diff --git a/sci-libs/colamd/ChangeLog b/sci-libs/colamd/ChangeLog
new file mode 100644
index 000000000000..47313ab4b29f
--- /dev/null
+++ b/sci-libs/colamd/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-libs/colamd
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/colamd/ChangeLog,v 1.1 2008/02/05 18:02:34 bicatali Exp $
+
+*colamd-2.7.1 (05 Feb 2008)
+
+ 05 Feb 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/colamd-2.7.1-autotools.patch, +metadata.xml, +colamd-2.7.1.ebuild:
+ Initial import. Thanks to Justin Bronder for his work, see bug #173900
+
diff --git a/sci-libs/colamd/Manifest b/sci-libs/colamd/Manifest
new file mode 100644
index 000000000000..622a523fa2c1
--- /dev/null
+++ b/sci-libs/colamd/Manifest
@@ -0,0 +1,5 @@
+AUX colamd-2.7.1-autotools.patch 1779 RMD160 97d68418d4f9e9f67ffbd127364d4f60b5cb4e9a SHA1 2c48650ac67293990eb75224d063bc668871c328 SHA256 f672d5e0a205011e9e6a701e592188e5f0c352d0158d1a376e297e28e7d9554d
+DIST COLAMD-2.7.1.tar.gz 55906 RMD160 04acdf4a2d9d16050258a973213686a94544277a SHA1 263803878f8d9abdfa5dd6d5209c73414d99d350 SHA256 b6362c7c8454a5ef305443d44fa4a7d6a3ad19e9b2431c8356a266fd258f35af
+EBUILD colamd-2.7.1.ebuild 706 RMD160 7ff12c767ed35dad0b3f68949f7143275ecc39ef SHA1 000b29abb856c3ea87f7691a9902754e87fbdbcf SHA256 a5f3cfbe6e3021de476943517705795aca8e2bf2994f2f6034882b22588cec0e
+MISC ChangeLog 350 RMD160 ed34b7b0f7b4193685ad6f02f7f14c35e8fd0a9c SHA1 39bf6ef54b54d311fddac11abea0b155982a1adb SHA256 b4f847556a8c1134155f8541bc136cd11768705ecc617438fd0d50d4706951a9
+MISC metadata.xml 850 RMD160 3b8e03422846e9b0b2296efcc7c3e9e5e339d60f SHA1 022dbb7c82c1b6a52aed33a13c099b9562304abb SHA256 8796fed39251490a755aed9bce464371c0ed14075e90ebbdbf5a9a1aa03af309
diff --git a/sci-libs/colamd/colamd-2.7.1.ebuild b/sci-libs/colamd/colamd-2.7.1.ebuild
new file mode 100644
index 000000000000..1a0f422eb802
--- /dev/null
+++ b/sci-libs/colamd/colamd-2.7.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/colamd/colamd-2.7.1.ebuild,v 1.1 2008/02/05 18:02:34 bicatali Exp $
+
+inherit autotools eutils
+
+MY_PN=COLAMD
+DESCRIPTION="Column approximate minimum degree ordering algorithm"
+HOMEPAGE="http://www.cise.ufl.edu/research/sparse/colamd"
+SRC_URI="http://www.cise.ufl.edu/research/sparse/${PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND="sci-libs/ufconfig"
+
+S="${WORKDIR}/${MY_PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-autotools.patch
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README.txt Doc/ChangeLog || die "dodoc failed"
+}
diff --git a/sci-libs/colamd/files/colamd-2.7.1-autotools.patch b/sci-libs/colamd/files/colamd-2.7.1-autotools.patch
new file mode 100644
index 000000000000..bb7b80fcc6f0
--- /dev/null
+++ b/sci-libs/colamd/files/colamd-2.7.1-autotools.patch
@@ -0,0 +1,58 @@
+--- Makefile.am 1970-01-01 01:00:00.000000000 +0100
++++ Makefile.am 2008-01-29 19:06:31.000000000 +0000
+@@ -0,0 +1,3 @@
++SUBDIRS = Source Demo
++include_HEADERS = $(top_srcdir)/Include/colamd.h
++EXTRA_DIST = README.txt
+--- configure.ac 1970-01-01 01:00:00.000000000 +0100
++++ configure.ac 2008-01-29 19:06:31.000000000 +0000
+@@ -0,0 +1,12 @@
++# -*- Autoconf -*-
++AC_PREREQ(2.59)
++AC_INIT(colamd, 2.7.1, davis@cise.ufl.edu)
++AM_INIT_AUTOMAKE([foreign])
++AC_PROG_INSTALL
++AC_PROG_LIBTOOL
++AC_CHECK_LIB(m, sqrt)
++AC_CHECK_HEADER( UFconfig.h )
++AC_OUTPUT(
++ Makefile \
++ Demo/Makefile \
++ Source/Makefile)
+--- Source/Makefile.am 1970-01-01 01:00:00.000000000 +0100
++++ Source/Makefile.am 2008-01-29 19:06:31.000000000 +0000
+@@ -0,0 +1,11 @@
++AM_CFLAGS = -I$(top_builddir)/Include
++lib_LTLIBRARIES = libcolamd.la
++noinst_LTLIBRARIES = libcolamdi.la libcolamdl.la
++
++libcolamdl_la_SOURCES = colamd.c
++libcolamdl_la_CPPFLAGS = -DDLONG
++
++libcolamdi_la_SOURCES = colamd.c
++
++libcolamd_la_SOURCES = colamd_global.c
++libcolamd_la_LIBADD = libcolamdi.la libcolamdl.la
+--- Demo/Makefile.am 1970-01-01 01:00:00.000000000 +0100
++++ Demo/Makefile.am 2008-01-29 19:06:31.000000000 +0000
+@@ -0,0 +1,20 @@
++LDADD = $(top_builddir)/Source/libcolamd.la
++AM_CPPFLAGS = -I$(top_srcdir)/Include
++
++check_PROGRAMS = colamd_example colamd_l_example
++colamd_example_SOURCES = colamd_example.c
++colamd_l_example_SOURCES = colamd_l_example.c
++colamd_l_example_CPPFLAGS = $(AM_CPPFLAGS) -DDLONG
++
++check-local: $(check_PROGRAMS)
++ @for i in $(check_PROGRAMS); do \
++ echo "Testing $$i"; \
++ ./$$i > my_$$i.out; \
++ if ! diff $$i.out my_$$i.out; then \
++ echo "Testing $$i failed"; \
++ exit 1; \
++ fi \
++ done;
++
++clean-local:
++ rm -f my*.out
diff --git a/sci-libs/colamd/metadata.xml b/sci-libs/colamd/metadata.xml
new file mode 100644
index 000000000000..5e7e28f3c14e
--- /dev/null
+++ b/sci-libs/colamd/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ The COLAMD column approximate minimum degree ordering algorithm
+ computes a permutation vector P such that the LU factorization of A
+ (:,P) tends to be sparser than that of A. The Cholesky factorization
+ of (A (:,P))\'*(A (:,P)) will also tend to be sparser than that of
+ A\'*A. SYMAMD is a symmetric minimum degree ordering method based on
+ COLAMD, available as a MATLAB-callable function. It constructs a
+ matrix M such that M\'*M has the same pattern as A, and then uses
+ COLAMD to compute a column ordering of M. Colamd and symamd tend to be
+ faster and generate better orderings than their MATLAB counterparts,
+ colmmd and symmmd.
+</longdescription>
+</pkgmetadata>