summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2006-04-30 14:59:22 +0000
committerMarkus Dittrich <markusle@gentoo.org>2006-04-30 14:59:22 +0000
commitb1f44b22cb603d8b5661506e6ad5118549e5c6af (patch)
treeca62e31e797bf4fd2b1feb9cc4f7d6ae46859b3c /sci-libs/galib
parentBlue skin updated (diff)
downloadgentoo-2-b1f44b22cb603d8b5661506e6ad5118549e5c6af.tar.gz
gentoo-2-b1f44b22cb603d8b5661506e6ad5118549e5c6af.tar.bz2
gentoo-2-b1f44b22cb603d8b5661506e6ad5118549e5c6af.zip
Patched makefile to also install crucial std_stream.h header into include directory. This fixes bug #131629.
(Portage version: 2.1_pre9-r4)
Diffstat (limited to 'sci-libs/galib')
-rw-r--r--sci-libs/galib/ChangeLog10
-rw-r--r--sci-libs/galib/files/digest-galib-2.4.62
-rw-r--r--sci-libs/galib/files/galib-2.4.6-makefile.patch12
-rw-r--r--sci-libs/galib/galib-2.4.6.ebuild10
4 files changed, 30 insertions, 4 deletions
diff --git a/sci-libs/galib/ChangeLog b/sci-libs/galib/ChangeLog
index 71bed58dfb65..e54240374640 100644
--- a/sci-libs/galib/ChangeLog
+++ b/sci-libs/galib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/galib
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/galib/ChangeLog,v 1.4 2005/09/21 15:30:17 phosphan Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/galib/ChangeLog,v 1.5 2006/04/30 14:59:22 markusle Exp $
+
+ 30 Apr 2006; Markus Dittrich <markusle@gentoo.org>
+ +files/galib-2.4.6-makefile.patch, galib-2.4.6.ebuild:
+ Patched makefile to also install crucial std_stream.h header into
+ include directory. Thanks much to dongxu li <butdiene@yahoo.com>
+ for pointing this out. This fixes bug #131629.
21 Sep 2005; Patrick Kursawe <phosphan@gentoo.org>
-files/galib-2.4.5-gcc3.3.patch, -galib-2.4.5.ebuild, galib-2.4.6.ebuild:
diff --git a/sci-libs/galib/files/digest-galib-2.4.6 b/sci-libs/galib/files/digest-galib-2.4.6
index 12c8115ed1e5..0294e051dbd3 100644
--- a/sci-libs/galib/files/digest-galib-2.4.6
+++ b/sci-libs/galib/files/digest-galib-2.4.6
@@ -1 +1,3 @@
MD5 e61efce22161907449b07f8472eb7c7c galib246.tgz 378431
+RMD160 9e74f2001d7583680effe6f8b04ebf9ced39291c galib246.tgz 378431
+SHA256 441150c728d401a93ed6d9e745eae85f9ddbd413cfe06396f1a426cd31c7cc00 galib246.tgz 378431
diff --git a/sci-libs/galib/files/galib-2.4.6-makefile.patch b/sci-libs/galib/files/galib-2.4.6-makefile.patch
new file mode 100644
index 000000000000..a2ced027a4a1
--- /dev/null
+++ b/sci-libs/galib/files/galib-2.4.6-makefile.patch
@@ -0,0 +1,12 @@
+--- galib246/ga/makefile.sources 2000-02-03 14:00:46.000000000 -0600
++++ galib246-new/ga/makefile.sources 2006-04-30 09:30:13.000000000 -0500
+@@ -8,7 +8,8 @@
+ GA1DBinStrGenome.h GA2DBinStrGenome.h GA3DBinStrGenome.h GABin2DecGenome.h \
+ GA1DArrayGenome.h GA2DArrayGenome.h GA3DArrayGenome.h \
+ GAStringGenome.h GARealGenome.h \
+- GATreeBASE.h GATree.h GATreeGenome.h GAListBASE.h GAList.h GAListGenome.h
++ GATreeBASE.h GATree.h GATreeGenome.h GAListBASE.h GAList.h GAListGenome.h \
++ std_stream.h
+ SRCS= garandom.C gaerror.C GAParameter.C GAStatistics.C \
+ GABaseGA.C GASStateGA.C GASimpleGA.C GAIncGA.C GADemeGA.C GADCrowdingGA.C \
+ GASelector.C GAScaling.C GAPopulation.C GAGenome.C \
diff --git a/sci-libs/galib/galib-2.4.6.ebuild b/sci-libs/galib/galib-2.4.6.ebuild
index beb8a90bb510..d1230875683e 100644
--- a/sci-libs/galib/galib-2.4.6.ebuild
+++ b/sci-libs/galib/galib-2.4.6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/galib/galib-2.4.6.ebuild,v 1.2 2005/09/21 15:30:17 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/galib/galib-2.4.6.ebuild,v 1.3 2006/04/30 14:59:22 markusle Exp $
inherit eutils
@@ -18,6 +18,12 @@ DEPEND=""
S="${WORKDIR}/galib${MYPV}"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-makefile.patch
+}
+
src_compile() {
make CXXFLAGS="${CXXFLAGS}" || die "make failed"
}