summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2013-03-02 16:09:54 +0000
committerAaron W. Swenson <titanofold@gentoo.org>2013-03-02 16:09:54 +0000
commit0161c519863376f225e3c095aaf98b5b728908c2 (patch)
tree32090dbfc87428c0cb0651048943a6a25bb4b1b4 /sci-libs/geos
parentStable for sh, wrt bug #458122 (diff)
downloadgentoo-2-0161c519863376f225e3c095aaf98b5b728908c2.tar.gz
gentoo-2-0161c519863376f225e3c095aaf98b5b728908c2.tar.bz2
gentoo-2-0161c519863376f225e3c095aaf98b5b728908c2.zip
Fix bug 455118 by modifying PHP dependency. Fix bug 450998 by correcting dohtml command. Fix bug 423097 by virtue of being bumped.
(Portage version: 2.1.11.52/cvs/Linux x86_64, signed Manifest commit with key D1BBFDA0)
Diffstat (limited to 'sci-libs/geos')
-rw-r--r--sci-libs/geos/ChangeLog9
-rw-r--r--sci-libs/geos/geos-3.3.8-r1.ebuild (renamed from sci-libs/geos/geos-3.3.8.ebuild)18
2 files changed, 21 insertions, 6 deletions
diff --git a/sci-libs/geos/ChangeLog b/sci-libs/geos/ChangeLog
index 1c891f00dbad..4226fe0e8030 100644
--- a/sci-libs/geos/ChangeLog
+++ b/sci-libs/geos/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-libs/geos
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/ChangeLog,v 1.71 2013/03/02 04:04:09 titanofold Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/ChangeLog,v 1.72 2013/03/02 16:09:54 titanofold Exp $
+
+*geos-3.3.8-r1 (02 Mar 2013)
+
+ 02 Mar 2013; Aaron W. Swenson <titanofold@gentoo.org> -geos-3.3.8.ebuild,
+ +geos-3.3.8-r1.ebuild:
+ Fix bug 455118 by modifying PHP dependency. Fix bug 450998 by correcting
+ dohtml command. Fix bug 423097 by virtue of being bumped.
*geos-3.3.8 (02 Mar 2013)
diff --git a/sci-libs/geos/geos-3.3.8.ebuild b/sci-libs/geos/geos-3.3.8-r1.ebuild
index ff147d3b0b4c..ea49cb4d3f28 100644
--- a/sci-libs/geos/geos-3.3.8.ebuild
+++ b/sci-libs/geos/geos-3.3.8-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/geos-3.3.8.ebuild,v 1.1 2013/03/02 04:04:09 titanofold Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/geos-3.3.8-r1.ebuild,v 1.1 2013/03/02 16:09:54 titanofold Exp $
EAPI=4
@@ -18,13 +18,16 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x64-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
IUSE="doc php python ruby static-libs"
-RDEPEND="php? ( dev-lang/php:5.3[-threads] )
- ruby? ( dev-lang/ruby )"
+RDEPEND="
+ php? ( >=dev-lang/php-5.3[-threads] )
+ ruby? ( dev-lang/ruby )
+"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )
php? ( dev-lang/swig )
python? ( dev-lang/swig )
- ruby? ( dev-lang/swig )"
+ ruby? ( dev-lang/swig )
+"
pkg_setup() {
use python && python_pkg_setup
@@ -49,6 +52,7 @@ src_configure() {
src_compile() {
emake
+
if use python; then
emake -C swig/python clean
python_copy_sources swig/python
@@ -62,11 +66,13 @@ src_compile() {
}
python_execute_function -s --source-dir swig/python building
fi
+
use doc && emake -C "${S}/doc" doxygen-html
}
src_install() {
default
+
if use python; then
installation() {
emake \
@@ -78,7 +84,9 @@ src_install() {
python_execute_function -s --source-dir swig/python installation
python_clean_installation_image
fi
- use doc && dohtml -r "${S}/doc" doxygen_docs/html/*
+
+ use doc && dohtml -r doc/doxygen_docs/html/*
+
find "${ED}" -name '*.la' -exec rm -f {} +
}