summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-06-27 18:28:03 +0000
committerJustin Lecher <jlec@gentoo.org>2010-06-27 18:28:03 +0000
commita202457ae7dcdb0ab1205ffb8d1e5a552ff21200 (patch)
tree8bf64948fe24636d714d4f4d8c96e2b68f9e1d5d /sci-libs/geos
parentx86 stable, bug 322791 (diff)
downloadgentoo-2-a202457ae7dcdb0ab1205ffb8d1e5a552ff21200.tar.gz
gentoo-2-a202457ae7dcdb0ab1205ffb8d1e5a552ff21200.tar.bz2
gentoo-2-a202457ae7dcdb0ab1205ffb8d1e5a552ff21200.zip
More inteligent search in configure for python stuff
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/geos')
-rw-r--r--sci-libs/geos/ChangeLog6
-rw-r--r--sci-libs/geos/files/3.2.0-python.patch40
-rw-r--r--sci-libs/geos/geos-3.2.0-r1.ebuild5
3 files changed, 48 insertions, 3 deletions
diff --git a/sci-libs/geos/ChangeLog b/sci-libs/geos/ChangeLog
index 8220fba452e9..ca3fad54a421 100644
--- a/sci-libs/geos/ChangeLog
+++ b/sci-libs/geos/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/geos
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/ChangeLog,v 1.45 2010/06/26 18:11:29 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/ChangeLog,v 1.46 2010/06/27 18:28:03 jlec Exp $
+
+ 27 Jun 2010; Justin Lecher <jlec@gentoo.org> +files/3.2.0-python.patch,
+ geos-3.2.0-r1.ebuild:
+ More inteligent search in configure for python stuff
26 Jun 2010; Kacper Kowalik <xarthisius@gentoo.org>
+files/3.2.0-swig2.0.patch, geos-3.2.0-r1.ebuild:
diff --git a/sci-libs/geos/files/3.2.0-python.patch b/sci-libs/geos/files/3.2.0-python.patch
new file mode 100644
index 000000000000..b4a85c0410ad
--- /dev/null
+++ b/sci-libs/geos/files/3.2.0-python.patch
@@ -0,0 +1,40 @@
+diff --git a/macros/ac_python_devel.m4 b/macros/ac_python_devel.m4
+index d67842b..f3a3a3b 100644
+--- a/macros/ac_python_devel.m4
++++ b/macros/ac_python_devel.m4
+@@ -29,13 +29,10 @@ AC_DEFUN([AC_PYTHON_DEVEL],[
+
+ # Check for Python include path
+ AC_MSG_CHECKING([for Python include path])
+- for i in "$base_python_path/include/python$PYTHON_VERSION/" "$base_python_path/include/python/" "$base_python_path/include/" "$base_python_path/" ; do
+- python_path=`find $i -type f -name Python.h -print 2> /dev/null | sed "1q"`
+- if test -n "$python_path" ; then
+- break
+- fi
+- done
+- python_path=`echo $python_path | sed "s,/Python.h$,,"`
++ python_path="${base_python_path}/include/python$PYTHON_VERSION/"
++ if test ! -f "${python_path}"/Python.h ; then
++ python_path=""
++ fi
+ AC_MSG_RESULT([$python_path])
+ if test -z "$python_path" ; then
+ AC_MSG_ERROR([cannot find Python include path])
+@@ -44,13 +41,10 @@ AC_DEFUN([AC_PYTHON_DEVEL],[
+
+ # Check for Python library path
+ AC_MSG_CHECKING([for Python library path])
+- for i in "$base_python_path/lib/python$PYTHON_VERSION/config/" "$base_python_path/lib/python$PYTHON_VERSION/" "$base_python_path/lib/python/config/" "$base_python_path/lib/python/" "$base_python_path/" "$base_python_path/libs/" ; do
+- python_path=`find $i -name libpython$PYTHON_VERSION.* -print 2> /dev/null | sed "1q"`
+- if test -n "$python_path" ; then
+- break
+- fi
+- done
+- python_path=`echo $python_path | sed "s,/libpython.*$,,"`
++ python_path=`python$PYTHON_VERSION -c 'import distutils.sysconfig; print(distutils.sysconfig.get_config_var("LIBDIR"))'`
++ if test ! -f "${python_path}"/libpython$PYTHON_VERSION.so ; then
++ python_path=""
++ fi
+ AC_MSG_RESULT([$python_path])
+ if test -z "$python_path" ; then
+ AC_MSG_ERROR([cannot find Python library path])
diff --git a/sci-libs/geos/geos-3.2.0-r1.ebuild b/sci-libs/geos/geos-3.2.0-r1.ebuild
index 386acf97e0f5..fc29ea6fa9fa 100644
--- a/sci-libs/geos/geos-3.2.0-r1.ebuild
+++ b/sci-libs/geos/geos-3.2.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/geos-3.2.0-r1.ebuild,v 1.3 2010/06/26 18:11:29 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/geos-3.2.0-r1.ebuild,v 1.4 2010/06/27 18:28:03 jlec Exp $
EAPI=2
@@ -33,7 +33,8 @@ pkg_setup() {
src_prepare() {
epatch "${FILESDIR}"/${PV}-multipy.patch \
- "${FILESDIR}"/${PV}-swig2.0.patch
+ "${FILESDIR}"/${PV}-swig2.0.patch \
+ "${FILESDIR}"/${PV}-python.patch
eautoreconf
echo "#!/bin/bash" > py-compile
}