summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2013-06-25 18:12:45 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2013-06-25 18:12:45 +0000
commitbb329a034ac0ba68e04e4a2bc2ad61b229bc05d2 (patch)
treec933607a586b833c0d4050a58ff152b0779a71d9 /sci-libs/itpp
parentVersion bump. (diff)
downloadgentoo-2-bb329a034ac0ba68e04e4a2bc2ad61b229bc05d2.tar.gz
gentoo-2-bb329a034ac0ba68e04e4a2bc2ad61b229bc05d2.tar.bz2
gentoo-2-bb329a034ac0ba68e04e4a2bc2ad61b229bc05d2.zip
Version bump
(Portage version: 2.2.01.22013-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-libs/itpp')
-rw-r--r--sci-libs/itpp/ChangeLog8
-rw-r--r--sci-libs/itpp/itpp-4.3.0.ebuild45
-rw-r--r--sci-libs/itpp/metadata.xml4
3 files changed, 54 insertions, 3 deletions
diff --git a/sci-libs/itpp/ChangeLog b/sci-libs/itpp/ChangeLog
index d502381a8db5..279298dd5ad0 100644
--- a/sci-libs/itpp/ChangeLog
+++ b/sci-libs/itpp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/itpp
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/ChangeLog,v 1.117 2013/02/21 21:30:40 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/ChangeLog,v 1.118 2013/06/25 18:12:45 bicatali Exp $
+
+*itpp-4.3.0 (25 Jun 2013)
+
+ 25 Jun 2013; Sébastien Fabbro <bicatali@gentoo.org> +itpp-4.3.0.ebuild,
+ metadata.xml:
+ Version bump
21 Feb 2013; Justin Lecher <jlec@gentoo.org> -itpp-4.0.6.ebuild,
itpp-4.2-r1.ebuild, itpp-4.2-r2.ebuild, metadata.xml:
diff --git a/sci-libs/itpp/itpp-4.3.0.ebuild b/sci-libs/itpp/itpp-4.3.0.ebuild
new file mode 100644
index 000000000000..17bc0f6ae64e
--- /dev/null
+++ b/sci-libs/itpp/itpp-4.3.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/itpp-4.3.0.ebuild,v 1.1 2013/06/25 18:12:45 bicatali Exp $
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="C++ library of mathematical, signal processing and communication"
+HOMEPAGE="http://itpp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND="
+ virtual/blas
+ virtual/lapack
+ >=sci-libs/fftw-3"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen virtual/latex-base )"
+
+DOCS=(ChangeLog NEWS AUTHORS README)
+
+src_prepare() {
+ # gentoo redefines the CMAKE_BUILD_TYPE
+ sed -i \
+ -e 's/CMAKE_BUILD_TYPE STREQUAL Release/NOT CMAKE_BUILD_TYPE STREQUAL Debug/' \
+ CMakeLists.txt || die
+ # respect gentoo doc dir
+ sed -i \
+ -e "s:share/doc/itpp:share/doc/${PF}:" \
+ itpp/CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBLA_VENDOR=Generic
+ $(cmake-utils_use doc HTML_DOCS)
+ )
+ cmake-utils_src_configure
+}
diff --git a/sci-libs/itpp/metadata.xml b/sci-libs/itpp/metadata.xml
index 8d93511d9b03..775bbb934a4b 100644
--- a/sci-libs/itpp/metadata.xml
+++ b/sci-libs/itpp/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci</herd>
- <longdescription lang="en">
+<herd>sci</herd>
+<longdescription lang="en">
IT++ is a C++ library of mathematical, signal processing and
communication classes and functions. Its main use is in simulation
of communication systems and for performing research in the area of