summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2006-01-03 15:56:19 +0000
committerMarkus Dittrich <markusle@gentoo.org>2006-01-03 15:56:19 +0000
commit3bf657e3905e02a00909357de74cc9ce4bee5092 (patch)
tree21a548bfc096e382bb77f4669cf85c94695858b2 /sci-libs/libqalculate/libqalculate-0.9.2.ebuild
parentFixed bug #117516. (diff)
downloadgentoo-2-3bf657e3905e02a00909357de74cc9ce4bee5092.tar.gz
gentoo-2-3bf657e3905e02a00909357de74cc9ce4bee5092.tar.bz2
gentoo-2-3bf657e3905e02a00909357de74cc9ce4bee5092.zip
New version. This fixes bug #116959.
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'sci-libs/libqalculate/libqalculate-0.9.2.ebuild')
-rw-r--r--sci-libs/libqalculate/libqalculate-0.9.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sci-libs/libqalculate/libqalculate-0.9.2.ebuild b/sci-libs/libqalculate/libqalculate-0.9.2.ebuild
new file mode 100644
index 000000000000..28e23e5b69f5
--- /dev/null
+++ b/sci-libs/libqalculate/libqalculate-0.9.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libqalculate/libqalculate-0.9.2.ebuild,v 1.1 2006/01/03 15:56:19 markusle Exp $
+
+DESCRIPTION="A modern multi-purpose calculator library"
+LICENSE="GPL-2"
+HOMEPAGE="http://qalculate.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qalculate/${P}.tar.gz"
+
+SLOT="0"
+IUSE="nls readline"
+KEYWORDS="~amd64 ~sparc ~x86"
+
+DEPEND="dev-lang/perl
+ dev-perl/XML-Parser
+ >=dev-util/pkgconfig-0.12.0"
+
+RDEPEND=">=sci-libs/cln-1.1
+ dev-libs/libxml2
+ >=dev-libs/glib-2.4
+ >=media-gfx/gnuplot-3.7
+ net-misc/wget
+ nls? ( sys-devel/gettext )
+ readline? ( sys-libs/readline )"
+
+src_compile() {
+ # The CLN test is buggy and will often fail though an appropriate version
+ # of the library is installed.
+ CONFIG="$(use_with readline) --disable-clntest"
+ econf ${CONFIG} || die "Configuration failed."
+ emake || die "Compilation failed."
+}
+
+src_install() {
+ einstall || die "Installation failed."
+ DOCS="AUTHORS ChangeLog NEWS README TODO"
+ dodoc ${DOCS} || die "Documentation installation failed."
+}