summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-01-23 14:11:22 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-01-23 14:11:22 +0000
commit4bf980e238386f99e26369d379fdb1caa2949675 (patch)
tree88b0f70103018ebf9969407c0c7f97c1ad8bc5b1 /sci-libs/minuit
parentDrop stardict dependency as it's provided by stardict.eclass. (diff)
downloadgentoo-2-4bf980e238386f99e26369d379fdb1caa2949675.tar.gz
gentoo-2-4bf980e238386f99e26369d379fdb1caa2949675.tar.bz2
gentoo-2-4bf980e238386f99e26369d379fdb1caa2949675.zip
Version bump
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/minuit')
-rw-r--r--sci-libs/minuit/ChangeLog10
-rw-r--r--sci-libs/minuit/files/minuit-5.22.00-as-needed.patch11
-rw-r--r--sci-libs/minuit/minuit-5.22.00.ebuild70
3 files changed, 89 insertions, 2 deletions
diff --git a/sci-libs/minuit/ChangeLog b/sci-libs/minuit/ChangeLog
index dbca73022fc8..e6ff9a72fc68 100644
--- a/sci-libs/minuit/ChangeLog
+++ b/sci-libs/minuit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/minuit
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/minuit/ChangeLog,v 1.7 2008/07/03 10:16:31 bicatali Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/minuit/ChangeLog,v 1.8 2009/01/23 14:11:22 bicatali Exp $
+
+*minuit-5.22.00 (23 Jan 2009)
+
+ 23 Jan 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/minuit-5.22.00-as-needed.patch, +minuit-5.22.00.ebuild:
+ Version bump
*minuit-5.20.00 (03 Jul 2008)
diff --git a/sci-libs/minuit/files/minuit-5.22.00-as-needed.patch b/sci-libs/minuit/files/minuit-5.22.00-as-needed.patch
new file mode 100644
index 000000000000..850098839c20
--- /dev/null
+++ b/sci-libs/minuit/files/minuit-5.22.00-as-needed.patch
@@ -0,0 +1,11 @@
+--- src/Makefile.am.orig 2009-01-22 00:44:01.925673316 +0000
++++ src/Makefile.am 2009-01-22 00:43:34.963076306 +0000
+@@ -79,6 +79,8 @@
+ mnvert.cxx \
+ mnxerbla.cxx
+
++libMinuit2_la_LDFLAGS = $(OPENMP_CXXFLAGS)
++
+ INCLUDES = \
+ -I$(top_srcdir)/inc
+
diff --git a/sci-libs/minuit/minuit-5.22.00.ebuild b/sci-libs/minuit/minuit-5.22.00.ebuild
new file mode 100644
index 000000000000..6482124a2c96
--- /dev/null
+++ b/sci-libs/minuit/minuit-5.22.00.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/minuit/minuit-5.22.00.ebuild,v 1.1 2009/01/23 14:11:22 bicatali Exp $
+
+EAPI=2
+inherit eutils toolchain-funcs flag-o-matic autotools
+
+MY_PN=Minuit2
+
+DESCRIPTION="A C++ physics analysis tool for function minimization"
+HOMEPAGE="http://seal.web.cern.ch/seal/MathLibs/Minuit2/html/index.html"
+
+SRC_URI="http://seal.web.cern.ch/seal/MathLibs/${MY_PN}/${MY_PN}-${PV}.tar.gz
+ doc? ( http://seal.cern.ch/documents/minuit/mnusersguide.pdf
+ http://seal.cern.ch/documents/minuit/mntutorial.pdf )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="doc openmp"
+DEPEND="doc? ( app-doc/doxygen )"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+pkg_setup() {
+ if use openmp && [[ $(tc-getCXX)$ == *g++* ]]; then
+ if built_with_use sys-devel/gcc openmp; then
+ append-ldflags -lgomp
+ else
+ ewarn "You are using gcc built without openmp"
+ ewarn "Switch CXX to an OpenMP capable compiler"
+ die "Need openmp"
+ fi
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+ AT_M4DIR="config/m4" eautoreconf
+}
+
+src_compile() {
+ emake || die "emake failed"
+ if use doc; then
+ emake docs || die "emake docs failed"
+ fi
+}
+
+src_test() {
+ emake check || die "emake check failed"
+ # make check only compiles the tests. run them
+ for d in test/Mn*; do
+ cd "${S}"/${d}
+ for t in test_*; do
+ ./${t} || die "${t} failed"
+ done
+ done
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ insinto /usr/share/doc/${PF}/MnTutorial
+ doins test/MnTutorial/*.{h,cxx}
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins "${DISTDIR}"/mn*.pdf || die "doins failed"
+ dohtml -r doc/html/* || die "dohtml failed"
+ fi
+}