summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-02-11 22:31:19 +0000
committerJustin Lecher <jlec@gentoo.org>2010-02-11 22:31:19 +0000
commitab4352e6fec16ef5e47645ae7d630ca61f9df1d6 (patch)
tree272d78a11b6771ac0548f8b36380a63ef83c6655 /sci-libs/mmtk
parentInitial import of litc. (diff)
downloadgentoo-2-ab4352e6fec16ef5e47645ae7d630ca61f9df1d6.tar.gz
gentoo-2-ab4352e6fec16ef5e47645ae7d630ca61f9df1d6.tar.bz2
gentoo-2-ab4352e6fec16ef5e47645ae7d630ca61f9df1d6.zip
Version bump, fixed missing doc installation per 298003, removed old version, which is breaking w/o numeric
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/mmtk')
-rw-r--r--sci-libs/mmtk/ChangeLog11
-rw-r--r--sci-libs/mmtk/mmtk-2.4.6.ebuild35
-rw-r--r--sci-libs/mmtk/mmtk-2.6.1.ebuild46
3 files changed, 55 insertions, 37 deletions
diff --git a/sci-libs/mmtk/ChangeLog b/sci-libs/mmtk/ChangeLog
index cbf78a6f7a1a..11988cfe1558 100644
--- a/sci-libs/mmtk/ChangeLog
+++ b/sci-libs/mmtk/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-libs/mmtk
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/mmtk/ChangeLog,v 1.5 2006/10/17 03:49:02 dberkholz Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/mmtk/ChangeLog,v 1.6 2010/02/11 22:31:19 jlec Exp $
+
+*mmtk-2.6.1 (11 Feb 2010)
+
+ 11 Feb 2010; Justin Lecher (jlec) <jlec@gentoo.org> -mmtk-2.4.6.ebuild,
+ +mmtk-2.6.1.ebuild:
+ Version bump, fixed missing doc installation per 298003, removed old
+ version, which is breaking w/o numeric
17 Oct 2006; Donnie Berkholz <dberkholz@gentoo.org>; mmtk-2.4.6.ebuild:
Homepage update.
diff --git a/sci-libs/mmtk/mmtk-2.4.6.ebuild b/sci-libs/mmtk/mmtk-2.4.6.ebuild
deleted file mode 100644
index d52fe7469a6c..000000000000
--- a/sci-libs/mmtk/mmtk-2.4.6.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/mmtk/mmtk-2.4.6.ebuild,v 1.2 2006/10/17 03:49:02 dberkholz Exp $
-
-MY_P=${P/mmtk/MMTK}
-S=${WORKDIR}/${MY_P}
-
-inherit distutils
-
-# This number identifies each release on the CRU website.
-# Can't figure out how to avoid hardcoding it.
-NUMBER="742"
-IUSE=""
-DESCRIPTION="Molecular Modeling ToolKit for Python"
-SRC_URI="http://sourcesup.cru.fr/frs/download.php/${NUMBER}/${MY_P}.tar.gz"
-HOMEPAGE="http://dirac.cnrs-orleans.fr/MMTK/"
-SLOT="0"
-LICENSE="as-is"
-KEYWORDS="~ppc ~x86"
-
-RDEPEND="dev-python/scientificpython"
-DEPEND="${RDEPEND}"
-
-src_install() {
- distutils_src_install
-
- dodoc MANIFEST.in COPYRIGHT README*
- cd Doc
- dodoc CHANGELOG
- dohtml HTML/*
-
- dodir /usr/share/doc/${PF}/pdf
- insinto /usr/share/doc/${PF}/pdf
- doins PDF/*
-}
diff --git a/sci-libs/mmtk/mmtk-2.6.1.ebuild b/sci-libs/mmtk/mmtk-2.6.1.ebuild
new file mode 100644
index 000000000000..bca27df0430d
--- /dev/null
+++ b/sci-libs/mmtk/mmtk-2.6.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/mmtk/mmtk-2.6.1.ebuild,v 1.1 2010/02/11 22:31:19 jlec Exp $
+
+EAPI=2
+
+MY_PN=${PN/mmtk/MMTK}
+MY_P=${MY_PN}-${PV}
+
+PYTHON_MODNAME=${MY_PN}
+
+inherit distutils
+
+# This number identifies each release on the CRU website.
+# Can't figure out how to avoid hardcoding it.
+NUMBER="2716"
+
+DESCRIPTION="Molecular Modeling ToolKit for Python"
+HOMEPAGE="http://dirac.cnrs-orleans.fr/MMTK/"
+SRC_URI="http://sourcesup.cru.fr/frs/download.php/${NUMBER}/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="CeCILL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/scientificpython-2.6"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -i -e "/ext_package/d" \
+ "${S}"/setup.py \
+ || die
+}
+
+src_install() {
+ distutils_src_install
+
+ dodoc README* Doc/CHANGELOG || die
+ dohtml -r Doc/{module_reference,users_guide} || die
+
+ insinto /usr/share/doc/${PF}/pdf
+ doins Doc/users_guide.pdf || die
+}