summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-01-07 11:36:19 +0000
committerJustin Lecher <jlec@gentoo.org>2011-01-07 11:36:19 +0000
commitffcb694a9437038e38c685a75cc80bdbd493280f (patch)
tree4d9db74df89f70546cd407662e606e7d61e0921f /sci-libs/mmtk
parentMinor elog message adjustment (diff)
downloadgentoo-2-ffcb694a9437038e38c685a75cc80bdbd493280f.tar.gz
gentoo-2-ffcb694a9437038e38c685a75cc80bdbd493280f.tar.bz2
gentoo-2-ffcb694a9437038e38c685a75cc80bdbd493280f.zip
Version Bump, 350909
(Portage version: 2.2.0_alpha14/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/mmtk')
-rw-r--r--sci-libs/mmtk/ChangeLog9
-rw-r--r--sci-libs/mmtk/mmtk-2.7.3.ebuild59
2 files changed, 66 insertions, 2 deletions
diff --git a/sci-libs/mmtk/ChangeLog b/sci-libs/mmtk/ChangeLog
index 19c921eca5be..43e87e20d83e 100644
--- a/sci-libs/mmtk/ChangeLog
+++ b/sci-libs/mmtk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/mmtk
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/mmtk/ChangeLog,v 1.7 2010/04/25 10:29:25 jlec Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/mmtk/ChangeLog,v 1.8 2011/01/07 11:36:19 jlec Exp $
+
+*mmtk-2.7.3 (07 Jan 2011)
+
+ 07 Jan 2011; Justin Lecher <jlec@gentoo.org> +mmtk-2.7.3.ebuild:
+ Version Bump, 350909
*mmtk-2.7.1 (25 Apr 2010)
diff --git a/sci-libs/mmtk/mmtk-2.7.3.ebuild b/sci-libs/mmtk/mmtk-2.7.3.ebuild
new file mode 100644
index 000000000000..f5d18a637c80
--- /dev/null
+++ b/sci-libs/mmtk/mmtk-2.7.3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/mmtk/mmtk-2.7.3.ebuild,v 1.1 2011/01/07 11:36:19 jlec Exp $
+
+EAPI="2"
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+# This number identifies each release on the CRU website.
+# Can't figure out how to avoid hardcoding it.
+NUMBER="3421"
+
+MY_PN=${PN/mmtk/MMTK}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Molecular Modeling ToolKit for Python"
+HOMEPAGE="http://dirac.cnrs-orleans.fr/MMTK/"
+SRC_URI="http://sourcesup.cru.fr/frs/download.php/${NUMBER}/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="CeCILL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="examples"
+
+RDEPEND="
+ >=dev-python/scientificpython-2.6
+ dev-python/cython"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${MY_P}
+
+
+src_prepare() {
+ export MMTK_USE_CYTHON="1"
+ sed -i -e "/ext_package/d" \
+ "${S}"/setup.py \
+ || die
+ distutils_src_prepare
+}
+
+src_install() {
+ distutils_src_install
+
+ dodoc README* Doc/CHANGELOG || die
+ dohtml -r Doc/HTML/* || die
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r Examples || die
+# Needs to wait for EAPI=4
+# dodoc -r Doc/Examples || die
+ fi
+}
+
+PYTHON_MODNAME="${MY_PN}"