summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-04-27 16:13:14 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2010-04-27 16:13:14 +0000
commitb91b5d8fada8639d76ceddb9c027fd0ad33c4e96 (patch)
tree8037f6d023622df3038f8570f48b774f0b530b99 /sci-libs/netcdf
parentx86 stable wrt bug #316293 (diff)
downloadgentoo-2-b91b5d8fada8639d76ceddb9c027fd0ad33c4e96.tar.gz
gentoo-2-b91b5d8fada8639d76ceddb9c027fd0ad33c4e96.tar.bz2
gentoo-2-b91b5d8fada8639d76ceddb9c027fd0ad33c4e96.zip
Version bump (includes dap client).
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/netcdf')
-rw-r--r--sci-libs/netcdf/ChangeLog8
-rw-r--r--sci-libs/netcdf/metadata.xml3
-rw-r--r--sci-libs/netcdf/netcdf-4.1.1.ebuild81
3 files changed, 91 insertions, 1 deletions
diff --git a/sci-libs/netcdf/ChangeLog b/sci-libs/netcdf/ChangeLog
index d04200e3bd2c..392343184cec 100644
--- a/sci-libs/netcdf/ChangeLog
+++ b/sci-libs/netcdf/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/netcdf
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/ChangeLog,v 1.65 2010/02/12 04:05:09 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/ChangeLog,v 1.66 2010/04/27 16:13:14 scarabeus Exp $
+
+*netcdf-4.1.1 (27 Apr 2010)
+
+ 27 Apr 2010; Tomáš Chvátal <scarabeus@gentoo.org> +netcdf-4.1.1.ebuild,
+ metadata.xml:
+ Version bump (includes dap client).
12 Feb 2010; Sébastien Fabbro <bicatali@gentoo.org>
netcdf-4.0.1-r1.ebuild:
diff --git a/sci-libs/netcdf/metadata.xml b/sci-libs/netcdf/metadata.xml
index d1109f322c2c..9ce8a74bbd41 100644
--- a/sci-libs/netcdf/metadata.xml
+++ b/sci-libs/netcdf/metadata.xml
@@ -10,4 +10,7 @@
Together, the interface, library, and format support the creation,
access, and sharing of scientific data.
</longdescription>
+<use>
+ <flag name="dap">Support for remote data access with the built-in OPeNDAP client</flag>
+</use>
</pkgmetadata>
diff --git a/sci-libs/netcdf/netcdf-4.1.1.ebuild b/sci-libs/netcdf/netcdf-4.1.1.ebuild
new file mode 100644
index 000000000000..ac9f4cd9327d
--- /dev/null
+++ b/sci-libs/netcdf/netcdf-4.1.1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/netcdf-4.1.1.ebuild,v 1.1 2010/04/27 16:13:14 scarabeus Exp $
+
+EAPI="3"
+
+inherit eutils autotools
+
+DESCRIPTION="Scientific library and interface for array oriented data access"
+SRC_URI="ftp://ftp.unidata.ucar.edu/pub/netcdf/${P}.tar.gz"
+HOMEPAGE="http://www.unidata.ucar.edu/software/netcdf/"
+
+LICENSE="UCAR-Unidata"
+SLOT="0"
+IUSE="dap doc fortran hdf5 static-libs szip cxx"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ hdf5? ( >=sci-libs/hdf5-1.8[zlib,szip?,fortran?] )
+ dap? ( net-misc/curl )
+"
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-2.2
+ doc? ( virtual/latex-base )
+ fortran? ( dev-lang/cfortran )"
+
+pkg_setup() {
+ if use hdf5 && has_version sci-libs/hdf5[mpi]; then
+ export CC=mpicc
+ if use cxx; then
+ export CXX=mpicxx
+ fi
+ if use fortran; then
+ export FC=mpif90
+ export F77=mpif77
+ fi
+ fi
+}
+
+src_prepare() {
+ # use system cfortran
+ rm -f fortran/cfortran.h || die
+}
+
+src_configure() {
+ local myconf
+ if use hdf5; then
+ myconf="--with-hdf5=${EPREFIX}/usr --with-zlib=${EPREFIX}/usr"
+ use szip && myconf="${myconf} --with-szlib=${EPREFIX}/usr"
+ fi
+
+ econf \
+ --enable-shared \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ $(use_enable dap) \
+ $(use_enable static-libs static) \
+ $(use_enable fortran f77) \
+ $(use_enable fortran f90) \
+ $(use_enable cxx) \
+ $(use_enable fortran separate-fortran) \
+ $(use_enable hdf5 netcdf-4) \
+ $(use_enable hdf5 ncgen4) \
+ $(use_enable doc docs-install) \
+ ${myconf}
+}
+
+src_compile() {
+ # hack to allow parallel build
+ if use doc; then
+ emake pdf || die "emake pdf failed"
+ cd man4
+ emake -j1 || die "emake doc failed"
+ cd ..
+ fi
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README RELEASE_NOTES VERSION || die
+}