summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-04-18 19:10:26 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-04-18 19:10:26 +0000
commitd238c1fcc8556615158db2e83ed5e81450906611 (patch)
tree473815337decdcb25bd354bd472cbc5594f75b60 /sci-libs/netcdf
parentx86 stable, bug #409403 (diff)
downloadgentoo-2-d238c1fcc8556615158db2e83ed5e81450906611.tar.gz
gentoo-2-d238c1fcc8556615158db2e83ed5e81450906611.tar.bz2
gentoo-2-d238c1fcc8556615158db2e83ed5e81450906611.zip
Version bump. C++ and FORTRAN libraries are now in packages netcdf-cxx and netcdf-fortran, following upstream. All patches applied upstream
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/netcdf')
-rw-r--r--sci-libs/netcdf/ChangeLog9
-rw-r--r--sci-libs/netcdf/metadata.xml12
-rw-r--r--sci-libs/netcdf/netcdf-4.2.ebuild44
3 files changed, 59 insertions, 6 deletions
diff --git a/sci-libs/netcdf/ChangeLog b/sci-libs/netcdf/ChangeLog
index 582b3d1da28b..126b5febd152 100644
--- a/sci-libs/netcdf/ChangeLog
+++ b/sci-libs/netcdf/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-libs/netcdf
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/ChangeLog,v 1.95 2012/03/29 19:01:45 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/ChangeLog,v 1.96 2012/04/18 19:10:26 bicatali Exp $
+
+*netcdf-4.2 (18 Apr 2012)
+
+ 18 Apr 2012; Sébastien Fabbro <bicatali@gentoo.org> +netcdf-4.2.ebuild,
+ metadata.xml:
+ Version bump. C++ and FORTRAN libraries are now in packages netcdf-cxx and
+ netcdf-fortran, following upstream. All patches applied upstream
29 Mar 2012; Sébastien Fabbro <bicatali@gentoo.org> netcdf-4.1.3.ebuild:
Fixed minimum libtool dependency (bug #409219, thanks dima), fixes a sed for
diff --git a/sci-libs/netcdf/metadata.xml b/sci-libs/netcdf/metadata.xml
index 19e0ef6858c6..d11d9efa513a 100644
--- a/sci-libs/netcdf/metadata.xml
+++ b/sci-libs/netcdf/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci</herd>
- <longdescription lang="en">
+ <herd>sci</herd>
+<longdescription lang="en">
NetCDF (network Common Data Form) is an interface for scientific
data access and a freely-distributed software library that provides an
implementation of the interface. The netCDF library also defines a
@@ -10,7 +10,9 @@
Together, the interface, library, and format support the creation,
access, and sharing of scientific data.
</longdescription>
- <use>
- <flag name="dap">Support for remote data access with the built-in OPeNDAP client</flag>
- </use>
+<use>
+ <flag name="dap">Support for remote data access with the built-in OPeNDAP client</flag>
+ <flag name="hdf">dd support for the Hierarchical Data Format v. 4<pkg>sci-libs/hdf</pkg></flag>
+ <flag name="tools">Build the utilities nccopy, ncgen and ncdump</flag>
+</use>
</pkgmetadata>
diff --git a/sci-libs/netcdf/netcdf-4.2.ebuild b/sci-libs/netcdf/netcdf-4.2.ebuild
new file mode 100644
index 000000000000..cc9dc53d6c61
--- /dev/null
+++ b/sci-libs/netcdf/netcdf-4.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/netcdf-4.2.ebuild,v 1.1 2012/04/18 19:10:26 bicatali Exp $
+
+EAPI=4
+
+inherit autotools-utils
+
+DESCRIPTION="Scientific library and interface for array oriented data access"
+HOMEPAGE="http://www.unidata.ucar.edu/software/netcdf/"
+SRC_URI="ftp://ftp.unidata.ucar.edu/pub/netcdf/${P}.tar.gz"
+
+LICENSE="UCAR-Unidata"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="+dap doc hdf +hdf5 mpi static-libs szip tools"
+
+RDEPEND="dap? ( net-misc/curl )
+ hdf? ( sci-libs/hdf >=sci-libs/hdf5-1.8.8 )
+ hdf5? ( >=sci-libs/hdf5-1.8.8[mpi=,szip=,zlib] )"
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_configure() {
+ myeconfargs=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ --disable-examples
+ $(use_enable dap)
+ $(use_enable doc doxygen)
+ $(use_enable hdf hdf4)
+ $(use_enable hdf5 netcdf4)
+ $(use_enable tools utilities)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}