summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-16 15:31:32 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-16 15:31:32 +0000
commit050bba8712513830bba6d26dedaad04c8e80a081 (patch)
tree27d9fa13b9c600b182a6f1d01e70665b94077b5c /sci-libs/scipy/files
parentAdd ~ia64 wrt #348984 (diff)
downloadgentoo-2-050bba8712513830bba6d26dedaad04c8e80a081.tar.gz
gentoo-2-050bba8712513830bba6d26dedaad04c8e80a081.tar.bz2
gentoo-2-050bba8712513830bba6d26dedaad04c8e80a081.zip
Delete older ebuild.
(Portage version: 2.2.0_alpha15_p10/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/scipy/files')
-rw-r--r--sci-libs/scipy/files/scipy-0.7.0_beta1-implicit.patch28
-rw-r--r--sci-libs/scipy/files/scipy-0.7.1-weave.patch12
-rw-r--r--sci-libs/scipy/files/scipy-0.7.2-optimize.patch54
-rw-r--r--sci-libs/scipy/files/scipy-0.7.2-python2.7.patch26
4 files changed, 0 insertions, 120 deletions
diff --git a/sci-libs/scipy/files/scipy-0.7.0_beta1-implicit.patch b/sci-libs/scipy/files/scipy-0.7.0_beta1-implicit.patch
deleted file mode 100644
index dee015244db3..000000000000
--- a/sci-libs/scipy/files/scipy-0.7.0_beta1-implicit.patch
+++ /dev/null
@@ -1,28 +0,0 @@
---- scipy/sparse/linalg/dsolve/SuperLU/SRC/dcomplex.c 2007-09-22 03:55:18.000000000 -0400
-+++ scipy/sparse/linalg/dsolve/SuperLU/SRC/dcomplex.c 2008-07-03 08:04:15.000000000 -0400
-@@ -11,6 +11,7 @@
- */
- #include <math.h>
- #include <stdio.h>
-+#include <stdlib.h>
- #include "dcomplex.h"
-
-
---- scipy/sparse/linalg/dsolve/SuperLU/SRC/scomplex.c 2007-09-22 03:55:18.000000000 -0400
-+++ scipy/sparse/linalg/dsolve/SuperLU/SRC/scomplex.c 2008-07-03 08:04:34.000000000 -0400
-@@ -11,6 +11,7 @@
- */
- #include <math.h>
- #include <stdio.h>
-+#include <stdlib.h>
- #include "scomplex.h"
-
-
---- scipy/sparse/linalg/dsolve/SuperLU/SRC/xerbla.c 2007-09-22 03:55:18.000000000 -0400
-+++ scipy/sparse/linalg/dsolve/SuperLU/SRC/xerbla.c 2008-07-03 08:05:27.000000000 -0400
-@@ -1,3 +1,5 @@
-+#include <stdio.h>
-+
- /* Subroutine */ int xerbla_(char *srname, int *info)
- {
- /* -- LAPACK auxiliary routine (version 2.0) --
diff --git a/sci-libs/scipy/files/scipy-0.7.1-weave.patch b/sci-libs/scipy/files/scipy-0.7.1-weave.patch
deleted file mode 100644
index 56d29f2addac..000000000000
--- a/sci-libs/scipy/files/scipy-0.7.1-weave.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-Index: /trunk/scipy/io/dumbdbm_patched.py
-===================================================================
---- /trunk/scipy/io/dumbdbm_patched.py (revision 3521)
-+++ /trunk/scipy/io/dumbdbm_patched.py (revision 5967)
-@@ -78,4 +78,7 @@
- return dat
-
-+ def __contains__(self, key):
-+ return key in self._index
-+
- def _addval(self, val):
- f = _open(self._datfile, 'rb+')
diff --git a/sci-libs/scipy/files/scipy-0.7.2-optimize.patch b/sci-libs/scipy/files/scipy-0.7.2-optimize.patch
deleted file mode 100644
index 4a3bb74012bd..000000000000
--- a/sci-libs/scipy/files/scipy-0.7.2-optimize.patch
+++ /dev/null
@@ -1,54 +0,0 @@
---- scipy/optimize/optimize.py.orig 2009-07-11 17:56:37.000000000 +1200
-+++ scipy/optimize/optimize.py 2010-05-17 21:36:07.605336495 +1200
-@@ -41,6 +41,12 @@
- m = asarray(m)
- return numpy.minimum.reduce(m,axis)
-
-+def is_array_scalar(x):
-+ """Test whether `x` is either a scalar or an array scalar.
-+
-+ """
-+ return len(atleast_1d(x) == 1)
-+
- abs = absolute
- import __builtin__
- pymin = __builtin__.min
-@@ -1177,13 +1183,12 @@
-
- """
- # Test bounds are of correct form
-- x1 = atleast_1d(x1)
-- x2 = atleast_1d(x2)
-- if len(x1) != 1 or len(x2) != 1:
-- raise ValueError, "Optimisation bounds must be scalars" \
-- " or length 1 arrays"
-+
-+ if not (is_array_scalar(x1) and is_array_scalar(x2)):
-+ raise ValueError("Optimisation bounds must be scalars"
-+ " or array scalars.")
- if x1 > x2:
-- raise ValueError, "The lower bound exceeds the upper bound."
-+ raise ValueError("The lower bound exceeds the upper bound.")
-
- flag = 0
- header = ' Func-count x f(x) Procedure'
---- scipy/optimize/tests/test_optimize.py.orig 2009-07-11 17:56:37.000000000 +1200
-+++ scipy/optimize/tests/test_optimize.py 2010-05-18 21:31:39.000000000 +1200
-@@ -159,10 +160,17 @@
- assert abs(x - 1.5) < 1e-6
- assert_raises(ValueError,
- optimize.fminbound, lambda x: (x - 1.5)**2 - 0.8, 5, 1)
-+
-+ def test_fminbound_scalar(self):
- assert_raises(ValueError,
-- optimize.fminbound, lambda x: (x - 1.5)**2 - 0.8,
-+ optimize.fminbound, lambda x: (x - 1.5)**2 - 0.8,
- np.zeros(2), 1)
-
-+ assert_almost_equal(
-+ optimize.fminbound(lambda x: (x - 1.5)**2 - 0.8, 1, np.array(5)),
-+ 1.5)
-+
-+
- class TestTnc(TestCase):
- """TNC non-linear optimization.
diff --git a/sci-libs/scipy/files/scipy-0.7.2-python2.7.patch b/sci-libs/scipy/files/scipy-0.7.2-python2.7.patch
deleted file mode 100644
index 13dbd4caaef3..000000000000
--- a/sci-libs/scipy/files/scipy-0.7.2-python2.7.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-http://projects.scipy.org/scipy/changeset/6645
-
---- scipy/sparse/sparsetools/setup.py
-+++ scipy/sparse/sparsetools/setup.py
-@@ -8,7 +8,10 @@
-
- for fmt in ['csr','csc','coo','bsr','dia']:
- sources = [ fmt + '_wrap.cxx' ]
-- config.add_extension('_' + fmt, sources=sources)
-+ depends = [ fmt + '.h' ]
-+ config.add_extension('_' + fmt, sources=sources,
-+ define_macros=[('__STDC_FORMAT_MACROS', 1)],
-+ depends=depends)
-
- return config
-
---- scipy/sparse/sparsetools/SConscript
-+++ scipy/sparse/sparsetools/SConscript
-@@ -3,6 +3,7 @@
- from numscons import GetNumpyEnvironment
-
- env = GetNumpyEnvironment(ARGUMENTS)
-+env.PrependUnique(CPPDEFINES = '__STDC_FORMAT_MACROS')
-
- for fmt in ['csr','csc','coo','bsr','dia']:
- sources = [ fmt + '_wrap.cxx' ]