summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2007-09-11 17:38:51 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2007-09-11 17:38:51 +0000
commitcc0d540d34ad94bd57d74a51d9be4faeba22125c (patch)
tree57d7a4cb17eb844dd892fdc4e53cc64bd2174033 /sci-libs/scipy
parentVersion bump. (diff)
downloadgentoo-2-cc0d540d34ad94bd57d74a51d9be4faeba22125c.tar.gz
gentoo-2-cc0d540d34ad94bd57d74a51d9be4faeba22125c.tar.bz2
gentoo-2-cc0d540d34ad94bd57d74a51d9be4faeba22125c.zip
removed old versions (commited this time)
(Portage version: 2.1.2.12)
Diffstat (limited to 'sci-libs/scipy')
-rw-r--r--sci-libs/scipy/files/digest-scipy-0.5.2-r13
-rw-r--r--sci-libs/scipy/files/digest-scipy-0.5.2-r23
-rw-r--r--sci-libs/scipy/scipy-0.5.2-r1.ebuild119
-rw-r--r--sci-libs/scipy/scipy-0.5.2-r2.ebuild148
4 files changed, 0 insertions, 273 deletions
diff --git a/sci-libs/scipy/files/digest-scipy-0.5.2-r1 b/sci-libs/scipy/files/digest-scipy-0.5.2-r1
deleted file mode 100644
index 89b1226c8e1b..000000000000
--- a/sci-libs/scipy/files/digest-scipy-0.5.2-r1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 e24387ac7f9e589816364db7c64c3185 scipy-0.5.2.tar.gz 6362164
-RMD160 fa945185df7fc48e03bafdddeaaea72a8eb4914d scipy-0.5.2.tar.gz 6362164
-SHA256 38e42155d3445699f28c36facdaa82200d8e017b4ca608f95f6d928065dc03ed scipy-0.5.2.tar.gz 6362164
diff --git a/sci-libs/scipy/files/digest-scipy-0.5.2-r2 b/sci-libs/scipy/files/digest-scipy-0.5.2-r2
deleted file mode 100644
index 89b1226c8e1b..000000000000
--- a/sci-libs/scipy/files/digest-scipy-0.5.2-r2
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 e24387ac7f9e589816364db7c64c3185 scipy-0.5.2.tar.gz 6362164
-RMD160 fa945185df7fc48e03bafdddeaaea72a8eb4914d scipy-0.5.2.tar.gz 6362164
-SHA256 38e42155d3445699f28c36facdaa82200d8e017b4ca608f95f6d928065dc03ed scipy-0.5.2.tar.gz 6362164
diff --git a/sci-libs/scipy/scipy-0.5.2-r1.ebuild b/sci-libs/scipy/scipy-0.5.2-r1.ebuild
deleted file mode 100644
index 783f80032c26..000000000000
--- a/sci-libs/scipy/scipy-0.5.2-r1.ebuild
+++ /dev/null
@@ -1,119 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/scipy-0.5.2-r1.ebuild,v 1.1 2007/02/19 11:09:36 bicatali Exp $
-
-NEED_PYTHON=2.3
-
-inherit distutils fortran
-
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-DESCRIPTION="Scientific algorithms library for Python"
-HOMEPAGE="http://www.scipy.org/"
-LICENSE="BSD"
-
-SLOT="0"
-
-IUSE="fftw umfpack"
-
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND=">=dev-python/numpy-1.0
- virtual/blas
- virtual/lapack
- fftw? ( sci-libs/fftw )
- umfpack? ( sci-libs/umfpack )"
-
-DEPEND="${RDEPEND}
- umfpack? ( dev-lang/swig )"
-
-RESTRICT="test"
-
-FORTRAN="gfortran g77"
-
-DOCS="THANKS.txt DEVELOPERS.txt LATEST.txt TOCHANGE.txt FORMAT_GUIDELINES.txt"
-
-scipy_configure() {
- [[ -z "${FFLAGS}" ]] && FFLAGS="${CFLAGS}"
- # scipy automatically detects libraries by default
- export FFTW=None FFTW3=None UMFPACK=None DJBFFT=None
- use fftw && unset FFTW FFTW3
- use umfpack && unset UMFPACK
- # Map compilers to what numpy calls them (same as scipy)
- case "${FORTRANC}" in
- gfortran)
- SCIPY_FC="gnu95"
- ;;
- g77)
- SCIPY_FC="gnu"
- ;;
- g95)
- SCIPY_FC="g95"
- ;;
- ifc|ifort)
- if use ia64; then
- SCIPY_FC="intele"
- elif use amd64; then
- SCIPY_FC="intelem"
- else
- SCIPY_FC="intel"
- fi
- ;;
- *)
- local msg="Invalid Fortran compiler \'${FORTRANC}\'"
- eerror "${msg}"
- die "${msg}"
- ;;
- esac
- export SCIPY_FC
-
- # http://projects.scipy.org/scipy/numpy/ticket/182
- # Can't set LDFLAGS
- unset LDFLAGS
- # need to build with -fPIC (bug #149153)
- export F77FLAGS="${F77FLAGS} -fPIC"
-}
-
-pkg_setup() {
- if use umfpack; then
- if ! built_with_use dev-lang/swig python; then
- eerror "With umfpack enabled you need"
- eerror "dev-lang/swig with python enabled"
- einfo "Please re-emerge swig with USE=python"
- die "needs swig with python"
- fi
- fi
- fortran_pkg_setup
-}
-
-src_compile() {
- scipy_configure
- distutils_src_compile \
- config_fc \
- --fcompiler="${SCIPY_FC}" \
- --opt="${FFLAGS}"
-}
-
-src_test() {
- scipy_configure
- ${python} setup.py install \
- --home="${S}"/test \
- --no-compile \
- config_fc \
- --fcompiler=${SCIPY_FC} \
- --opt="${FFLAGS}" || die "install test failed"
- pushd "${S}"/test/lib*/python
- PYTHONPATH=. "${python}" -c \
- "import scipy as s;import sys;sys.exit(s.test(10,3))" \
- > test.log 2>&1
- grep -q OK test.log || die "test failed"
- popd
- rm -rf test
-}
-
-src_install() {
- scipy_configure
- distutils_src_install \
- config_fc \
- --fcompiler="${SCIPY_FC}" \
- --opt="${FFLAGS}"
-}
diff --git a/sci-libs/scipy/scipy-0.5.2-r2.ebuild b/sci-libs/scipy/scipy-0.5.2-r2.ebuild
deleted file mode 100644
index ef2e2c15ed31..000000000000
--- a/sci-libs/scipy/scipy-0.5.2-r2.ebuild
+++ /dev/null
@@ -1,148 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/scipy-0.5.2-r2.ebuild,v 1.1 2007/06/06 21:27:52 bicatali Exp $
-
-NEED_PYTHON=2.3
-
-inherit eutils distutils fortran
-
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-DESCRIPTION="Scientific algorithms library for Python"
-HOMEPAGE="http://www.scipy.org/"
-LICENSE="BSD"
-
-SLOT="0"
-
-IUSE="fftw umfpack sandbox"
-
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND=">=dev-python/numpy-1.0
- virtual/blas
- virtual/lapack
- fftw? ( =sci-libs/fftw-2.1* )
- umfpack? ( sci-libs/umfpack )
- sandbox? ( >=sci-libs/netcdf-3.6 x11-libs/libX11 )"
-
-DEPEND="${RDEPEND}
- umfpack? ( dev-lang/swig )"
-
-FORTRAN="gfortran g77"
-
-# test still buggy on lapack, remove when OK (check each new version)
-RESTRICT="test"
-
-DOCS="THANKS.txt DEVELOPERS.txt LATEST.txt TOCHANGE.txt FORMAT_GUIDELINES.txt"
-
-scipy_configure() {
- [[ -z "${FFLAGS}" ]] && FFLAGS="${CFLAGS}"
- # scipy automatically detects libraries by default
- export FFTW=None FFTW3=None UMFPACK=None DJBFFT=None
- use fftw && unset FFTW
- use umfpack && unset UMFPACK
- # Map compilers to what numpy calls them (same as scipy)
- case "${FORTRANC}" in
- gfortran)
- SCIPY_FC="gnu95"
- ;;
- g77)
- SCIPY_FC="gnu"
- ;;
- ifc|ifort)
- if use ia64; then
- SCIPY_FC="intele"
- elif use amd64; then
- SCIPY_FC="intelem"
- else
- SCIPY_FC="intel"
- fi
- ;;
- *)
- local msg="Invalid Fortran compiler \'${FORTRANC}\'"
- eerror "${msg}"
- die "${msg}"
- ;;
- esac
- export SCIPY_FC
-
- # http://projects.scipy.org/scipy/numpy/ticket/182
- # Can't set LDFLAGS
- unset LDFLAGS
- # need to build with -fPIC (bug #149153)
- export F77FLAGS="${F77FLAGS} -fPIC"
-}
-
-pkg_setup() {
- if use umfpack && ! built_with_use dev-lang/swig python; then
- eerror "With umfpack enabled you need"
- eerror "dev-lang/swig with python enabled"
- einfo "Please re-emerge swig with USE=python"
- die "needs swig with python"
- fi
- fortran_pkg_setup
- use sandbox && elog "Warning: using sandbox modules at your own risk!"
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- # most of these patches should be useless in versions >=0.5.3)
- # various patches from scipy svn and to allow sandbox modules
- epatch "${FILESDIR}"/${P}-signals.patch
- epatch "${FILESDIR}"/${P}-viewer.patch
- epatch "${FILESDIR}"/${P}-randomkit.patch
- epatch "${FILESDIR}"/${P}-umfpack.patch
- epatch "${FILESDIR}"/${P}-montecarlo-test.patch
- epatch "${FILESDIR}"/${P}-mio.patch
- epatch "${FILESDIR}"/${P}-minpack.patch
- epatch "${FILESDIR}"/${P}-bspline.patch
- has_version ">=dev-python/numpy-1.0.3" && epatch "${FILESDIR}"/${P}-getpath.patch
- # following patch still not fixed in svn
- epatch "${FILESDIR}"/${P}-nonexisting.patch
- # fix test (use a sed instead of big patch)
- einfo "Fixing tests"
- find Lib -name \*.py -exec grep -l ScipyTest '{}' \; | \
- xargs sed -i -e 's/ScipyTest/NumpyTest/g' \
- || die "sed failed"
- use sandbox && cp "${FILESDIR}"/enabled_packages.txt Lib/sandbox/
- #use sandbox && cp "${FILESDIR}"/_bspline.cpp .
-}
-
-src_compile() {
- scipy_configure
- distutils_src_compile \
- config_fc \
- --fcompiler="${SCIPY_FC}" \
- --opt="${FFLAGS}"
-}
-
-src_test() {
- scipy_configure
- ${python} setup.py install \
- --home="${S}"/test \
- --no-compile \
- config_fc \
- --fcompiler=${SCIPY_FC} \
- --opt="${FFLAGS}" || die "install test failed"
- pushd "${S}"/test/lib*/python
- PYTHONPATH=. "${python}" -c \
- "import scipy as s;import sys;sys.exit(s.test(10,3))" \
- > test.log 2>&1
- grep -q OK test.log || die "test failed"
- popd
- rm -rf test
-}
-
-src_install() {
- scipy_configure
- distutils_src_install \
- config_fc \
- --fcompiler="${SCIPY_FC}" \
- --opt="${FFLAGS}"
-}
-
-pkg_postinst() {
- elog "You might want to set the variable SCIPY_PIL_IMAGE_VIEWER"
- elog "to your prefered image viewer if you don't like the default one. Ex:"
- elog "\t echo \"export SCIPY_PIL_IMAGE_VIEWER=display\" >> ~/.bashrc"
-}