summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2009-10-18 07:05:49 +0000
committerSteve Arnold <nerdboy@gentoo.org>2009-10-18 07:05:49 +0000
commit371917ae1df36c005c64e096276cb87ae743f3f0 (patch)
tree12a69c262a2e03750c82bcca1fedbdd1c1882c57 /sci-libs/shapelib
parentVersion bump. Drop old. (diff)
downloadgentoo-2-371917ae1df36c005c64e096276cb87ae743f3f0.tar.gz
gentoo-2-371917ae1df36c005c64e096276cb87ae743f3f0.tar.bz2
gentoo-2-371917ae1df36c005c64e096276cb87ae743f3f0.zip
QA fix: updated to respect LDFLAGS per bug 289158.
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/shapelib')
-rw-r--r--sci-libs/shapelib/ChangeLog6
-rw-r--r--sci-libs/shapelib/files/makefile-fix.patch9
-rw-r--r--sci-libs/shapelib/shapelib-1.2.10-r1.ebuild12
3 files changed, 21 insertions, 6 deletions
diff --git a/sci-libs/shapelib/ChangeLog b/sci-libs/shapelib/ChangeLog
index 73d5769b20cf..d63f28124bf2 100644
--- a/sci-libs/shapelib/ChangeLog
+++ b/sci-libs/shapelib/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/shapelib
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/shapelib/ChangeLog,v 1.10 2009/09/16 04:58:05 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/shapelib/ChangeLog,v 1.11 2009/10/18 07:05:49 nerdboy Exp $
+
+ 18 Oct 2009; Steve Arnold <nerdboy@gentoo.org> shapelib-1.2.10-r1.ebuild,
+ +files/makefile-fix.patch:
+ More QA fixes: updated to respect LDFLAGS per bug 289158.
16 Sep 2009; Steve Arnold <nerdboy@gentoo.org> shapelib-1.2.10-r1.ebuild,
+files/fix-shapelib-test.diff, +files/stdlib_include_fix.patch:
diff --git a/sci-libs/shapelib/files/makefile-fix.patch b/sci-libs/shapelib/files/makefile-fix.patch
new file mode 100644
index 000000000000..f30bbfc2d215
--- /dev/null
+++ b/sci-libs/shapelib/files/makefile-fix.patch
@@ -0,0 +1,9 @@
+--- Makefile.orig 2009-10-17 23:37:30.307257014 -0700
++++ Makefile 2009-10-17 23:38:25.914190883 -0700
+@@ -1,6 +1,7 @@
+
+ #LINKOPT = /usr/local/lib/libdbmalloc.a
++LINKOPT = $(LDFLAGS)
+ CFLAGS = -g
+
+ default: all
diff --git a/sci-libs/shapelib/shapelib-1.2.10-r1.ebuild b/sci-libs/shapelib/shapelib-1.2.10-r1.ebuild
index 3eddad9839d2..4da6c07756c2 100644
--- a/sci-libs/shapelib/shapelib-1.2.10-r1.ebuild
+++ b/sci-libs/shapelib/shapelib-1.2.10-r1.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/shapelib/shapelib-1.2.10-r1.ebuild,v 1.3 2009/09/16 04:58:05 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/shapelib/shapelib-1.2.10-r1.ebuild,v 1.4 2009/10/18 07:05:49 nerdboy Exp $
+EAPI="2"
inherit eutils toolchain-funcs
DESCRIPTION="library for manipulating ESRI Shapefiles"
@@ -15,16 +16,17 @@ IUSE=""
DEPEND=""
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
+ epatch "${FILESDIR}"/makefile-fix.patch
epatch "${FILESDIR}"/fix-shapelib-test.diff
epatch "${FILESDIR}"/stdlib_include_fix.patch
sed -i \
-e 's:/usr/local/:${DESTDIR}/usr/:g' \
-e "s:/usr/lib:/usr/$(get_libdir):g" \
-e 's:SHPLIB_VERSION=1.2.9:SHPLIB_VERSION=1.2.10:g' \
- -e "s:-g:${CFLAGS}:g" \
+ -e "s:-g:${CFLAGS}:" \
+ -e "s:-g -O2:${CFLAGS}:g" \
+ -e "s:link gcc :link gcc ${LDFLAGS}:" \
Makefile || die "sed failed"
}