summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-01-20 05:53:51 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-01-20 05:53:51 +0000
commit4db52ec00694379c633a6c5cdf631121118ab9b5 (patch)
tree80a67acf29e5aafae0025ec6a6f599ab9fda2cda /sci-libs/spqr/spqr-1.2.3.ebuild
parentVersion bump (diff)
downloadgentoo-2-4db52ec00694379c633a6c5cdf631121118ab9b5.tar.gz
gentoo-2-4db52ec00694379c633a6c5cdf631121118ab9b5.tar.bz2
gentoo-2-4db52ec00694379c633a6c5cdf631121118ab9b5.zip
Version bump
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/spqr/spqr-1.2.3.ebuild')
-rw-r--r--sci-libs/spqr/spqr-1.2.3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sci-libs/spqr/spqr-1.2.3.ebuild b/sci-libs/spqr/spqr-1.2.3.ebuild
new file mode 100644
index 000000000000..8672398e08fd
--- /dev/null
+++ b/sci-libs/spqr/spqr-1.2.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/spqr/spqr-1.2.3.ebuild,v 1.1 2012/01/20 05:53:50 bicatali Exp $
+
+EAPI=4
+AUTOTOOLS_AUTORECONF=yes
+inherit autotools-utils
+
+MY_PN=SPQR
+DESCRIPTION="Multithreaded multifrontal sparse QR factorization library"
+HOMEPAGE="http://www.cise.ufl.edu/research/sparse/SPQR"
+SRC_URI="http://www.cise.ufl.edu/research/sparse/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc metis static-libs tbb"
+RDEPEND="sci-libs/cholmod[supernodal]
+ tbb? ( dev-cpp/tbb )
+ metis? ( >=sci-libs/cholmod-1.7.0-r1[metis] )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+DOCS=( README.txt Doc/ChangeLog )
+PATCHES=( "${FILESDIR}"/${P}-autotools.patch )
+
+S="${WORKDIR}/${MY_PN}"
+
+src_configure() {
+ myeconfargs+=(
+ $(use_with metis)
+ $(use_with tbb)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ use doc && doins Doc/*.pdf
+}