summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2015-05-21 15:46:31 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2015-05-21 15:46:31 +0000
commit09b31e107d9056742252238a4252111431afcf94 (patch)
tree29f39f44107461d0b0798c5d65862b206acdbae1 /sci-libs
parentRemove old. (diff)
downloadgentoo-2-09b31e107d9056742252238a4252111431afcf94.tar.gz
gentoo-2-09b31e107d9056742252238a4252111431afcf94.tar.bz2
gentoo-2-09b31e107d9056742252238a4252111431afcf94.zip
Version bump
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 94BFDF4484AD142F)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/armadillo/ChangeLog8
-rw-r--r--sci-libs/armadillo/armadillo-5.100.2.ebuild119
-rw-r--r--sci-libs/armadillo/metadata.xml4
3 files changed, 130 insertions, 1 deletions
diff --git a/sci-libs/armadillo/ChangeLog b/sci-libs/armadillo/ChangeLog
index 9fd5916d9f8c..4bb075a87b91 100644
--- a/sci-libs/armadillo/ChangeLog
+++ b/sci-libs/armadillo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/armadillo
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/armadillo/ChangeLog,v 1.33 2015/05/04 13:57:42 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/armadillo/ChangeLog,v 1.34 2015/05/21 15:46:31 dilfridge Exp $
+
+*armadillo-5.100.2 (21 May 2015)
+
+ 21 May 2015; Andreas K. Hüttel <dilfridge@gentoo.org>
+ +armadillo-5.100.2.ebuild, metadata.xml:
+ Version bump
04 May 2015; Justin Lecher <jlec@gentoo.org> armadillo-4.600.4.ebuild,
armadillo-4.650.2.ebuild, armadillo-4.650.4.ebuild, metadata.xml:
diff --git a/sci-libs/armadillo/armadillo-5.100.2.ebuild b/sci-libs/armadillo/armadillo-5.100.2.ebuild
new file mode 100644
index 000000000000..8c70c8332e4b
--- /dev/null
+++ b/sci-libs/armadillo/armadillo-5.100.2.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/armadillo/armadillo-5.100.2.ebuild,v 1.1 2015/05/21 15:46:31 dilfridge Exp $
+
+EAPI=5
+
+CMAKE_IN_SOURCE_BUILD=1
+
+inherit cmake-utils toolchain-funcs multilib eutils
+
+DESCRIPTION="Streamlined C++ linear algebra library"
+HOMEPAGE="http://arma.sourceforge.net/"
+SRC_URI="mirror://sourceforge/arma/${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0/5"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="arpack blas debug doc examples hdf5 lapack mkl superlu tbb test"
+REQUIRED_USE="test? ( lapack )"
+
+RDEPEND="
+ dev-libs/boost
+ arpack? ( sci-libs/arpack )
+ blas? ( virtual/blas )
+ lapack? ( virtual/lapack )
+ superlu? ( sci-libs/superlu )
+"
+DEPEND="${RDEPEND}
+ arpack? ( virtual/pkgconfig )
+ blas? ( virtual/pkgconfig )
+ hdf5? ( sci-libs/hdf5 )
+ lapack? ( virtual/pkgconfig )
+ mkl? ( sci-libs/mkl )
+ tbb? ( dev-cpp/tbb )"
+PDEPEND="${RDEPEND}
+ hdf5? ( sci-libs/hdf5 )
+ mkl? ( sci-libs/mkl )
+ tbb? ( dev-cpp/tbb )"
+
+src_prepare() {
+ # avoid the automagic cmake macros
+ sed -i -e '/ARMA_Find/d' CMakeLists.txt || die
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DINSTALL_LIB_DIR="${EPREFIX}/usr/$(get_libdir)"
+ $(cmake-utils_use debug ARMA_EXTRA_DEBUG)
+ $(cmake-utils_use mkl ARMA_USE_MKL_ALLOC)
+ $(cmake-utils_use tbb ARMA_USE_TBB_ALLOC)
+ )
+ if use arpack; then
+ mycmakeargs+=(
+ -DARPACK_FOUND=ON
+ -DARPACK_LIBRARY="$($(tc-getPKG_CONFIG) --libs arpack)"
+ )
+ fi
+# if use atlas; then
+# local c=atlas-cblas l=atlas-clapack
+# $(tc-getPKG_CONFIG) --exists ${c}-threads && c+=-threads
+# $(tc-getPKG_CONFIG) --exists ${l}-threads && l+=-threads
+# mycmakeargs+=(
+# -DCBLAS_FOUND=ON
+# -DCBLAS_INCLUDE_DIR="$($(tc-getPKG_CONFIG) --cflags-only-I ${c} | sed 's/-I//')"
+# -DCBLAS_LIBRARIES="$($(tc-getPKG_CONFIG) --libs ${c})"
+# -DCLAPACK_FOUND=ON
+# -DCLAPACK_INCLUDE_DIR="$($(tc-getPKG_CONFIG) --cflags-only-I ${l} | sed 's/-I//')"
+# -DCLAPACK_LIBRARIES="$($(tc-getPKG_CONFIG) --libs ${l})"
+# )
+# fi
+ if use blas; then
+ mycmakeargs+=(
+ -DBLAS_FOUND=ON
+ -DBLAS_LIBRARIES="$($(tc-getPKG_CONFIG) --libs blas)"
+ )
+ fi
+ if use hdf5; then
+ mycmakeargs+=(
+ -DHDF5_FOUND=ON
+ -DHDF5_LIBRARIES="-lhdf5"
+ )
+ fi
+ if use lapack; then
+ mycmakeargs+=(
+ -DLAPACK_FOUND=ON
+ -DLAPACK_LIBRARIES="$($(tc-getPKG_CONFIG) --libs lapack)"
+ )
+ fi
+ if use superlu; then
+ mycmakeargs+=(
+ -DSuperLU_FOUND=ON
+ -DSuperLU_LIBRARIES="$($(tc-getPKG_CONFIG) --libs superlu)"
+ )
+ fi
+
+ cmake-utils_src_configure
+}
+
+src_test() {
+ pushd examples > /dev/null
+ emake \
+ CXXFLAGS="-I../include ${CXXFLAGS} -DARMA_USE_BLAS -DARMA_USE_LAPACK" \
+ EXTRA_LIB_FLAGS="-L.. $($(tc-getPKG_CONFIG) --libs blas lapack)"
+ LD_LIBRARY_PATH="..:${LD_LIBRARY_PATH}" ./example1 || die
+ LD_LIBRARY_PATH="..:${LD_LIBRARY_PATH}" ./example2 || die
+ emake clean
+ popd > /dev/null
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc README.txt
+ use doc && dodoc *pdf && dohtml *html
+ if use examples; then
+ insinto /usr/share/examples/${PF}
+ doins -r examples/*
+ fi
+}
diff --git a/sci-libs/armadillo/metadata.xml b/sci-libs/armadillo/metadata.xml
index 11d3a310d02b..f75da17f2040 100644
--- a/sci-libs/armadillo/metadata.xml
+++ b/sci-libs/armadillo/metadata.xml
@@ -28,5 +28,9 @@
Use matrix allocation from the Threads Building Blocks
<pkg>dev-cpp/tbb</pkg>
</flag>
+ <flag name="superlu">
+ Use SuperLU for sparse linear equation solving
+ <pkg>sci-libs/superlu</pkg>
+ </flag>
</use>
</pkgmetadata>