summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-09-27 06:35:45 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-09-27 06:35:45 +0000
commit2fabde94ff4a4f912506e70d1a71c2f27db72660 (patch)
treecf76d17f9495b36996a7305527a85496f0e4c118 /sci-libs
parentFixed autotools patch: added missing files to the library, updated ax_blas ma... (diff)
downloadgentoo-2-2fabde94ff4a4f912506e70d1a71c2f27db72660.tar.gz
gentoo-2-2fabde94ff4a4f912506e70d1a71c2f27db72660.tar.bz2
gentoo-2-2fabde94ff4a4f912506e70d1a71c2f27db72660.zip
VErsion bump
(Portage version: 2.2_rc86/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/nlopt/ChangeLog7
-rw-r--r--sci-libs/nlopt/nlopt-2.2.1.ebuild90
2 files changed, 96 insertions, 1 deletions
diff --git a/sci-libs/nlopt/ChangeLog b/sci-libs/nlopt/ChangeLog
index 9ca6f11c471e..e5407d6bfe98 100644
--- a/sci-libs/nlopt/ChangeLog
+++ b/sci-libs/nlopt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/nlopt
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/nlopt/ChangeLog,v 1.5 2010/08/10 22:04:02 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/nlopt/ChangeLog,v 1.6 2010/09/27 06:35:45 bicatali Exp $
+
+*nlopt-2.2.1 (27 Sep 2010)
+
+ 27 Sep 2010; Sébastien Fabbro <bicatali@gentoo.org> +nlopt-2.2.1.ebuild:
+ Version bump
10 Aug 2010; Sébastien Fabbro <bicatali@gentoo.org> nlopt-2.2.ebuild:
Fixed for guile and multiple python, bug #331347
diff --git a/sci-libs/nlopt/nlopt-2.2.1.ebuild b/sci-libs/nlopt/nlopt-2.2.1.ebuild
new file mode 100644
index 000000000000..66b38f7825af
--- /dev/null
+++ b/sci-libs/nlopt/nlopt-2.2.1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/nlopt/nlopt-2.2.1.ebuild,v 1.1 2010/09/27 06:35:45 bicatali Exp $
+
+EAPI=3
+SUPPORT_PYTHON_ABIS="1"
+PYTHON_DEPEND="python? *"
+inherit eutils python
+
+DESCRIPTION="Non-linear optimization library"
+HOMEPAGE="http://ab-initio.mit.edu/nlopt/"
+SRC_URI="${HOMEPAGE}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1 MIT"
+KEYWORDS="~amd64 ~x86"
+
+SLOT="0"
+IUSE="cxx guile octave python static-libs"
+
+DEPEND="guile? ( dev-scheme/guile )
+ octave? ( sci-mathematics/octave )
+ python? ( dev-python/numpy )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ if use python; then
+ sed -i \
+ -e '/^LTLIBRARIES/s:$(pyexec_LTLIBRARIES)::g' \
+ swig/Makefile.in || die
+ echo '#!/bin/sh' > py-compile
+ fi
+}
+
+src_configure() {
+ if use octave; then
+ export OCT_INSTALL_DIR="${EPREFIX}"/usr/libexec/octave/site/oct/${CHOST}
+ export M_INSTALL_DIR="${EPREFIX}"/usr/share/octave/site/m
+ else
+ export MKOCTFILE=None
+ fi
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static) \
+ $(use_with cxx) \
+ $(use_with guile) \
+ $(use_with octave) \
+ $(use_with python)
+ use python && python_copy_sources swig
+}
+
+src_compile() {
+ default
+ if use python; then
+ compilation() {
+ emake \
+ PYTHON_CPPFLAGS="-I$(python_get_includedir)" \
+ PYTHON_LDFLAGS="$(python_get_library -l)" \
+ PYTHON_SITE_PKG="$(python_get_sitedir)" \
+ PYTHON_VERSION="$(python_get_version)" \
+ pyexecdir="$(python_get_sitedir)"
+ }
+ python_execute_function -s --source-dir swig compilation
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ if use python; then
+ installation() {
+ emake \
+ DESTDIR="${D}" \
+ pyexecdir="$(python_get_sitedir)" \
+ pythondir="$(python_get_sitedir)" \
+ install
+ }
+ python_execute_function -s --source-dir swig installation
+ python_clean_installation_image
+ fi
+
+ dodoc AUTHORS ChangeLog NEWS README
+ for r in */README; do newdoc ${r} README.$(dirname ${r}); done
+}
+
+pkg_postinst() {
+ use python && python_mod_optimize ${PN}.py
+}
+
+pkg_postrm() {
+ use python && python_mod_cleanup ${PN}.py
+}