summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2013-07-22 16:33:52 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2013-07-22 16:33:52 +0000
commit652581171408dc15ada7424d84e29d1d632690cc (patch)
tree5edf749b336b4a9997d4bf7bda172b18e4372122 /sci-libs
parentMask new binary rpi kernel image, adjust other rpi masks, fix mask timestamp (diff)
downloadgentoo-2-652581171408dc15ada7424d84e29d1d632690cc.tar.gz
gentoo-2-652581171408dc15ada7424d84e29d1d632690cc.tar.bz2
gentoo-2-652581171408dc15ada7424d84e29d1d632690cc.zip
Version bump
(Portage version: 2.2.01.22124-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/dlib/ChangeLog7
-rw-r--r--sci-libs/dlib/dlib-18.3.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/sci-libs/dlib/ChangeLog b/sci-libs/dlib/ChangeLog
index e4bc9ea417d1..23610decc354 100644
--- a/sci-libs/dlib/ChangeLog
+++ b/sci-libs/dlib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/dlib
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/dlib/ChangeLog,v 1.5 2013/02/07 05:46:33 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/dlib/ChangeLog,v 1.6 2013/07/22 16:33:52 bicatali Exp $
+
+*dlib-18.3 (22 Jul 2013)
+
+ 22 Jul 2013; Sébastien Fabbro <bicatali@gentoo.org> +dlib-18.3.ebuild:
+ Version bump
*dlib-18.0 (07 Feb 2013)
diff --git a/sci-libs/dlib/dlib-18.3.ebuild b/sci-libs/dlib/dlib-18.3.ebuild
new file mode 100644
index 000000000000..bd04a43bd159
--- /dev/null
+++ b/sci-libs/dlib/dlib-18.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/dlib/dlib-18.3.ebuild,v 1.1 2013/07/22 16:33:52 bicatali Exp $
+
+EAPI=5
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Numerical and networking C++ library"
+HOMEPAGE="http://dlib.net/"
+SRC_URI="mirror://sourceforge/dclib/${P}.tar.bz2"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="blas doc examples jpeg lapack png test X"
+
+RDEPEND="
+ blas? ( virtual/blas )
+ jpeg? ( virtual/jpeg )
+ lapack? ( virtual/lapack )
+ png? ( media-libs/libpng )
+ X? ( x11-libs/libX11 )"
+DEPEND="test? ( ${RDEPEND} )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-17.48-makefile-test.patch
+}
+
+src_test() {
+ cd dlib/test
+ emake CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS}"
+ ./test --runall || die
+}
+
+src_install() {
+ dodoc dlib/README.txt
+ rm -r dlib/{README,LICENSE}.txt dlib/test || die
+ doheader -r dlib
+ use doc && dohtml -r docs/*
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}